uart interrupt configuration on beaglebone black.

Hi All,

I am trying to enable interrupts on UART2 of beaglebone black, I am not aware of what are all the registers to be configured to work interrupts properly.

any help is appreciated.

Thanks in advance.


Hello Madhu,

I am not an expert so please take this advice with pinch of salt.
here are few steps to get you started:

1)You have to first enable the UART by modifying the uEnv.txt file in your /boot/uboot folder.

  1. reboot
  2. check dmesg by running: dmesg | grep UART
  3. From above you will get an interrupt number assigned to your respective UART.
  4. Use this to configure your ISR and etc.

Please refer TRM of AM3358 for further details on IRQ and ISR.


Hi Rathin,

Thanks for your response.!!!

I enabled interrupts for UART2 and working fine.

Thanks & regards

Dear Madhu,

It would like to request you that it would be great if you can write a brief description of what all you did and how you did it.

That would contribute a lot to other fellow travelers on the same journey in future :slight_smile:


Hi Rathin,

Yeah, I will do that…


Hi Madhu K,

Can you please describe how u enabled UART2 interrupt in BBB

Thanks and Best Regards
Krishnakanth M