UART5 clarification


I would also be very interested in this topic. I also do not see any reason why it should not work. I would like to use this port for a 485 connection, so I need RTS to enable the sender. But when I tried, it really does not work.

I tried to configure the pins with:



echo 4 > /sys/kernel/debug/omap_mux/lcd_data8


echo 24 > /sys/kernel/debug/omap_mux/lcd_data9

CTS - not needed

#echo 6 > /sys/kernel/debug/omap_mux/lcd_data14


echo 6 > /sys/kernel/debug/omap_mux/lcd_data15


Then I used a self-written program to set RTS, send some strings, clear RTS, wait for answers, etc. (It’s a M2M communication, the program itself was tested on a normal Linux host which has a 485 port, so this should work.)
Do I miss something here?
I also cross-checked by setting lcd_data15 to GPIO output and to value 1, then echoed some strings to ttyO5. These strings were actually sent to 485. Second cross-check would be using another program like minicom, but which supports some 485 mode. But I did not find anything like this yet.

So in total I see two options:

  1. The documentation mentioned above, which states UART5 would not work with RTS/CTS is wrong, and I do miss something in my application.
  2. The documentation is right and UART5 RTS simply does not work as RTS on this MCU. Perhaps this is mentioned in a device errata which I did not find yet.

Can anyone help here?