Ubuntu 20.04 / Debian bullseye + ROS

I am trying to run a recent version of ROS on Beaglebone Blue using Ubuntu 20.04 or Debian 11.3 (I’ve taken the following images from - http://repos.rcn-ee.com/):

  • bone-ubuntu-20.04.4-console-armhf-2022-05-22-4gb.img
  • bone-debian-11.3-iot-armhf-2022-05-22-4gb.img

I connected the board to the internet via wifi using ubuntu@ubuntu:~# wpa_cli -i wlan0

But no matter what image I use when I am running ubuntu@ubuntu:~$ sudo apt install ros-desktop the execution hangs in different points after the installation begins.
It looks like the following:

Get:208 http://ports.ubuntu.com focal/universe armhf libstdc++-7-dev armhf 7.5.0-6ubuntu2 [1,543 kB]                                                                                   
Get:209 http://ports.ubuntu.com focal/main armhf libboost1.71-dev armhf 1.71.0-6ubuntu6 [9,068 kB]                                                                                     
Get:210 http://ports.ubuntu.com focal/main armhf libboost-atomic1.71.0 armhf 1.71.0-6ubuntu6 [205 kB]                                                                                  
Get:211 http://ports.ubuntu.com focal/main armhf libboost-atomic1.71-dev armhf 1.71.0-6ubuntu6 [205 kB]                                                                                
Get:212 http://ports.ubuntu.com focal/main armhf libboost-chrono1.71-dev armhf 1.71.0-6ubuntu6 [220 kB]                                                                                
Get:213 http://ports.ubuntu.com focal/main armhf libboost-date-time1.71.0 armhf 1.71.0-6ubuntu6 [216 kB]                                                                               
Get:214 http://ports.ubuntu.com focal/main armhf libboost-serialization1.71.0 armhf 1.71.0-6ubuntu6 [283 kB]                                                                           
Get:215 http://ports.ubuntu.com focal/main armhf libboost-serialization1.71-dev armhf 1.71.0-6ubuntu6 [356 kB]                                                                         
Get:216 http://ports.ubuntu.com focal/main armhf libboost-date-time1.71-dev armhf 1.71.0-6ubuntu6 [229 kB]                                                                             
Get:217 http://ports.ubuntu.com focal/main armhf libboost-system1.71.0 armhf 1.71.0-6ubuntu6 [205 kB]                                                                                  
Get:218 http://ports.ubuntu.com focal/main armhf libboost-system1.71-dev armhf 1.71.0-6ubuntu6 [205 kB]                                                                                
Get:219 http://ports.ubuntu.com focal/main armhf libboost-thread1.71-dev armhf 1.71.0-6ubuntu6 [255 kB]                                                                                
Get:220 http://ports.ubuntu.com focal/main armhf libboost-thread-dev armhf [3,416 B]                                                                                   
Get:221 http://ports.ubuntu.com focal/main armhf libboost-system-dev armhf [3,536 B]                                                                                   
Get:222 http://ports.ubuntu.com focal/main armhf libdpkg-perl all 1.19.7ubuntu3 [230 kB]                                                                                               
Get:223 http://ports.ubuntu.com focal/main armhf pkg-config armhf 0.29.1-0ubuntu4 [42.6 kB]                                                                                            
Get:224 http://ports.ubuntu.com focal/universe armhf libconsole-bridge-dev armhf 0.4.4+dfsg-1build1 [6,648 B]                                                                          
Get:225 http://ports.ubuntu.com focal/universe armhf libboost-date-time-dev armhf [3,396 B]                                                                            
Get:226 http://ports.ubuntu.com focal/universe armhf libroscpp-core-dev armhf 0.6.13-1build1 [21.4 kB]                                                                                 
Get:227 http://ports.ubuntu.com focal/universe armhf ros-message-runtime armhf 0.4.12-6 [5,800 B]                                                                                      
55% [227 ros-message-runtime 4,096 B/5,800 B 71%]                                                                                                                                      

55% [227 ros-message-runtime 4,096 B/5,800 B 71%]

  • If I press Enter the last line is duplicated, which means the system is not entirely hangs
  • I am able to open another SSH session via USB, ls command works - but top is not working
  • SD card led is constantly on.
  • I thought there is a problem with SD card and replaced with another one with exactly the same result
  • It happens on Debian and on Ubuntu
  • Looks like it is happening regardless of the command - sometimes it’s getting stuck on sudo apt update also

Looks to me like some kind of Kernel problem.

Any idea?

1 Like


I know nothing about ROS now. But…once upon a time, it was kept. This would be a good project to create for the BBB or other boards from beagleboard.org.


P.S. There used to be a way to get it on the board. Maybe when it turns full at 4096, the heap needs to be altered? It may be something to look into, stack and heap! I remember I had an issue on my builds before w/ the heap allocation being too high for the 512 MB of memory. I am glad someone is trying to make this work. If time persists and you are able to keep this alive in the forums and around the community, GOOD! I can then revisit it and put in my two cents.

You may try going through the ROS/ROS2 Debian install from source steps instead of trying to install the packages from apt. I’ve done this with the Debian images for a BBAI installing ROS2 Foxy but it should work for a ROS variant.

If it continues to hang, you may consider adding a swap space or increasing the existing one since the BBs tend to have low RAM.

There used to be a BeagleBone ROS Wiki but it is quite outdate.



1 Like

Thanks everyone - looks like the board was faulty - replaced with another one and never experienced the issue.

1 Like

Hello @mirots ,

Seth here. Are you trying this idea: Docker Setup for ROS 2 — Robotics SDK Documentation ?

It is for the ROS2 implementation for the BBAI-64.


P.S. I know you were using the BBBlue but I was just wondering since you were doing ROS type things.

I just bumped into this sort of problem with big batches of activity in eMMC on my BBBlue.installing ROS is a good example of that :slight_smile: .

When I started seeing problems like you describe I noticed that the eMMC had been remounted read-only, so I ran dmesg -w in a separate ssh session to monitory kernel logs in real time and then re-ran the apt-get upgrade operation to find out why.

When I saw the write operation block errors in the kernel log so I did the standard thing when devices fail under processing load, stabilized the power.

For me it turned out that connecting a 12V 3A power input made the problem go away. I doubt my USB hub was able to keep up.

I also now have a 2S 800mAh 45C Li-Poly battery plugged in since I intend to use this as a land yacht autopilot. I have not seen any problems since.

Maybe one of the RPi high power adapters would help, The ones intended for RPi 3 boards have micro B connectors and >2.5 Ampere ratings.

1 Like