Ubuntu and Midi

I installed rcn's demo image of maverick and have updated
it to Natty through the update-manager.

I can see my usb midi device in Alsamixer, bu unlike my seperate usb
audio device cannot connect to it.

Running aconnect, gives the following error:

ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No
such file or directory
can't open sequencer

Running sudo modprobe snd_seq, gives the following:

FATAL: Module snd_seq not found.
FATAL: Error running install command for snd_seq

Does the Kernel need to be patched for midi? I'm not sure how to do

Sorry, that config wasn't currently enabled.. this if first request
i've seen for it..

patched: http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/revision/196

Follow these directions to rebuild the kernel:


Thanks for responding so quickly, unfortunately I had to install
Ubuntu Natty on my x86 to do this, and the scripts fail on the
uninstallable dependency of ncurses, so I can't build. ncurses5 in

That's strange.. On my natty build machine it works fine.. using


Ah sorry, got confused with ncurses5-base. What am I doing wrong here,
and how much space will I need approx:

sudo ./build_kernel.sh
+ Detected build host [debian-]
Using: Cross Compiler

Building for Debian Squeeze/Wheezy/Sid & Ubuntu 10.04/10.10/11.04

--2011-04-29 18:35:20-- http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.38.tar.bz2
Resolving www.kernel.org...,
Connecting to www.kernel.org||:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not

    The file is already fully retrieved; nothing to do.

--2011-04-29 18:35:20-- http://www.kernel.org/pub/linux/kernel/v2.6/patch-
Resolving www.kernel.org...,
Connecting to www.kernel.org||:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not

    The file is already fully retrieved; nothing to do.

Cleaning Up
Extracting: 2.6.38 Kernel
Applying: Patch
Starting patch.sh
bugs and trivial stuff
for_next from tmlind's tree..
dss2 from for-next
dspbridge from for-next
omap fixes
for_next from tmlind's tree..
wip patches for mainline
sakoman's patches
musb patches
micrel patches
beagle patches
igepv2 board related patches
touchbook patches
omap4 related patches
merge in ti sgx modules
patch.sh ran successful
make: arm-linux-gnueabi-gcc: Command not found
  HOSTCC scripts/basic/fixdep
  HOSTCC scripts/basic/docproc
  HOSTCC scripts/kconfig/conf.o
  HOSTCC scripts/kconfig/kxgettext.o
  HOSTCC scripts/kconfig/lxdialog/checklist.o
  HOSTCC scripts/kconfig/lxdialog/inputbox.o
  HOSTCC scripts/kconfig/lxdialog/menubox.o
  HOSTCC scripts/kconfig/lxdialog/textbox.o
  HOSTCC scripts/kconfig/lxdialog/util.o
  HOSTCC scripts/kconfig/lxdialog/yesno.o
  HOSTCC scripts/kconfig/mconf.o
  SHIPPED scripts/kconfig/zconf.tab.c
  SHIPPED scripts/kconfig/lex.zconf.c
  SHIPPED scripts/kconfig/zconf.hash.c
  HOSTCC scripts/kconfig/zconf.tab.o
  HOSTLD scripts/kconfig/mconf
scripts/kconfig/mconf Kconfig

*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

make -j5 ARCH=arm LOCALVERSION=-x3.1 CROSS_COMPILE="ccache arm-linux-
ccache: FATAL: Could not find compiler "arm-linux-gnueabi-gcc" in PATH
  HOSTLD scripts/kconfig/conf
scripts/kconfig/conf --silentoldconfig Kconfig
ccache: FATAL: Could not find compiler "arm-linux-gnueabi-gcc" in PATH
  CHK include/linux/version.h
  UPD include/linux/version.h
  HOSTCC scripts/kallsyms
  HOSTCC scripts/pnmtologo
  CC scripts/mod/empty.o
ccache: FATAL: Could not find compiler "arm-linux-gnueabi-gcc" in PATH
make[2]: *** [scripts/mod/empty.o] Error 1
make[1]: *** [scripts/mod] Error 2
make[1]: *** Waiting for unfinished jobs....
  HOSTCC scripts/genksyms/genksyms.o
  HOSTCC scripts/selinux/genheaders/genheaders
  CHK include/generated/utsrelease.h
  UPD include/generated/utsrelease.h
  SHIPPED scripts/genksyms/lex.c
  HOSTCC scripts/selinux/mdp/mdp
  SHIPPED scripts/genksyms/parse.h
  Generating include/generated/mach-types.h
  SHIPPED scripts/genksyms/keywords.c
  SHIPPED scripts/genksyms/parse.c
  HOSTCC scripts/genksyms/lex.o
  HOSTCC scripts/genksyms/parse.o
  CC kernel/bounds.s
ccache: FATAL: Could not find compiler "arm-linux-gnueabi-gcc" in PATH
make[1]: *** [kernel/bounds.s] Error 1
make: *** [prepare0] Error 2
make: *** Waiting for unfinished jobs....
  HOSTLD scripts/genksyms/genksyms
make: *** [scripts] Error 2

Looks like your missing the cross compiler.. The script doesn't force
one compiler, since many can be used..

In ubuntu you can pull the linaro arm cross compiler via: sudo apt-get
install gcc-4.5-arm-linux-gnueabi


That's what I thought, but I knew I had already installed it, but
stupidly 4.4 as well as 4.5. I removed 4.4, same results with only
4.5, rebooted - same results.

Should this be the exact line 22 in system,sh:


is the last - wrong, or does it need a version number?

double check that "arm-linux-gnueabi-gcc -v" actually returns something..

Then: CC=arm-linux-gnueabi- would be correct..


With 4.5 installed:

arm-linux-gnueabi-gcc -v
The program 'arm-linux-gnueabi-gcc' can be found in the following
* gcc-4.4-arm-linux-gnueabi
* gcc-arm-linux-gnueabi

I then uninstalled 4.5, installed 4.4, but still have the same error!
Something is wrong with my Ubuntu installation, unfortunately don't
think I'll have time to check this, will have to wait for mainline.

Thanks again though.

crap, i see what they did..

maverick: arm-linux-gnueabi-gcc
natty: arm-linux-gnueabi-gcc-4.5

dumbest change ever.. :wink:

In natty:

sudo apt-get install gcc-arm-linux-gnueabi


Yeah, I tried that - thanks, and it would have worked, had my x86 usb
install stick not crapped out on me part way through the script -
*jumps up and down on useless piece of yellow Kingston plastic* Will
try again this weekend.

Tried again, and it works - thank you!

Noticed that there are no instructions provided for building the kernel in the Ubuntu wiki like there is on the Debian wiki. Is there a script to run that allows the kernel to be customised before running build_kernel.sh? Under great pressure to get the BBB MIDI organ finished in time for Xmas. Ended up being caught off guard by the sequencer not found issue which pops up when running aseqdump -l (lists all MIDI devices connected and recognised by Linux which is part of the alsa-utils package). Did the testing on a Linux desktop thinking that I was all set to do a similar setup on the BBB. Unfortunately Murphy’s law kicked in.

So incredibly easy for good plans to come unravelled in a blink of an eye.

Does kernel 3.17 include MIDI support?