Ubuntu - Flash - How 2?

Hi folks,

I know, its a beginner question and I should read all the manuals and docus, but I’m getting lost. I thought I’ll start from the scratch, install a prebuilt-kernel for Ubuntu (BBB A6) and therefore followed to some extend:


Downloaded the image from


flashed it with Win32DiskManager with success. Inserting the SD-card and nothing happens:

- Only the blue light next to the power lights, none more
- holding the button next to the SD-card, plugin the power cable, lights still remain with the single blue line above mentioned
- trying to boot without SD-card fails, only the blue light
- inserting an *old* uSD-image worx cause now the 4 lights blink differently

What I wanted to achieve? Somehow to flash an Ubuntu image from uSD to eMMC - preferable my existing one and than be able to boot from eMMC despite uSD-card is available.

Flashing failed for some reasons cause I get always the response 'Your foo is too weak'. 

Any ideas what is the best way to proceed? Start from the scratch? Try to the the flasher running?



ubuntu@arm:~$ sudo /bin/bash ./bbb-eMMC-flasher-eewiki-12mb.sh
Valid EEPROM header found

To turn a "non-flasher" to a "flasher"



Hm’, IFFF I understand it correctly, than I should stick to the new image and try to flash it. OK, fine, BUTTT

The system doesn’t start :frowning:

If press the button next to the SD, insert the power, than I get just one blue light as described
If I don’t press any buttons, just plugin than I from the 4 lights 2 lights are constantly on, namely the two outer lights

Any ideas what I should do to get it booting?

Do you have a usb serial debug cable?


somewhere I should have it. Tried it once and I didn’t figure out how to get it working. I gave up - not paying much thoughts expect ‘Well I’ll probably won’t use it.’

So, what to do with the cable?

plug it in,

fire up terraterm/gtkterm/etc at 115200 8 n 1 and shows us what
happens on power up


Hm’, I plugged in and I am getting stuck like the last time :frowning:

The cable is connected (green to SD-card side and black to J1). The COM is recognized by Win8.1, but I have had to change to 115200.

Launching ttpro I can connect to COM6 at 115200. In the window the cursor remains blinking, no change. Keyboard doesn’t seem to have much influence.

I tried the cable as well the opposite way, but didn’t change anything. Leaving plugged in and pressing the reset-button, doesn’t show up anything in the existing TT-session.

Hints? Ideas?

You "should" either get random text from something booting or a stream
of "CCCCC's"

If you get neither, either the serial is plugged in wrong, terra term
doesn't have the correct port.


I get none of them. I tried as well reinstall the Win drivers, as well as Putty-access. Nope, doesn’t work. I would say its the image which hangs, but no idea where and what.

Other ideas?

Is it possible to flash the existing image? I posted my attempt at the very beginning but somehow this failed. Ideas for this part?

Make sure hardware control flow are set to “none” in both puTTY and device manager for the COM port. Then make sure if using a serial debug cable as you seem to be saying you are. That TX on cable is connected to RX on J1, and RX on cable is connected to TX on J1.NO idea what your experience level is here so I’ll just mention that.

And ground on J1 of course is denoted by the white dot on the board.

Just to make things clearer, this post I’m going to link to has an image of the BBB with J1 pins marked appropriately. The rest of the post will probably not be of much use for you, as i made this last year as a demonstration on how to hack an MSP430 Launchpad into acting as a “poor mans” serial debug device.


Thx for the hints. Since I tried already many ways with the serial cable I concluded I throw in the towel. Especially since I could flash Debian straight away. I have other problems, but seems resolvable…

The link looks nice reg. How to hack :wink: