Ubuntu on Beaglebone

Hi,

I am trying to install Ubuntu according to
http://www.instructables.com/id/BeagleBone-Ubuntu-OS-LXDE-GUI/?ALLSTEPS

on a SD-Card and get this on the serial console while booting (the
heartbeat LED go into nervously flashing after this...):
U-Boot 2011.09-dirty (Feb 27 2012 - 10:01:37)

I2C: ready
DRAM: 256 MiB
No daughter card present
NAND: HW ECC Hamming Code selected
No NAND device found!!!
0 MiB
MMC: OMAP SD/MMC: 0
*** Warning - readenv() failed, using default environment

Net: cpsw
Hit any key to stop autoboot: 0
SD/MMC found on device 0
reading uEnv.txt

** Unable to read "uEnv.txt" from mmc 0:1 **
reading uImage

2642856 bytes read
## Booting kernel from Legacy Image at 80007fc0 ...
   Image Name: Linux
   Image Type: ARM Linux Kernel Image (uncompressed)
   Data Size: 2642792 Bytes = 2.5 MiB
   Load Address: 80008000
   Entry Point: 80008000
   Verifying Checksum ... OK
   XIP Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.2.23-psp18 (root@panda-es-b1-1gb) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #1 Fri Jul 27 20:46:04 UTC 2012
[ 0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c53c7d
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ 0.000000] Machine: am335xevm
[ 0.000000] Memory policy: ECC disabled, Data cache writeback
[ 0.000000] AM335X ES1.0 (sgx neon )
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 65024
[ 0.000000] Kernel command line: console=ttyO0,115200n8 root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait ip=none
[ 0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] allocated 1048576 bytes of page_cgroup
[ 0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[ 0.000000] Memory: 256MB = 256MB total
[ 0.000000] Memory: 251272k/251272k available, 10872k reserved, 0K highmem
[ 0.000000] Virtual kernel memory layout:
[ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
[ 0.000000] fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
[ 0.000000] vmalloc : 0xd0800000 - 0xff000000 ( 744 MB)
[ 0.000000] lowmem : 0xc0000000 - 0xd0000000 ( 256 MB)
[ 0.000000] modules : 0xbf000000 - 0xc0000000 ( 16 MB)
[ 0.000000] .text : 0xc0008000 - 0xc0699000 (6724 kB)
[ 0.000000] .init : 0xc0699000 - 0xc06d7000 ( 248 kB)
[ 0.000000] .data : 0xc06d8000 - 0xc0720360 ( 289 kB)
[ 0.000000] .bss : 0xc0720384 - 0xc0761d1c ( 263 kB)
[ 0.000000] NR_IRQS:410 nr_irqs:410 410
[ 0.000000] IRQ: Found an INTC at 0xfa200000 (revision 5.0) with 128 interrupts
[ 0.000000] Total of 128 interrupts on 1 active controller
[ 0.000000] OMAP clockevent source: GPTIMER2 at 24000000 Hz
[ 0.000000] OMAP clocksource: GPTIMER1 at 32768 Hz
[ 0.000000] sched_clock: 32 bits at 32kHz, resolution 30517ns, wraps every 131071999ms
[ 0.000000] Console: colour dummy device 80x30
[ 0.000152] Calibrating delay loop... 718.02 BogoMIPS (lpj=3590144)
[ 0.058563] pid_max: default: 32768 minimum: 301
[ 0.058685] Security Framework initialized
[ 0.058746] AppArmor: AppArmor initialized
[ 0.058807] Mount-cache hash table entries: 512
[ 0.059204] Initializing cgroup subsys cpuacct
[ 0.059234] Initializing cgroup subsys memory
[ 0.059265] Initializing cgroup subsys devices
[ 0.059295] Initializing cgroup subsys freezer
[ 0.059295] Initializing cgroup subsys blkio
[ 0.059326] Initializing cgroup subsys perf_event
[ 0.059387] CPU: Testing write buffer coherency: ok
[ 0.060363] devtmpfs: initialized
[ 0.079986] omap_hwmod: gfx: failed to hardreset
[ 0.096282] omap_hwmod: pruss: failed to hardreset
[ 0.096984] print_constraints: dummy:
[ 0.097229] NET: Registered protocol family 16
[ 0.098327] OMAP GPIO hardware version 0.1
[ 0.099395] omap_mux_init: Add partition: #1: core, flags: 0
[ 0.100616] omap_i2c.1: alias fck already exists
[ 0.101013] hw-breakpoint: debug architecture 0x4 unsupported.
[ 0.101165] omap2_mcspi.1: alias fck already exists
[ 0.101287] omap2_mcspi.2: alias fck already exists
[ 0.101379] omap_init_sham: platform not supported
[ 0.101379] omap_init_aes: platform not supported
[ 0.101440] edma.0: alias fck already exists
[ 0.101470] edma.0: alias fck already exists
[ 0.101470] edma.0: alias fck already exists
[ 0.101562] cape: pcm register
[ 0.109130] bio: create slab <bio-0> at 0
[ 0.110412] SCSI subsystem initialized
[ 0.111267] usbcore: registered new interface driver usbfs
[ 0.111419] usbcore: registered new interface driver hub
[ 0.111572] usbcore: registered new device driver usb
[ 0.111877] registerd cppi-dma Intr @ IRQ 17
[ 0.111907] Cppi41 Init Done Qmgr-base(d083a000) dma-base(d0838000)
[ 0.111907] Cppi41 Init Done
[ 0.111938] musb-ti81xx musb-ti81xx: musb0, board_mode=0x13, plat_mode=0x3
[ 0.112091] musb-ti81xx musb-ti81xx: musb1, board_mode=0x13, plat_mode=0x1
[ 0.112548] omap_i2c omap_i2c.1: bus 1 rev2.4.0 at 100 kHz
[ 0.113250] tps65910 1-002d: could not be detected
[ 0.113708] Advanced Linux Sound Architecture Driver Version 1.0.24.
[ 0.114257] NetLabel: Initializing
[ 0.114288] NetLabel: domain hash size = 128
[ 0.114288] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.114349] NetLabel: unlabeled traffic allowed by default
[ 0.114379] Switching to clocksource gp timer
[ 0.114593] AppArmor: AppArmor Filesystem Enabled
[ 0.124389] musb-hdrc: version 6.0, ?dma?, otg (peripheral+host)
[ 0.124633] musb-hdrc musb-hdrc.0: dma type: dma-cppi41
[ 0.124816] MUSB0 controller's USBSS revision = 4ea20800
[ 0.125549] musb-hdrc musb-hdrc.0: USB OTG mode controller at d081c000 using DMA, IRQ 18
[ 0.125823] musb-hdrc musb-hdrc.1: dma type: dma-cppi41
[ 0.125946] MUSB1 controller's USBSS revision = 4ea20800
[ 0.126373] musb-hdrc musb-hdrc.1: MUSB HDRC host driver
[ 0.126464] musb-hdrc musb-hdrc.1: new USB bus registered, assigned bus number 1
[ 0.126586] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 0.126617] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.126647] usb usb1: Product: MUSB HDRC host driver
[ 0.126647] usb usb1: Manufacturer: Linux 3.2.23-psp18 musb-hcd
[ 0.126647] usb usb1: SerialNumber: musb-hdrc.1
[ 0.127258] hub 1-0:1.0: USB hub found
[ 0.127288] hub 1-0:1.0: 1 port detected
[ 0.127746] musb-hdrc musb-hdrc.1: USB Host mode controller at d081e800 using DMA, IRQ 19
[ 0.128173] NET: Registered protocol family 2
[ 0.128479] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.129272] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.129455] TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.129547] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.129547] TCP reno registered
[ 0.129577] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.129577] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.129913] NET: Registered protocol family 1
[ 0.130310] RPC: Registered named UNIX socket transport module.
[ 0.130310] RPC: Registered udp transport module.
[ 0.130310] RPC: Registered tcp transport module.
[ 0.130340] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.132171] audit: initializing netlink socket (disabled)
[ 0.132232] type=2000 audit(0.110:1): initialized
[ 0.290222] VFS: Disk quotas dquot_6.5.2
[ 0.290344] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.291900] nfs4filelayout_init: NFSv4 File Layout Driver Registering...
[ 0.291961] fuse init (API version 7.17)
[ 0.292602] Btrfs loaded
[ 0.292633] msgmni has been set to 490
[ 0.293762] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[ 0.293884] io scheduler noop registered
[ 0.293884] io scheduler deadline registered
[ 0.293945] io scheduler cfq registered (default)
[ 0.295104] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 0.296203] omap_uart.0: ttyO0 at MMIO 0x44e09000 (irq = 72) is a OMAP UART0
[ 0.990966] console [ttyO0] enabled
[ 0.995208] omap_uart.1: ttyO1 at MMIO 0x48022000 (irq = 73) is a OMAP UART1
[ 1.002929] omap_uart.2: ttyO2 at MMIO 0x48024000 (irq = 74) is a OMAP UART2
[ 1.010620] omap_uart.3: ttyO3 at MMIO 0x481a6000 (irq = 44) is a OMAP UART3
[ 1.018280] omap_uart.4: ttyO4 at MMIO 0x481a8000 (irq = 45) is a OMAP UART4
[ 1.025939] omap_uart.5: ttyO5 at MMIO 0x481aa000 (irq = 46) is a OMAP UART5
[ 1.040374] brd: module loaded
[ 1.047515] loop: module loaded
[ 1.050872] at24 1-0051: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 1.114959] No daughter card found
[ 1.118560] at24 1-0050: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 1.133758] Board config.name: A335BONE00A62712BB000768
[ 1.139221] Board name: A335BONE
[ 1.142578] Board version: 00A6
[ 1.145843] The board is a AM335x Beaglebone.
[ 1.151031] tps65217 1-0024: TPS65217 ID 0xf version 1.1
[ 1.158386] print_constraints: DCDC1: 900 <--> 1800 mV at 1800 mV
[ 1.166656] print_constraints: DCDC2: 900 <--> 3300 mV at 1275 mV
[ 1.174896] print_constraints: DCDC3: 900 <--> 1500 mV at 1100 mV
[ 1.183105] print_constraints: LDO1: 1000 <--> 3300 mV at 1800 mV
[ 1.191345] print_constraints: LDO2: 900 <--> 3300 mV at 3300 mV
[ 1.199493] print_constraints: LDO3: 1800 <--> 3300 mV at 3300 mV
[ 1.207733] print_constraints: LDO4: 1800 <--> 3300 mV at 3300 mV
[ 1.214660] cpufreq: disabling OPPTURBO (720mhz)
[ 1.219848] omap_i2c.3: alias fck already exists
[ 1.225036] omap_i2c omap_i2c.3: bus 3 rev2.4.0 at 100 kHz
[ 1.231475] omap_hsmmc.0: alias fck already exists
[ 1.239562] at24 3-0054: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 1.269958] BeagleBone cape EEPROM: found eeprom at address 0x54
[ 1.276245] BeagleBone cape: Beagleboardtoys. BeagleBone LCD7 CAPE............Beagleboardtoys., revision 00A2
[ 1.286590] BeagleBone cape partnumber: BB-BONE-LCD7-01.
[ 1.292114] BeagleBone cape: initializing LCD cape
[ 1.297546] da8xx_lcdc.0: alias fck already exists
[ 1.302825] da8xx_lcdc da8xx_lcdc.0: GLCD: Found TFC_S9700RTWV35TR_01B panel
[ 1.321197] Console: switching to colour frame buffer device 100x30
[ 1.334655] BeagleBone cape: initializing LCD cape touchscreen
[ 1.340759] TSC connected to BeagleBone
[ 1.345153] BeagleBone cape: Registering PWM backlight for LCD cape
[ 1.351684] BeagleBone cape: Registering gpio-keys for LCD cape
[ 1.358215] at24 3-0055: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 1.425018] BeagleBone cape EEPROM: could not read eeprom at address 0x55
[ 1.432159] at24 3-0056: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 1.494995] BeagleBone cape EEPROM: could not read eeprom at address 0x56
[ 1.502105] at24 3-0057: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 1.565002] BeagleBone cape EEPROM: could not read eeprom at address 0x57
[ 1.572082] BeagleBone cape: initializing w1-gpio
[ 1.577148] w1-gpio connected to P8_6
[ 1.581939] CAN device driver interface
[ 1.585998] CAN bus driver for Bosch D_CAN controller 1.0
[ 1.635009] davinci_mdio davinci_mdio.0: davinci mdio revision 1.6
[ 1.641479] davinci_mdio davinci_mdio.0: detected phy mask fffffffe
[ 1.648986] davinci_mdio.0: probed
[ 1.652526] davinci_mdio davinci_mdio.0: phy[0]: device 0:00, driver SMSC LAN8710/LAN8720
[ 1.661254] usbcore: registered new interface driver cdc_ether
[ 1.667419] usbcore: registered new interface driver rndis_host
[ 1.673614] cdc_ncm: 04-Aug-2011
[ 1.677062] usbcore: registered new interface driver cdc_ncm
[ 1.683044] Initializing USB Mass Storage driver...
[ 1.688262] usbcore: registered new interface driver usb-storage
[ 1.694519] USB Mass Storage support registered.
[ 1.699462] usbcore: registered new interface driver libusual
[ 1.705566] gadget: using random self ethernet address
[ 1.711029] gadget: using random host ethernet address
[ 1.717315] usb0: MAC 4a:77:87:cf:f4:83
[ 1.721313] usb0: HOST MAC 72:d8:83:fe:c1:5c
[ 1.725860] gadget: Ethernet Gadget, version: Memorial Day 2008
[ 1.732116] gadget: g_ether ready
[ 1.735687] musb-hdrc musb-hdrc.0: MUSB HDRC host driver
[ 1.741302] musb-hdrc musb-hdrc.0: new USB bus registered, assigned bus number 2
[ 1.749176] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[ 1.756256] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 1.763793] usb usb2: Product: MUSB HDRC host driver
[ 1.768981] usb usb2: Manufacturer: Linux 3.2.23-psp18 musb-hcd
[ 1.775177] usb usb2: SerialNumber: musb-hdrc.0
[ 1.780548] hub 2-0:1.0: USB hub found
[ 1.784484] hub 2-0:1.0: 1 port detected
[ 1.789428] mousedev: PS/2 mouse device common for all mice
[ 1.796234] omap_rtc omap_rtc: rtc core: registered omap_rtc as rtc0
[ 1.802886] omap_rtc: already running
[ 1.806823] i2c /dev entries driver
[ 1.810852] Linux media interface: v0.10
[ 1.815093] lirc_dev: IR Remote Control driver registered, major 249
[ 1.821807] Driver for 1-wire Dallas network protocol.
[ 1.828491] OMAP Watchdog Timer Rev 0x01: initial timeout 60 sec
[ 1.840301] cpuidle: using governor ladder
[ 1.844787] cpuidle: using governor menu
[ 1.851989] usbcore: registered new interface driver usbhid
[ 1.857879] usbhid: USB HID core driver
[ 1.862976] usbcore: registered new interface driver snd-usb-6fire
[ 1.870056] ALSA device list:
[ 1.873168] No soundcards found.
[ 1.877960] TCP cubic registered
[ 1.881500] NET: Registered protocol family 10
[ 1.889617] NET: Registered protocol family 17
[ 1.894470] can: controller area network core (rev 20090105 abi 8)
[ 1.901123] NET: Registered protocol family 29
[ 1.905822] can: raw protocol (rev 20090105)
[ 1.910369] Registering the dns_resolver key type
[ 1.915374] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 3
[ 1.923370] ThumbEE CPU extension supported.
[ 1.927917] mux: Failed to setup hwmod io irq -22
[ 1.933593] Power Management for AM33XX family
[ 1.944000] registered taskstats version 1
[ 1.948730] Detected MACID=d4:94:a1:99:9b:82
[ 1.957275] input: gpio-keys as /devices/platform/gpio-keys/input/input0
[ 1.964752] omap_rtc omap_rtc: setting system clock to 2000-01-01 05:38:35 UTC (946705115)
[ 1.974304] Waiting for root device /dev/mmcblk0p2...
[ 2.015838] mmc0: host does not support reading read-only switch. assuming write-enable.
[ 2.026245] mmc0: new high speed SDHC card at address b368
[ 2.032623] mmcblk0: mmc0:b368 TF16G 14.8 GiB
[ 2.039062] mmcblk0: p1 p2
[ 2.103973] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[ 2.112579] VFS: Mounted root (ext4 filesystem) readonly on device 179:2.
[ 2.122497] devtmpfs: mounted
[ 2.126220] Freeing init memory: 248K
[ 2.224578] gadget: high-speed config #1: CDC Ethernet (ECM)
[ 2.410400] init: Failed to create pty - disabling logging for job
[ 2.425567] init: Temporary process spawn error: No such file or directory
[ 2.480255] init: Failed to create pty - disabling logging for job
[ 2.505767] init: Temporary process spawn error: No such file or directory
[ 2.518585] init: Failed to create pty - disabling logging for job
[ 2.535736] init: Temporary process spawn error: No such file or directory
[ 2.561279] init: Failed to create pty - disabling logging for job
[ 2.575561] init: Temporary process spawn error: No such file or directory
[ 2.664978] init: ureadahead main process (55) terminated with status 5
[ 2.886169] init: Failed to create pty - disabling logging for job
[ 2.892944] init: Temporary process spawn error: No such file or directory
[ 2.947143] init: Failed to create pty - disabling logging for job
[ 2.953887] init: Temporary process spawn error: No such file or directory
[ 3.087585] init: Failed to create pty - disabling logging for job
[ 3.094360] init: Temporary process spawn error: No such file or directory
[ 3.230590] init: Failed to create pty - disabling logging for job
[ 3.245910] init: Temporary process spawn error: No such file or directory
[ 3.272399] init: Failed to create pty - disabling logging for job
[ 3.285858] init: Temporary process spawn error: No such file or directory
[ 3.312774] init: Failed to create pty - disabling logging for job
[ 3.325866] init: Temporary process spawn error: No such file or directory
[ 3.903442] init: Failed to create pty - disabling logging for job
[ 3.926147] init: Temporary process spawn error: No such file or directory
[ 3.940246] init: Failed to create pty - disabling logging for job
[ 3.966308] init: Temporary process spawn error: No such file or directory
[ 4.016754] init: Failed to create pty - disabling logging for job
[ 4.023529] init: Temporary process spawn error: No such file or directory
[ 4.130218] init: Failed to create pty - disabling logging for job
[ 4.258514] init: Failed to create pty - disabling logging for job
[ 4.316162] init: Failed to create pty - disabling logging for job
[ 4.375549] init: Failed to create pty - disabling logging for job
[ 5.011932] init: Failed to create pty - disabling logging for job
[ 5.057891] init: Failed to create pty - disabling logging for job
[ 5.112884] init: Failed to create pty - disabling logging for job
[ 5.253112] init: Failed to create pty - disabling logging for job
[ 5.310699] init: Failed to create pty - disabling logging for job

What is going on here? Is mz beaglebone damaged?

Thank you very much in advance for any help!
Best regards,
mcc

Hi,

I am trying to install Ubuntu according to
http://www.instructables.com/id/BeagleBone-Ubuntu-OS-LXDE-GUI/?ALLSTEPS

on a SD-Card and get this on the serial console while booting (the
heartbeat LED go into nervously flashing after this...):
U-Boot 2011.09-dirty (Feb 27 2012 - 10:01:37)

I2C: ready
DRAM: 256 MiB
No daughter card present
NAND: HW ECC Hamming Code selected
No NAND device found!!!
0 MiB
MMC: OMAP SD/MMC: 0
*** Warning - readenv() failed, using default environment

Net: cpsw
Hit any key to stop autoboot: 0
SD/MMC found on device 0
reading uEnv.txt

** Unable to read "uEnv.txt" from mmc 0:1 **
reading uImage

This is a little odd, any chance can you 'rerun' the setup_sdcard.sh
script and share the terminal log with me.. As it looks like the
image wasn't flashed correctly for some odd reason..

[ 2.410400] init: Failed to create pty - disabling logging for job
[ 2.425567] init: Temporary process spawn error: No such file or directory

Does this go away when you power it via the DC jack? vs the otg connector?

Regards,

Robert Nelson <robertcnelson@gmail.com> [12-09-01 15:16]:

> Hi,
>
> I am trying to install Ubuntu according to
> http://www.instructables.com/id/BeagleBone-Ubuntu-OS-LXDE-GUI/?ALLSTEPS
>
> on a SD-Card and get this on the serial console while booting (the
> heartbeat LED go into nervously flashing after this...):
> U-Boot 2011.09-dirty (Feb 27 2012 - 10:01:37)
>
> I2C: ready
> DRAM: 256 MiB
> No daughter card present
> NAND: HW ECC Hamming Code selected
> No NAND device found!!!
> 0 MiB
> MMC: OMAP SD/MMC: 0
> *** Warning - readenv() failed, using default environment
>
> Net: cpsw
> Hit any key to stop autoboot: 0
> SD/MMC found on device 0
> reading uEnv.txt
>
> ** Unable to read "uEnv.txt" from mmc 0:1 **
> reading uImage

This is a little odd, any chance can you 'rerun' the setup_sdcard.sh
script and share the terminal log with me.. As it looks like the
image wasn't flashed correctly for some odd reason..

> [ 2.410400] init: Failed to create pty - disabling logging for job
> [ 2.425567] init: Temporary process spawn error: No such file or directory

Does this go away when you power it via the DC jack? vs the otg connector?

Regards,

--
Robert Nelson
http://www.rcn-ee.com/

-- To join: http://beagleboard.org/discuss
To unsubscribe from this group, send email to:
beagleboard+unsubscribe@googlegroups.com
Frequently asked questions: http://beagleboard.org/faq

Hi Robert,

my setup is a beaglebone A6 attached to LCD7 cape.
I feed power normally via the LCD7 cape. When using
serial over USB, power is also fed via usb but blocked
by the inner logic of the bone...

Thank you very mch for your help in advance!
Best regards,
mcc

here is the logfile:

    Script started on Sat Sep 1 15:26:31 2012
#solfire:BeagleBoneOSs/ubuntu-12.04-r5-minimal-armhf-2012-07-29>.
    ./setup_sdcard.sh --mmc /dev/sdb --uboot bone

I see...
fdisk -l:
Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
Disk /dev/sdb: 15.9 GB, 15943598080 bytes

mount:
/dev/root on / type ext4 (rw,noatime,commit=0)
devpts on /dev/pts type devpts (rw,relatime,gid=4,mode=622)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda1 on /boot type ext2 (rw,noatime)
/dev/sda5 on /tmp type ext4 (rw,commit=0)
/dev/sda6 on /home type ext4 (rw,commit=0)
/dev/sda7 on /home/user/data/pools/pool00 type ext4 (rw,noatime,commit=0)
/dev/sda8 on /home/user/data/pools/pool01 type ext4 (rw,noatime,commit=0)
/dev/sda9 on /home/user/data/pools/pool02 type ext4 (rw,noatime,commit=0)
/dev/sda10 on /home/user/data/pools/pool03 type ext4 (rw,noatime,commit=0)
/dev/sda3 on /home/user/data/pools/pool04 type ext4 (rw,noatime,commit=0)
/dev/sda12 on /home/user/data/pools/pool05 type ext4 (rw,noatime,commit=0)

Are you 100% sure, on selecting [/dev/sdb] (y/n)? y

Debug: ARM rootfs: armel-rootfs-201207291026.tar
Debug: image has initrd.img: HAS_INITRD=1

Downloading Device's Bootloader

Hi Robert,

my setup is a beaglebone A6 attached to LCD7 cape.
I feed power normally via the LCD7 cape. When using
serial over USB, power is also fed via usb but blocked
by the inner logic of the bone...

Debug: Contents of Boot Partition
-----------------------------
total 8.2M
-rw-r--r-- 1 root root 138 Sep 1 15:27 SOC.sh
-rw-r--r-- 1 root root 2.8M Sep 1 15:27 initrd.img
drwxr-xr-x 2 root root 4.0K Sep 1 15:27 tools
-rw-r--r-- 1 root root 746 Sep 1 15:27 uEnv.txt
-rw-r--r-- 1 root root 2.8M Sep 1 15:27 uInitrd
-rwxr-xr-x 1 root root 2.6M Sep 1 15:27 zImage
-----------------------------
umount: /tmp/tmp.eqHxWQ3aYI/disk: not mounted

#solfire:pool01/BeagleBoneOSs>ls -l ./mnt1 ; echo ;ls -l ./mnt2
total 2848
-rwxr-xr-x 1 root root 37135 2012-09-01 15:27 MLO
drwxr-xr-x 2 root root 2048 2012-09-01 15:27 backup
-rwxr-xr-x 1 root root 230308 2012-09-01 15:27 u-boot.img
-rwxr-xr-x 1 root root 2642856 2012-09-01 15:27 uImage

Now that's strange... For some reason, half the files never actually
made it to the boot partition...

What OS/Distro are you running?

Regards,

Robert Nelson <robertcnelson@gmail.com> [12-09-01 15:56]:

> Hi Robert,
>
> my setup is a beaglebone A6 attached to LCD7 cape.
> I feed power normally via the LCD7 cape. When using
> serial over USB, power is also fed via usb but blocked
> by the inner logic of the bone...

> Debug: Contents of Boot Partition
> -----------------------------
> total 8.2M
> -rw-r--r-- 1 root root 138 Sep 1 15:27 SOC.sh
> -rw-r--r-- 1 root root 2.8M Sep 1 15:27 initrd.img
> drwxr-xr-x 2 root root 4.0K Sep 1 15:27 tools
> -rw-r--r-- 1 root root 746 Sep 1 15:27 uEnv.txt
> -rw-r--r-- 1 root root 2.8M Sep 1 15:27 uInitrd
> -rwxr-xr-x 1 root root 2.6M Sep 1 15:27 zImage
> -----------------------------
> umount: /tmp/tmp.eqHxWQ3aYI/disk: not mounted

> #solfire:pool01/BeagleBoneOSs>ls -l ./mnt1 ; echo ;ls -l ./mnt2
> total 2848
> -rwxr-xr-x 1 root root 37135 2012-09-01 15:27 MLO
> drwxr-xr-x 2 root root 2048 2012-09-01 15:27 backup
> -rwxr-xr-x 1 root root 230308 2012-09-01 15:27 u-boot.img
> -rwxr-xr-x 1 root root 2642856 2012-09-01 15:27 uImage

Now that's strange... For some reason, half the files never actually
made it to the boot partition...

What OS/Distro are you running?

Regards,

--
Robert Nelson
http://www.rcn-ee.com/

-- To join: http://beagleboard.org/discuss
To unsubscribe from this group, send email to:
beagleboard+unsubscribe@googlegroups.com
Frequently asked questions: http://beagleboard.org/faq

Hi Robert,

I am using Gentoo Linux, which I normally update on a daily basis.
Would it help to untar the rootfs.tar and copy the file via
(as root) cp -avf * <target mountpoint>/. after the script has run?
The SD card has 16GB by the way...

Best regards,
mcc