Ubuntu on Bealeboard

I need know how Install ubuntu in beagleboard Rev C3 because I
followed the steps that are in http://elinux.org/BeagleBoardUbuntu
and not been posible make it in my Beagle. Please help me



Ditto for me. I started with 10.10 and did an upgrade to 11.04.
# ssh -X g3vbv
root@g3vbv's password:
Welcome to Ubuntu 11.04 (GNU/Linux 3.1.0-rc7-d3 armv7l)

  * Documentation: https://help.ubuntu.com/

Last login: Sun Sep 25 01:08:59 2011 from slipstream.site


After fighting with following the Beagle elinux builds it was this that worked for me: https://wiki.ubuntu.com/ARM/OmapNetbook

I downloaded that Win32ImageWriter and after a half an hour or so, I had a working SD that boots Ubuntu Natty 11.04 like a dream on Beagleboard Rev C2.


hi dear friends

i have a question abount running ubuntu natty
i wrote raw image to sd card and with minicom i tried to start.

On a serial console connected to the system, I TRIED to halt any autoboot script and type setenv bootcmd ‘mmc init;fatload mmc 0 0x82000000 boot.scr;source 0x82000000’; setenv autostart yes; saveenv; boot the board but i cant enter any character from keyboard. do i need to have any process to do before??


Did you set flow control in minicom?



i saw that the problem is about db9 cable. it is taking the data but not sending, so after change Tx channel send data correctly

another question about installing ubuntu:

when i write: setenv bootcmd ‘mmc init;fatload mmc 0 0x82000000 boot.scr;source 0x82000000’;
i got error: Writing to Nand… done Usage: mmcinit - init mmc card ** Unable to use mmc 0:1 for fatload **

when i write: mmcinit instead of mmc init
i got error like that: Writing to Nand… done reading boot.scr ** Unable to read “boot.scr” from mmc 0:1 **

anyone has any suggestion?(U-Boot 2009.01-dirty (Feb 19 2009 - 12:22:31)) should i update u-boot