Ubuntu on BegleBoard:Key board and mouse not working..Help needed urgently

Hi All,
   I have a question regarding fat32 content for Ubuntu distribution
on beagleboard .As specified in http://elinux.org/BeagleBoardUbuntu I
copied uImage(just Uimage nothing else) in fat32 and rootfs in
ext3 .After booting it ubuntu screen apprears but it keyboard and
mouse are not working.

Can any one please provide me files that ave to copied in fat32
parition and sequence of steps to flash nand.

Hi Neelima,

Couple things to make sure:

Are you using a USB 2.0 Hub between the beagleboard and your usb keyboard/mouse?
Can you provide a complete serial dump, including first power on too
the ubuntu login? (paste to pastebin.com)

Sorry, I've never used the NAND as the root file system so the wiki
doesn't cover that..


Hi Robert,
  Yes I am using USB2.0 hub and it was working for angstrom
Sorry I did not get what you mean by complete serial dump ,including
fits power on to the ubuntu login ,Do you mean to say dmesg when
Please let me know so that I can send lgs accordingly.


Hi Neelima,

On my beagle's dmesg always seems to miss the start:

Registered protocol family 2
[128494.647949] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[128494.648559] TCP established hash table entries: 4096 (order: 3, 32768 bytes)
[128494.648712] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[128494.648803] TCP: Hash tables configured (established 4096 bind 4096)

So just capture the serial boot log,

Like: http://pastebin.com/m53eb9914


Hi Robert,

   I copied serial port log at http://pastebin.com/m4e3fd205
Fat32 partition had v2.6.29-oer32
and I built root filesystem using below command
sudo ./build-arm-rootfs --fqdn beagleboard --login ubuntu --password
temppwd --imagesize 3G --seed ubuntu-desktop,linux-firmware

I really appreciate your help in this matter


Hi Neelima,

For comparison, here's my pastebin using the same kernel:

Major differences that could cause an error..

You had X-Loader 1.41 vs X-Loader 1.4.2 (but USB worked before)

Yours: Haven't seen this error before....
Spurious irq 95: 0xffffffdf, please flush posted write for irq 56
Spurious irq 95: 0xffffffdf, please flush posted write for irq 56

There should at least be a USB hub detected:

In Mine
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 4 ports detected

Very strange...


Hi Robert ,
  I acutally wanted to connect to internet using Ubuntu on
beagleboard.Can you tell me if you have any other linux distribution
with wii-fii working on it.
Can you please let me know what linux distrib you are using.


Hi Neelima,

Most of my beagles are running Debian Squeeze with a MOSTEC based
usb-ethernet adapter. (these build beagle kernel deb's and test gcc)

At work mostly ubuntu and angstrom.

I've had very good luck with rtl8187 based usb wifi adapters.


In ubuntu is where the files ... the ethernet ....

I plugged the network cable in beagleboard. and did lsusb Realtek - RTL8150

Thanks Diego...

That one should be supported, not sure if anyone has ever tested it..

.config has: CONFIG_USB_RTL8150=y

When plugged into the beagleboard does it show up in dmesg or lsusb?

dmesg | grep rtl8

dmesg | grep eth

If that returns a result, you may have to do:

sudo ifconfig ethX up
sudo dhclient ethX


But I need the ethernet in Angstrom

same kernel..

Hey Robert,
  Instead of building Rootfs is there any exiting rootfs available
for Ubuntu


Hi Neelima,

Sorry, I wasn't able to host them due to bandwidth limits, but I build
them the same way the wiki says..


the angstrom identifies the Ethernet but he says NOT CONNECTED

Then you are very close...

Do the Angstrom equivalent of:

sudo ifconfig ethX up
sudo dhclient ethX

or use the Network Manager gui Angstrom provides..


I was there but still not working, I need the Angstrom

Hey Robert,

  Is there any other way I can boot ubuntu on BB.I really need some
help with it .I would appreciate if you can help me with this.

Hi Neelima,

You could try an older 2.6.28 kernel... (just to see if usb works and
if this is a regression..)

Grab it from my archive location...

rename to "uImage"


Hi Robert,
  Thanks alot .Actually I was looking for 2.6.28 kernel .I really
appreciate you help.