Ubuntu Precise 12.04 LTS + LXDE Desktop + Wifi Dongle UWN100

So I am happily running Ubuntu Precise 12.04 + LXDE Desktop and I was curious about this little dongle:
https://docs.google.com/document/d/1-CIGQYdk8ZhU3D3UCNn70jc7C9HdXvEZAsiNW71fGIE/edit

it is being sold by LogicSupply at a mere $10 … the link shows instructions on how to get it working on Angstrom Distribution release 2013-06-20 … the question is… does any of you have a this dongle or a similar one running on Ubuntu Precise 12.04 ??

Thanks much!

For a "mere" 2-3 more $'s you can get a WiFi dongle that'll work out
of the box without custom non-mainline drivers that do not always
work.

Atheros (atk9) based modules on amazon...
tl-wn721n
tl-wn722n

Just search "wifi" in this group, for all the problems with those
'tiny' wifi adapters...

Regards,

Thanks for the info Robert,

question… would you say the issue with these tiny dongles is because they use Realtek chipsets?.. or because they are really small and the antennas dont work that well?.. somebody in the forums had success with a small dongle using the Atheros chipset with the ASUS Wireless-N150 USB adapter…

Thanks!

on Tuesday, July 30, 2013 9:52:37 PM UTC-4, RobertCNelson wrote:

The UWN100 and UWN200 have been tested and work on Ubuntu 13.04 (with NetworkManager support, too). The pre-compiled drivers won’t work, as they were compiled on the ARM architecture. However, the full installation process will work, and is nearly the same as the tutorial outlines. There are some distribution-specific changes that need to be made, though.
You’ll need to install the “build-essential” package instead of “kernel-dev,” and you’ll probably also need “linux-headers-$(uname -r)”.
The module files (.ko files) should be copied to /lib/modules/$(uname -r)/kernel/drivers/net/wireless/
You’ll need to add “mtnet7601Usta” to /etc/modules, instead of /etc/modules-load.d/mt7601.conf

Hope this helps!

hi Casey… thanks for the info…

question… you mentioned it works with Ubuntu 13.04… how about 12.04 ? I wanted Desktop on BBB and 12.04 + LXDE works well… the Desktop installs on 13.04 seems to be still buggy or too heavy… I want to stick with 12.04 + LXDE

thanks much!

12.04 has not been tested, but I have no reason to believe it will not work. Or maybe you can install the LXDE desktop on 13.04?

Hi Casey… LXDE + 13.04 is being reported as buggy… thanks for all your help… once I get the dongle I will try it on 12.04 and report back… thanks!

Hello Joebotics,

Did you have any success getting your wifi dongle to work? If you did, I’d love to know how you did it.

Thanks for any guidance.

Charles

Great project and lots of interesting things with this BBB.

I’m having a similar issue as what was posted in this thread. I’m attempting to get the UWN100 functional with BBB. So far no luck. It appears my problem is getting the driver to install. I’m looking to use this with MachineKit and a LCD7 cape. Below are some key bits about my particular image.

$ uname -r
3.8.13-xenomai-r83
$ cat /etc/debian_version
8.7
$ whoami
machinekit

I’m using the machinekit BBB image posted at the below link. It looks like the last build was 2017-02-12 19:35
http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#BBW.2FBBB_.28All_Revs.29_Machinekit

I have installed that image, and it mostly works with my LCD7. I have a functional ssh over USB and I have a hardwired Ethernet / internet connection. However I’m having trouble getting it to work with the wifi. The hard wired setup is not pleasant for me, so I’m really hoping I can get the wifi working.

When un-powered I plugged in the USB UWN100, then booted it up. Then ifconfig does not show ra0 or wlan0. Then lsmod does not show anything like rt2800usb. I did a bunch of modprobes and got things that might be close to show up with lsmod. But still no ra0 and no wlan0. Does anyone have a suggestion on how to get the driver installed? I have tried module-assistant and the below commands, but still no dice. I seem to have loaded a bunch of modules, and perhaps one of the modules is correct but needs to be configured. I’m not sure.

See below commands for additional information. Is it possible to get the wifi module to load?

Thanks in advance, and any help on this matter would be appreciated.

$ ifconfig
eth0 Link encap:Ethernet HWaddr 90:59:af:8e:32:6c
inet addr:192.168.1.80 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::9259:afff:fe8e:326c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1
RX packets:15153 errors:0 dropped:0 overruns:0 frame:0
TX packets:147 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2110142 (2.0 MiB) TX bytes:19077 (18.6 KiB)
Interrupt:40

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1784 errors:0 dropped:0 overruns:0 frame:0
TX packets:1784 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:137919 (134.6 KiB) TX bytes:137919 (134.6 KiB)

usb0 Link encap:Ethernet HWaddr 90:59:af:8e:32:6e
inet addr:192.168.7.2 Bcast:192.168.7.255 Mask:255.255.255.0
inet6 addr: fe80::9259:afff:fe8e:326e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3593 errors:0 dropped:0 overruns:0 frame:0
TX packets:1302 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:354403 (346.0 KiB) TX bytes:303300 (296.1 KiB)

$ lsusb
Bus 001 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ lsmod
Module Size Used by
8021q 14928 0
garp 5494 1 8021q
stp 1843 1 garp
llc 5042 2 stp,garp
omap_rng 4246 0
g_ether 24037 0
libcomposite 15116 1 g_ether
cpufreq_userspace 2103 0

$

$ find /lib/modules/$(uname -r)/kernel/drivers/net | grep rt
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas/libertas_sdio.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas/libertas.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas/libertas_spi.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas/usb8xxx.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rtl8192cu
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rtl818x
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rtl818x/rtl8187
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00/rt73usb.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00/rt2800lib.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00/rt2x00usb.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00/rt2x00lib.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00/rt2500usb.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/rt2x00/rt2800usb.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas_tf
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas_tf/libertas_tf.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/wireless/libertas_tf/libertas_tf_usb.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/usb/rtl8150.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/irda/irtty-sir.ko
/lib/modules/3.8.13-xenomai-r83/kernel/drivers/net/virtio_net.ko

$ sudo modprobe rt2800usb
$ sudo modprobe rtx00usb
$ sudo modprobe rt2x00usb
$ sudo modprobe rt18150
$ sudo modprobe rtl8150
$ sudo modprobe rt2500usb
$ sudo modprobe rt73usb
$ sudo modprobe rtl8187

$ sudo depmod -a

$ lsmod
Module Size Used by
8192cu 426122 0
rtl8187 40288 0
rt73usb 18975 0
rt2500usb 15121 0
rtl8150 8004 0
rt2800usb 13518 0
rt2800lib 42303 1 rt2800usb
rt2x00usb 9798 3 rt73usb,rt2500usb,rt2800usb
rt2x00lib 37102 5 rt73usb,rt2x00usb,rt2500usb,rt2800lib,rt2800usb
mac80211 423501 4 rtl8187,rt2x00lib,rt2x00usb,rt2800lib
cfg80211 355263 3 mac80211,rtl8187,rt2x00lib
rfkill 16805 2 cfg80211
8021q 14928 0
garp 5494 1 8021q
stp 1843 1 garp
llc 5042 2 stp,garp
omap_rng 4246 0
g_ether 24037 0
libcomposite 15116 1 g_ether
cpufreq_userspace 2103 0

the UWN100 is a "MediaTek MT7601 (Ralink 7601)", the driver went
mainline around v4.5.x-ish:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/?qt=grep&q=mt7601

For 3.8.13-xenomai-r83, make sure this module is installed..

http://repos.rcn-ee.net/debian/pool/main/m/mt7601u-modules-3.8.13-bone83/mt7601u-modules-3.8.13-bone83_1jessie_armhf.deb

here is the out of tree module we used till it went mainline:

https://github.com/rcn-ee/mt7601u/tree/master/src

Regards,

Thank you for the reply. I used aptitude to install the .deb file you suggested. However after a reboot I still do not get wlan0 or ra0. Looks like the module is still not installed.

To prevent issues with various hacky things that I was trying, I started this from fresh install and followed these steps.

+++ Get initial image
– Get machinekit image bone-debian-8.7-machinekit-armhf-2017-02-12-4gb.img.xz from here
http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#BBW.2FBBB_.28All_Revs.29_Machinekit
– Extract to blah.img file with 7zip
– Burn to SD card with win32 disk imager, Win32DiskImager-0.9.5-install.exe
– install Logicsupply UWN100 and 5V 2A supply when powered off.
– put memory card in un-powered BBB

– Turn on BBB, connect 5V 2A power supply.
– Connect USB cable, wait for windows drivers to install
– SSH to 192.168.7.2 user and pass is “machinekit”
– $ cat /etc/debian_version
– Connect to hard wire Ethernet connection, wireless will not work with out first updating drivers via hardware internet connection.
– $ sudo nano /etc/network/interfaces
change to the below

iface eth0 inet dhcp
#address 192.168.1.80 # these are commented out, reference only
#netmask 255.255.255.0
#gateway 192.168.1.1
#dns-nameservers 8.8.8.8
#dns-nameservers 8.8.4.4

– $ sudo ifdown eth0
– $ sudo ifup eth0
– ifconfig to see if it is configured
– $ Ping 8.8.8.8 yipee!! internet.

– Get latest packages
– $ sudo apt-get update

+++ Setup wireless
– $ uname -r

3.8.13-xenomai-r83
– $ sudo apt-get install aptitude
– $ sudo aptitude
use “/” to search for mt7601u-modules-3.8.13-bone83 (note this needs to match uname results. Install the module. This is the driver for the UWN100
use “+” to mark selected package for install
use “g g” to do the install


use “q” to quit.

– Sudo reboot
– ifconfig should now show wlan0 or ra0.

Hmmmmmm, that did not seem to fully work. I get the below after a reboot.

machinekit@beaglebone:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 90:59:af:8e:32:6c
inet addr:192.168.1.8 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::9259:afff:fe8e:326c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1
RX packets:262 errors:0 dropped:0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:29938 (29.2 KiB) TX bytes:9267 (9.0 KiB)
Interrupt:40

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:166 errors:0 dropped:0 overruns:0 frame:0
TX packets:166 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13621 (13.3 KiB) TX bytes:13621 (13.3 KiB)

usb0 Link encap:Ethernet HWaddr 90:59:af:8e:32:6e
inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252
inet6 addr: fe80::9259:afff:fe8e:326e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:245 errors:0 dropped:0 overruns:0 frame:0
TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21283 (20.7 KiB) TX bytes:16114 (15.7 KiB)

machinekit@beaglebone:~$ lsmod
Module Size Used by
omap_rng 4254 0
8021q 15004 0
garp 5513 1 8021q
stp 1867 1 garp
llc 5058 2 stp,garp
g_ether 23921 0
libcomposite 15107 1 g_ether
machinekit@beaglebone:~$ lsusb
Bus 001 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
machinekit@beaglebone:~$

Thank you for the reply. I used aptitude to install the .deb file you
suggested. However after a reboot I still do not get wlan0 or ra0. Looks
like the module is still not installed.

To prevent issues with various hacky things that I was trying, I started
this from fresh install and followed these steps.

+++ Get initial image
-- Get machinekit image bone-debian-8.7-machinekit-armhf-2017-02-12-4gb.img.xz
from here
http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#BBW.
2FBBB_.28All_Revs.29_Machinekit
-- Extract to blah.img file with 7zip
-- Burn to SD card with win32 disk imager, Win32DiskImager-0.9.5-install.
exe

If you use etcher.io, you don't have to extract the *.img.xz

-- install Logicsupply UWN100 and 5V 2A supply when powered off.
-- put memory card in un-powered BBB
-- Turn on BBB, connect 5V 2A power supply.
-- Connect USB cable, wait for windows drivers to install
-- SSH to 192.168.7.2 user and pass is "machinekit"
-- $ cat /etc/debian_version
-- Connect to hard wire Ethernet connection, wireless will not work with
out first updating drivers via hardware internet connection.
-- $ sudo nano /etc/network/interfaces
change to the below

iface eth0 inet dhcp
#address 192.168.1.80 # these are commented out, reference only
#netmask 255.255.255.0
#gateway 192.168.1.1
#dns-nameservers 8.8.8.8
#dns-nameservers 8.8.4.4

-- $ sudo ifdown eth0
-- $ sudo ifup eth0
-- ifconfig to see if it is configured
-- $ Ping 8.8.8.8 yipee!! internet.

-- Get latest packages
-- $ sudo apt-get update

+++ Setup wireless
-- $ uname -r
> 3.8.13-xenomai-r83
-- $ sudo apt-get install aptitude
-- $ sudo aptitude
use "/" to search for mt7601u-modules-3.8.13-bone83 (note this needs to
match uname results. Install the module. This is the driver for the UWN100
use "+" to mark selected package for install
use "g g" to do the install

<https://lh3.googleusercontent.com/-_8kx6LGdX8k/WLNDt-YHQvI/AAAAAAAAAGY/nRl8CAGesWQM3PV0ZjPs8uAnQ9SJ31WvwCLcB/s1600/Capture.PNG>

"i" it's already installed.

try:

sudo depmod -a
sudo modprobe mt7601Usta

then dmesg so we can see what happened..

Regards,

Regards,

Hello,

My PC is old like Jesus. etcher.io failed, probably because it to to old. I got it to work so I moved on.

The aptitude snap shot was after I installed it. It was not originally installed.

Results of dmesg below.

[ 12.579251] hub 2-0:1.0: local power source is good
[ 12.579320] hub 2-0:1.0: enabling power on all ports
[ 12.680306] hub 2-0:1.0: state 7 ports 1 chg 0000 evt 0000
[ 12.680370] hub 2-0:1.0: hub_suspend
[ 12.680397] usb usb2: bus auto-suspend, wakeup 1
[ 12.819884] CAUTION: musb: Babble Interrupt Occurred
[ 12.981097] CAUTION: musb: Babble Interrupt Occurred
[ 13.076082] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
[ 13.189474] gadget: high-speed config #2: RNDIS
[ 13.189686] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready
[ 15.051883] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 15.051941] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 15.581013] 8021q: 802.1Q VLAN Support v1.8
[ 19.101535] omap_rng 48310000.rng: base address of priv is -97452032
[ 19.101877] omap_rng 48310000.rng: OMAP Random Number Generator ver. 20
[ 27.864493] tilcdc 4830e000.fb: timeout waiting for framedone
[ 65.132537] EXT4-fs (mmcblk1p2): mounted filesystem with ordered data mode. Opts: (null)
[ 1582.820945] usbcore: registered new interface driver rt2870

Then sudo depmod -a and sudo modprobe mt7601Usta then dmesg again. To me this looks the same, no new lines.

[ 12.579251] hub 2-0:1.0: local power source is good
[ 12.579320] hub 2-0:1.0: enabling power on all ports
[ 12.680306] hub 2-0:1.0: state 7 ports 1 chg 0000 evt 0000
[ 12.680370] hub 2-0:1.0: hub_suspend
[ 12.680397] usb usb2: bus auto-suspend, wakeup 1
[ 12.819884] CAUTION: musb: Babble Interrupt Occurred
[ 12.981097] CAUTION: musb: Babble Interrupt Occurred
[ 13.076082] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
[ 13.189474] gadget: high-speed config #2: RNDIS
[ 13.189686] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready
[ 15.051883] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 15.051941] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 15.581013] 8021q: 802.1Q VLAN Support v1.8
[ 19.101535] omap_rng 48310000.rng: base address of priv is -97452032
[ 19.101877] omap_rng 48310000.rng: OMAP Random Number Generator ver. 20
[ 27.864493] tilcdc 4830e000.fb: timeout waiting for framedone
[ 65.132537] EXT4-fs (mmcblk1p2): mounted filesystem with ordered data mode. Opts: (null)
[ 1582.820945] usbcore: registered new interface driver rt2870

Then this, and several variants like “real” “wifi” and a couple others that I thought might have something did not produce results.

$ dmesg | grep mt7

I’m quite certain that I have the proper USB module, but these do have minimal markings. There is a small chance I got it mixed up with another one. Is there a way I can verify it’s the proper one? What is this rt2870? Is that perhaps claiming I have the wrong adapter in the port?

well a quick google search of your lsusb

$ lsusb
Bus 001 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

points too:

https://cateee.net/lkddb/web-lkddb/R8188EU.html

If you install the v4.4.x-xenomai kernel that one should also work out
of the box..

cd /opt/scripts/tools/
git pull
sudo ./update_kernel.sh --ti-xenomai-channel --lts-4_4

Regards,

This is looking better. It appears that driver is now installed, but not configured correctly. Does this also mean that is is not a UWN100?

machinekit@beaglebone:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

usb0 no wireless extensions.

wlx001d43504f97 unassociated Nickname:“WIFI@REALTEK
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

machinekit@beaglebone:~$

Per adafruit tutorial, this should be showing ra0 or wlan0. However it does not. So I’m not sure how to modify /etc/network/interfaces. Do you have a suggested next step?

open /boot/uEnv.txt

you'll find a "cmdline=coherent_pool=1M quiet"

modify it to show

cmdline=coherent_pool=1M net.ifnames=0 quiet

and systemd won't rename wlan0 as wlx001d43504f97

Regards,

Hello Robert,

I’m getting back to this. I now have an official UWN100. I have a fresh install, with 7601 installed via aptitude. I’m attempting to get wifi internet configured. Per Adafruit WiFi tutorial, how do I get wlan0 or ra0 listed by ifconfig? Either that or how do I get WiFi internet functional? See logs and additional information below.

machinekit@beaglebone:~$ lsusb
Bus 001 Device 002: ID 148f:7601 Ralink Technology, Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

machinekit@beaglebone:~$ lsmod

Module Size Used by
mt7601Usta 461214 0
omap_rng 4254 0
8021q 15004 0
garp 5513 1 8021q
stp 1867 1 garp
llc 5058 2 stp,garp
g_ether 23921 0
libcomposite 15107 1 g_ether
machinekit@beaglebone:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 90:59:af:8e:32:6c
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::9259:afff:fe8e:326c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:245 errors:0 dropped:0 overruns:0 frame:0
TX packets:69 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:33142 (32.3 KiB) TX bytes:10331 (10.0 KiB)
Interrupt:40

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:160 errors:0 dropped:0 overruns:0 frame:0
TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12960 (12.6 KiB) TX bytes:12960 (12.6 KiB)

usb0 Link encap:Ethernet HWaddr 90:59:af:8e:32:6e
inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252
inet6 addr: fe80::9259:afff:fe8e:326e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:585 errors:0 dropped:0 overruns:0 frame:0
TX packets:615 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:44127 (43.0 KiB) TX bytes:149972 (146.4 KiB)

machinekit@beaglebone:~$

$ uname -r
3.8.13-xenomai-r83
$ cat /etc/debian_version
8.7
$ whoami
machinekit

Last lines of dmesg

[ 11.861453] gadget: Ethernet Gadget, version: Memorial Day 2008
[ 11.861483] gadget: g_ether ready
[ 11.861525] musb-hdrc musb-hdrc.0.auto: MUSB HDRC host driver
[ 11.864085] musb-hdrc musb-hdrc.0.auto: new USB bus registered, assigned bus number 2
[ 11.864122] musb-hdrc musb-hdrc.0.auto: supports USB remote wakeup
[ 11.864190] usb usb2: default language 0x0409
[ 11.864221] usb usb2: udev 1, busnum 2, minor = 128
[ 11.864234] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[ 11.864245] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 11.864255] usb usb2: Product: MUSB HDRC host driver
[ 11.864264] usb usb2: Manufacturer: Linux 3.8.13-bone83 musb-hcd
[ 11.864273] usb usb2: SerialNumber: musb-hdrc.0.auto
[ 11.867309] usb usb2: usb_probe_device
[ 11.867330] usb usb2: configuration #1 chosen from 1 choice
[ 11.867383] usb usb2: adding 2-0:1.0 (config #1, interface 0)
[ 11.867513] hub 2-0:1.0: usb_probe_interface
[ 11.867525] hub 2-0:1.0: usb_probe_interface - got id
[ 11.867544] hub 2-0:1.0: USB hub found
[ 11.867568] hub 2-0:1.0: 1 port detected
[ 11.867578] hub 2-0:1.0: standalone hub
[ 11.867587] hub 2-0:1.0: individual port power switching
[ 11.867596] hub 2-0:1.0: no over-current protection
[ 11.867605] hub 2-0:1.0: Single TT
[ 11.867615] hub 2-0:1.0: TT requires at most 8 FS bit times (666 ns)
[ 11.867625] hub 2-0:1.0: power on to power good time: 10ms
[ 11.867647] hub 2-0:1.0: local power source is good
[ 11.867705] hub 2-0:1.0: enabling power on all ports
[ 11.971450] hub 2-0:1.0: state 7 ports 1 chg 0000 evt 0000
[ 11.971509] hub 2-0:1.0: hub_suspend
[ 11.971534] usb usb2: bus auto-suspend, wakeup 1
[ 12.154459] CAUTION: musb: Babble Interrupt Occurred
[ 12.255386] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
[ 12.345202] CAUTION: musb: Babble Interrupt Occurred
[ 12.601595] gadget: high-speed config #2: RNDIS
[ 12.601792] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready
[ 12.923002] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 12.923059] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 13.009080] 8021q: 802.1Q VLAN Support v1.8
[ 16.985793] omap_rng 48310000.rng: base address of priv is -97452032
[ 16.995010] omap_rng 48310000.rng: OMAP Random Number Generator ver. 20
[ 18.083053] rt2870 1-1:1.0: usb_probe_interface
[ 18.083081] rt2870 1-1:1.0: usb_probe_interface - got id
[ 18.151182] usbcore: registered new interface driver rt2870
[ 25.063171] tilcdc 4830e000.fb: timeout waiting for framedone
[ 38.277740] EXT4-fs (mmcblk1p2): mounted filesystem with ordered data mode. Opts: (null)

machinekit@beaglebone:~$ dmesg | grep mt
machinekit@beaglebone:~$ dmesg | grep 7601
[ 2.078832] usb 1-1: New USB device found, idVendor=148f, idProduct=7601
machinekit@beaglebone:~$

Hello,

I’m still looking to configure WiFi. Can someone suggest what tools I should be using to configure the WiFi? This is 3.8.13-xenomai-r83 debian_version 8.7 machinekit image. Here is a bit more information.

I have found many tutorials which use many different tools. I have not found a tutorial that works with this BBB image yet. More info below about my ra0 UWN100.

machinekit@beaglebone:~$ sudo iwconfig
ra0 Ralink STA ESSID:""
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=10/100 Signal level:0 dBm Noise level:0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

usb0 no wireless extensions.

machinekit@beaglebone:~$ sudo ifup ra0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up ra0.
machinekit@beaglebone:~$ sudo iwlist ra0 scan

ra0 No scan results

machinekit@beaglebone:~$

I have tried adding some things per adafruit tutorial into /etc/network/interfaces, but no dice yet.

Hello,

Can someone suggest how to configure the wifi on this 3.8.13-xenomai-r83 Debian 8.7 machinekit BBB? It appears that connman is installed and aptitude hangs when I try to remove it. I was trying to remove connman such that I could use wicd, but I could not get connman to remove. It appears I’ll need to configure connman to use the wifi. I have found some connman tutorials. However they do not go smoothly. I can not get the wifi to scan. It appears I need to enable some permissions, but I’m not sure what permissions to enable, or how to enable those permissions. See below which notes the wifi is not powered and it will not allow me to enable it. Can someone suggest what permissions are needed to get this to enable?

machinekit@beaglebone:~$ sudo connmanctl

enable wifi

Error wifi: Operation not permitted

technologies
/net/connman/technology/wifi
Name = WiFi
Type = wifi
Powered = False
Connected = False
Tethering = False
/net/connman/technology/gadget
Name = Gadget
Type = gadget
Powered = True
Connected = False
Tethering = False
/net/connman/technology/ethernet
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False

quit
machinekit@beaglebone:~$