Ubuntu setup: no disks detected

After some effort, Ubuntu 14.04 is booting on my Beagleboard-xM.

I’m going through the Ubuntu setup. When I get to “Detect disks”, I’m told that none were detected, and presented with a menu of drivers. Is that normal? I don’t know what driver I need, and I don’t know whether it’s specifically looking for a traditional disk drive rather than an SC card. Should I pick a driver? Which one?

If I tell it to continue with no disk drive it tries to login to iSCSI, and here if I’m supposed to do something, I don’t know what it is.

Sadly, this is known regression.. "mmc -110" to be exact.

Every-time i try to bisect this issue, my "random microSD that shows
the mmc -110 error" doesn't always fail 100%.. So it's a pain to

Either use a different brand disk, or try a different kernel, here are
the 3 other options, listed in the order you should test.

--use-stable-kernel = 4.2.6-armv7-x3
--use-testing-kernel = 4.3.0-armv7-x1
--use-experimental-kernel = 4.4.0-rc1-armv7-x0


None of that worked on three different SanDisk cards, one purchased this week, the others are probably two years old.

A PNY card worked beautifully with the default kernel.

Thanks for your help!