uImage booting on BB

Hi,
I have BB Rev C2 board.
I have downloaded sources from http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
and build.
I copied following images to SDcard.
1. MLO
2. uImage
3. u-boot.bin
4. x-load.bin.ift

while booting uImage I am getting below error

<5>RAMDISK: Couldn't find valid RAM disk image starting at 0.
RAMDISK: Couldn't find valid RAM disk image starting at 0.
List of all partitions:
List of all partitions:
1f00 512 mtdblock01f00 512 mtdblock0 (driver?)
(driver?)
1f01 1920 mtdblock11f01 1920 mtdblock1 (driver?)
(driver?)
1f02 128 mtdblock21f02 128 mtdblock2 (driver?)
(driver?)
1f03 5120 mtdblock31f03 5120 mtdblock3 (driver?)
(driver?)
1f04 254464 mtdblock41f04 254464 mtdblock4 (driver?)
(driver?)
No filesystem could mount root, tried: No filesystem could mount root,
tried: ext2 ext2

<0>Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-
block(1,0)

The entire log is available @ http://pastebin.com/m2abeac96

Kindly help out to resolve this issue.

Thanks.

bb410 wrote:

Hi,
I have BB Rev C2 board.
I have downloaded sources from http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
and build.
I copied following images to SDcard.
1. MLO
2. uImage
3. u-boot.bin
4. x-load.bin.ift

while booting uImage I am getting below error

<5>RAMDISK: Couldn't find valid RAM disk image starting at 0.
RAMDISK: Couldn't find valid RAM disk image starting at 0.

You configured to start from a ram disk by kernel command line

... ramdisk_size=3072 root=/dev/ram0 rw rootfstype=ext2 initrd=0x81600000,3M ...

which seems couldn't be found there.

Have a look to

http://elinux.org/BeagleBoardBeginners#SD_card_setup

and/or

http://code.google.com/p/beagleboard/wiki/BootingBeagleBoard

how to prepare SD card with root fs.

Best regards

Dirk

Where can find the kernel command in source files and Can I remove
this command line? or it should be set in source
Or before booting uImage is it possible to change ?

You mean I have to keep rd-ext2-8M.bin ( rename to rd-ext2.bin ) onto
SD card ?
The file rd-ext2-8M.bin is available in http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
path under Pre-Built Images for Beagle Board.

Thanks in advance.

Hi,
After copying rd-ext2-8M.bin ( rename to rd-ext2.bin ) onto SD card I
got root prompt on my teraterm ....
The file rd-ext2-8M.bin is available in http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
path under Pre-Built Images for Beagle Board.

I am not sure whether it is correct file ( rd-ext2-8M.bin file ) to
use for this distribution. Can you tell me ?
......Piece of log at end is ...........
System initialization complete.

Please press Enter to activate this console. Jan 1 00:00:06
beagleboard syslog.info syslogd started: BusyBox v1.9.0

starting pid 292, tty '': '/bin/sh'

    Setting shell environment ...
    - Path
    - Aliases
    - Touchscreen

    Done!

[root@beagleboard /]#
.................................

On my PC it is showing one more " LocalAreaNetwork2 ". On my PC's task
bar at right corner I can see LAN symbol but it is crossed with red
color.
Is there anything I am missing while enabling in kernel?
may I know why it is coming and what is use ?
Is it possible remove this by modifying kernel? how and where to
change ?

Is this kernel having any example/sample codes to test ?
It will be great full if I get any .wav playback application and how
to load and execute.

Kindly help out.

Thanks in advance.