ulcd7 lite image

I bought the ulcd7 and work fine with my beagleboard. Now I wan´t to
know if the image I've downloaded at beagleboardtoys does include
native qt-embedded or qt4 sdk. I have tried the command qmake but it
isn't avalaible. Do I have to use the angstrom cross toolchain

I think they got their image from BeagleBoard.org - esc. I used
Narcissus to create that image. One of the options is to enable a
"Native (on-target) Qt Embedded SDK ". I suggest trying to build
yourself an image and toolchain that way. Be sure to use
"core-eglibc" as the release to base your rootfs from to make sure you
get the drivers for the ulcd7.

Hi Jason,

I am trying to build a new image using Narcissus to utilize my ulcd7. If I select [core-eglibc], when I extact the tar, I end up with: MLO, uImage, & u-boot.img. I don’t get u-boot.bin which the beagelboard-xm is looking for. Am I doing something incorrect?

I also noticed that in the ulcd7 image supplied by beagleboardtoys (http://beagleboardtoys.com/wiki/index.php?title=ULCD7_Lite), the boot partition has 3 files:

  • u-boot.bin
  • uEnv.txt
  • user.txt (which is empty)
    It doesn’t have a MLO file, but it boots up just fine. What is going on there?



No, more recent MLOs (mid 2011 vintage) require u-boot.img, not u-boot.bin

No, more recent MLOs (mid 2011 vintage) require u-boot.img, not u-boot.bin

Thanks for getting back to me! I really do appreciate it.

So I tried the image with the MLO provided with the Narcissus build & u-boot.img. It does not boot. I get the following:

Texas Instruments X-Loader 1.5.5ss (Mar 8 2011 -10:21:21)
Beagle xM
Reading boot sector
u-boot.bin not found or blank nand contents - attempting serial boot . . .

So do I need to go out and find a newer MLO file elsewhere?

So do I need to go out and find a newer MLO file elsewhere?

I went to the Angstrom Demo Page (http://www.angstrom-distribution.org/demo/beagleboard/), downloaded the MLO there (1/29/12) and sure enough it boots up… kind of.

The ulcd7 display is inverted & it takes several minutes to finally get to a prompt on the ulcd7 display. The serial stream stops responding mid-way through boot.

More work to be done!

To save you some hair pulling.. run this little magic gem in your
u-boot boot script..

lcd1=i2c mw 40 00 00; i2c mw 40 04 80; i2c mw 40 0d 05
uenvcmd=i2c dev 1; run lcd1; i2c dev 0



Thank you Robert & Koen! I am getting close, but I’m not quite there.

My ulcd7 display works, looks great! With the angstrom demo MLO, it is booting my u-boot.img file. It gets all the way through the boot process and to a login prompt. But thats as far as I get. For some reason, it is not accepting root as a login. There are no errors displayed during the boot process, nothing on the ulcd7 or on the serial output.

It obviously understands root as a username because it does not ask me for a password. It just kicks back, ‘login incorrect’. With anything else I provide as a login, it asks for a password.

BTW - all I selected in the Narcissus build was: core-eglibc (to get the latest kernel) & the bootscripts. Nothing else!