Unable to boot from SD card or mount a blank one


I am new to the BB AI. I have been facing some issues with the SD-card boot.
The board boots just fine off of the eMMC. However, I would like to boot it from the SD card.
I have used a number of images from the BB images page, written them into the SD card with Balena etcher, no use - the board always boots off of the eMMC.

I then tried formatting the card with FAT32 , allocation unit size 4096, and then checked if I could at least mount it from the eMMC booted system. The SD card is never recognized and there is no entry in /dev for this device.

I tried using dtc on the am5729-beagleboardai.dtb to generate the dts, followed the post at:

specifically, I did this:
"converted the am5729-beagleboneai.dtb to xx.dts using “dtc”. Then, I found out mmc1 node (mmc@4809c000), and modify some places as follows:

1. compatible = “ti,dra7-sdhci”; >>>>> compatible = “ti,dra7-sdhci”, “ti,omap4-hsmmc”;

2. add: vmmc_aux-supply = <0xd0>; (same node with vqmmc-supply)

3. max-frequency = <0xb71b000>; >>>>> max-frequency = <0x16e3600>; (to lower the frequency of mmc)

Save and exit, then convert the .dts file to am5729-beagleboneai.dtb, replace the old one.


(copied the steps from the above site)

This does not work either.

I dont have a serial interface for the board just yet so I dont have the serial output.

I would appreciate any input or help. I am not sure what I should do to get this board booting off of the SD card.

Thank you and Best regards!

If it’s like the Beaglebone Black, when you apply power, you have to hold the boot button down for quite a while. That’s what tells the system to boot from the sd card.

It won’t matter if you form the card as Balena etcher will write the image in the format required for the Beagle.


Have you tried the lsscsi and lsblk commands to see what the system thinks that device is?

I just looked at one of the photos of the BB AI and I don’t see a boot button. So ignore my last posting.

If you install an sd card how does it know what to boot from? Would it default to the sd image? And if the /boot/uEnv.txt has the write to flash set at the end wouldn’t it just automatically then write the image to eMMC?

Theoretically the BBB always boots to eMMC and the Boot button is required. But I recall at some point also running the BBB where it booted automatically to the sd card image. But I don’t remember how it did that without the Boot button. Is there an EEROM location that has been corrupted on the BB AI?


if i remember right. it boots from SD card if its there then defaults to Emmc
it was changed a long time ago to not need a boot button

That has only applied to very old BBB eMMC images... Sometime in the
late Wheezy or mid-Jessie era, u-Boot was modified to automatically search
for a uSD card image, and transfer control to the SD card if found.

  I haven't had to touch the boot select switch in something like 3+

  Note: the BB AI does not have a boot select switch -- it expects the
eMMC u-Boot to do the switching if a proper card is found.

The am57xx boot rom defaults to microsd before emmc…

Thank you for your answers. However, the board never recognizes the SD card…

What is the image name of the file, you flashed with etcher.io to your SD card?


Thank you for your answers. However, the board never recognizes the SD card…

What is the image name of the file, you flashed with etcher.io to your SD card?


I used : am57xx-debian-9.9-lxqt-armhf-2019-08-03-4gb.img.xz with etcher.

Which could mean a faulty uSD card socket...