Unable to boot from SD card

Hi All,
  I downloaded demo version of Angstrom distribution and copied MLO ,U-
boot and UImage in bootable fat32 partition and untarred root
filesystem into ext3,but still am not able to boot it.(I pressed user
button to change boot sequence.)
I even tried downloading ubuntu distibution and booting ,still its not

I had been stuck formating SD card for more than a week.I greatly
appreciate if anyone can tell me solution to my problem.

Thanks In advance,

Hi Neelima,

Let's start with the basic's, would you please provide a log of your
current beagleboard u-boot boot sequence with pastebin (1). Also pause
it, and type "printenv".

1: http://pastebin.com/



Here are a couple of possibilities:

1. You must HOLD down the USER button while pressing and releasing
RESET or cycling power.

2. Be sure SD card is inserted all the way. The card should protrude
from the edge of the BeagleBoard by about 18mm -- it goes under the
top surface contact fingers. Always be careful inserting the card.

3. MLO must be the first file on the SD card. Just deleting files
and re-copying them may not put MLO first. What worked for me was to
reformat Partition 1 using Windows and then recopy the files starting
with MLO, also using Windows. Here's the full saga of how I got
Ångström running:


Hope this helps,

...And use a card smaller than 2 GB

Thanks a lot for reply.I am currently using Linux OS and partitioned
SD card using gparted and whenever I try to save MLO file from web it
is saving as mlo .Does MLO name have to be in uppercase .

Actually I had working SD card that I took from my friend and I could
successfully boot it but , I am not able to enter username and
passowrd is Angstrom login page and here is hardware setup that I had

I have 2 GB card ,can I use it for formatting

If you usb keyboard isn't working to login, please verify:

Hi Robert,
  Thanks alot for reply .I could not see anything except for beagle
board logo on screen(TV monitor) and I don't know how to print u-boot
boot sequence.Sorry I am totally new to it and don't know how to log
boot sequence.I tried to connect beagleboard RS-232 to my desktop
serial port and used minicom but, Its not connecting .I specified
serial port as ttsy2 and bit rate as 115200 n81 in minicom settings.

Can you please let me know if what I am doing is correct and I would
appreciate if u can guide me.


Hi Neelima,

I was guessing that, minicom can be a pain at times. If you are
running a ubuntu/debian based os, give "sudo apt-get install gtkterm"
a try, you can't really log with it, but it's way more gui based then
minicom. :wink: (it's hard to trouble shoot with out knowing exactly what
uboot's doing.)

ps, for ubuntu, i had an error report sent to me last night, and had
adjusted the *.scr scripts for Rev C2 boards. My build system is just
now finishing that build/upload..

Hi Robert,

  Do I have to copy anything other than MLO,u-boot.bin and uImage ?
Actually I had working SD card that I took from my friend and saw that
they have other files like reset.scr rr.scr and u-boot-f.bin .Do I
have to have all those files on fat 32 partition as well ,whenever I
try to save MLO file from web it is saving as mlo .Does MLO name have
to be in uppercase .

Thanks in advance,

Hi Neelima,

I wouldn't worry about the MLO, i have a number of rev b*'s boards
still running the original 1.41 firmware. Rev Cx boards come with the
latest MLO already.

If the version of uboot installed on your beagle automatically runs
script files, you'll just need a uImage (kernel) & one of the boot.scr
file (either ubuntu-ext2.scr or ubuntu-ext3.scr based on how you
format the second partition.)

If the version of uboot doesn't automatically run script files, you'll
just need a uImage (kernel) then this needs to be manually typed in
uboot thru the serial port:

setenv bootcmd 'mmcinit; fatload mmc 0:1 0x80300000 uImage; bootm 0x80300000'
setenv bootargs 'console=ttyS2,115200n8 console=tty0
root=/dev/mmcblk0p2 rootdelay=2 rootfstype=ext3 ro
omap-dss.def_disp=lcd omapfb.video_mode=1280x720MR-24@60'
Replace ext3 for ext2..

(the saveenv command isn't used in the script files, but is useful so
you don't have to type it on every boot.)


Neelima, make sure your serial cable is connected properly and is
indeed ttys2 (I guess your ttsy2 is a typo). More likely it will be
someting like ttyS2.
Or if you use a usb to serial cable it would be ttyUSB0 or so.

Wrt the TV: I suggest connecting to a DVI monitor first.
TV's tend to be more critical wrt the signal that they get and support
less modes.
Out of the box with the standard SD card content you will not get a
picture on your TV (apart from the logo).



For serial issues, there are lots of useful comments on the
BeagleBoard FAQ: http://elinux.org/BeagleBoardFAQ#Serial_connection_.231
Many people have had problems with the DB9 to 10-pin IDC cable. There
are two standards, and you must have the correct one to work with


Thanks alot for reply Frans.I would try that


you can also try a new image like the instructions here:

No need for a serial adapter.

Also, the tty settings differ based upon where your computer has allocated the serial port, so it will not always be at tty2 and as stated above, if it is over USB it will not be a tty prefix.

Just remember to breathe.



Are you just feeling like spamming/trolling the boards today? this
thread was from 2009....