Unable to connect to BBB over USB on desktop

I purchased a Beaglebone Black (rev. A6) at the end of last year and was highly unsuccessful in getting the board up and running on my desktop PC. Unfortunately, due to work and grad. school commitments I haven’t made time to pursue this board any further until now.

Now onto the actual problem… I am unable to connect to the default web server over the USB connection on my desktop PC. Up until recently I was able to get the BBB mounted to my PC, however, after some tweaking last night I am now unable to do that either. I only tried very briefly to connect via the RJ45 connector on the board and was unsuccessful in that as well. I will say that I am able to connect to the BBB over USB on my laptop very quickly and easily so I really don’t expect this to be a hardware issue.

My desktop PC is a Windows 7 64-bit machine that hasn’t seen a fresh install in probably 2-3 years. In that time I’ve run a couple of different development boards (Arduino and a couple of simple PIC setups) plus a ton of other random peripherals. I also currently connect to the internet through a VPN and installed a TAP driver to do so. I have a VM setup through VirtualBox which has an entry in the network adapters section of the device manager labeled “VirtualBox Host-Only Ethernet Adapter”. I guess the takeaway here is that I’ve been using this install for a few years now and have install all kinds of different device drivers for various peripherals that may be conflicting with my BBB. My laptop on the other hand is a new (<1 year old) Dell which is also running Windows 7 64-bit but has had far less connected to it.

As of early last night I was able to connect the BBB via USB to my desktop PC and see the BBB mounted to my PC. There were entries in the device manager for the Beaglebone (under Portable Devices), the Gadget Serial (under Ports COM & LPT), and the Linux RNDIS Ethernet gadget (under Network Adapters and shows up as Linux USB Ethernet/RNDIS Gadget #2 for some reason). The RNDIS entry showed device error 10 saying that the device was not able to start. I have installed the drivers through the BONE_D64 executable as well as by trying to manually update the driver and point it to the RNDIS driver located at F:\Drivers\Windows\src\files\RNDIS. Later last night I tried uninstalling all of the BBB entries I could find within the device manager (the three I listed above) and used bcdedit to allow the installation of digitally unsigned drivers thinking that perhaps Windows was blocking the install somehow. I restarted my PC, installed the drivers, re-enabled driver integrity checks with bcdedit and restarted my PC once again. This was unsuccessful and I was still unable to get the Linux USB Ethernet/RNDIS Gadget to start properly.

I also tried uninstalling all of the drivers, restarting, installing Code Composer Studio 5.5.0, and restarting again in the hopes that the software would be packaged with a digitally signed set of drivers that would run properly on my machine. Again, this was met with no success and I was still unable to connect to the BBB’s internal web server.

Lastly, I tried downloading and flashing the BBB with the latest Angstrom image to see if maybe there was some weird interaction between the particular version of Linux on my BBB and my PC (despite it seeming unlikely due to the error with the RNDIS gadget). This last step was again unsuccessful, but I am still able to connect over USB to the BBB’s webserver on my laptop.

I’d really like to solve this issue asap but I am out of ideas. I will probably be reinstalling Windows in about a month once my new SSD is no longer on back order. I am hoping that there is a solution someone else knows of that will get me up and running faster than that though. Working on my laptop is an option but my desktop has far more RAM which makes it much more appealing when I am running a VM to develop code for the BBB. Hopefully I’ve provided enough information for someone to give me an idea of what else I could try. Thanks in advance for your help guys!

If anyone can provide any insight here I’d definitely appreciate it! I’m strongly considering just reformatting my PC but would prefer to avoid that solution for the time being if possible.

Unfortunately, I do not know anyone who could possibly troubleshoot this problem without being at the keyboard. Your install is old, and is probably broken in one way or another.

I have personally experienced similar issues with the same version of Windows, and my own recourse is just to reinstall. One thing you can do to help facilitate this is to keep the OS separate from your data ( e.g. two partitions, 1 for OS, one for data ). It wont keep the OS from eventually loosing its mind, but it should keep your data safe, and make it very simple to reinstall.

Also, for the drivers, I have no idea who actually wrote them but they seem to be a bit inexperienced with windows drivers. As there should be an option to remove existing old drivers. The problem here is when you update your BBB sometimes Windows views the hardware differently, and has no idea how to interact with it. So, you’re required to reinstall the drivers, while previous versions stay installed. Confusing Windows even more eventually until it just starts to silently fail.

The last time I personally reinstalled was fairly recently. Just before I did however, I booted into safe mode, and did some investigation. Between the two BBB’s we have several MSP430 launchpad’s and perhaps an old M3 stellaris dev board. I had 10 + old drivers still installed but not being used.

Further advice would be to limit what you install on your development workstations. The standard K.I.S.S methodology.

Thanks for the reply William. I was hopeful that maybe I was doing something dumb or perhaps just missing something that someone here would be able to easily pickup on and point out to me. I’ve already started downloading installers for the software I use frequently in order to have a (hopefully) quick and easy reinstall this weekend. I intend to image my OS drive after the reinstall to make things easier the next time this occurs. I do have a separate drive (not just partitions) for my OS and most frequently used programs so I shouldn’t lose any important data. If I could convince my fiancee that I need a 5th computer I’d love to have a dedicated machine for development, but until then I suppose I’ll have to live with my general purpose desktop machine. I do have a bad tendency to download new software just to play around with it though. Maybe I’ll try to be a little more selective about what I install next time around :slight_smile:

heh, I just have two laptops that I use lately. One is the general purpose do everything system. Mostly, it just runs VLC to play movies, and then virtualbox where I have an x86 Debian install support “system” for the BBB. I tried dual booting, but for the purpose above . . . it was not working out for me. Mostly because I did not want to install X on my support system.

My other system is fairly minimal. No JRE, or java apps period, no Flash, etc Pretty much just firefox, sublime text 2 for editing code, puTTY, x-chat, winrar.

The Debian virtual machine does all the cross compiling, and hosts the BBB’s rootfs ( NFS root ), while also acting as a Samba server so I can access files on the BBB or support system via mapped network drive from My “dev machine”. It’s a fairly complex setup, but I’m pretty happy with it.

OK so I just performed a clean install of Windows 7 and I am still unable to connect to the default web server via USB. The drivers were reinstalled but the Linux USB Ethernet/RNDIS Gadget still says the device cannot start. Does anyone have any suggestions given that this doesn’t appear to be a broken OS anymore?

I had a chance to look at my problem again and I managed to get my BBB connected properly. After the reinstall I went through the normal 3-4 sessions of Windows updates and restarts to install them. Then I updates my motherboard BIOS and installed all of the applicable drivers from the Gigabyte website. Two of the things I did were to install the latest Realtek Ethernet driver for my motherboard and run the Intel INF update utility. I still think my old Windows 7 install was probably causing me problems due to how old it was and all of the devices I had installed during that time, however, I also should have installed all of the appropriate drivers from the Gigabyte website before posting that my problem wasn’t solved.

At this point I see all three devices listed in the device manager (Gadget Serial under Ports, BEAGLEBONE under Portable Devices, and Linux USB Ethernet/RNDIS Gadget under Network Adapters) and they are listed as working properly. Hopefully if anyone else has a similar issue they’ll be able to get something useful out of this thread. Unfortunately, I don’t know exactly which step solved my issues but updating BIOS and drivers seems like a good first step.

I faced similar problem for the BBB that I bought couple of days back. I was using Windows XP and Windows 7, but could not identify the exact issue. I did reinstalling all the drivers as suggested but did not work.

Finally, I found that under the device manager - Other devices, there was “RNDIS” and “CDC serial”. Once I installed RNDIS from microsoft (http://developer.toradex.com/knowledge-base/how-to-install-microsoft-rndis-driver-for-windows-7) along with BONE_DRV.exe (USB driver for windows - step 2. http://beagleboard.org/getting-started) resolved the issue.

Thanks for the post. and I hope this additional info might help some more people like me. :slight_smile:


ITFK, So judging by last comment I would suspect the step that fixed it for you was Windows update. Since Windows update will see partially installed, or outdated drivers and update them, sometimes.

Can you try the newly signed drivers?

Let me send that again from the right e-mail address:

Try these and let me know how it goes:

This problem still exists in 2018.

BeagleBone Blue running bone-debian-9.3-console-armhf-2018-02-18-1gb.img.xz.

Several computers w/ Windows 10. Arch Linux too.

Very poor form not to have sorted out such a basic issue by now. Whoever is disposed to / has responsibility for etc…?

No 3rd party drivers for Windows 10 is required.

The latest images now use Window's 10 built-in drivers by default.



I have borrow BBW from element14,
Since last 4 months I am doing hands on experience on this devices and goiung good,
But since lase two days this board hase stopped detecting on desktop and Iam unable to solve it ,
Please help on this to solve it.


Vivek Patel