Unable to establish a net connection through BB-xM Rev C

Hello,

I am using the ubuntu image, i got from the following site. http://www.timzaman.nl/?p=1114&lang=en.

I am unable to connect to the net through the Beagle-xM Rev C board. I get the below error on trying to use sudo apt-get update.

My setup comprises of my laptop connected to a ADSL router, running ubuntu 10.04 LTS in VMWare. The board is connected to the router. I am able to ping the router’s ip. I am not able to ping the laptop through the board or the board through the laptop. Also the green and orange LED’s on the ethernet jack are glowing. The board is running Ubuntu 11.04 Natty.

ubuntu@omap:~$ sudo ifconfig -a
[sudo] password for ubuntu:
eth0 Link encap:Ethernet HWaddr 4a:5d:3e:1e:fb:b5
inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::485d:3eff:fe1e:fbb5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1488 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1626 (1.6 KB) TX bytes:2790 (2.7 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr 7e:55:fe:f4:67:67
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ubuntu@omap:~$ sudo dhclient eth0
ubuntu@omap:~$ sudo apt-get update
Err http://ports.ubuntu.com natty InRelease

Err http://ports.ubuntu.com natty-updates InRelease

Err http://ports.ubuntu.com natty Release.gpg
Temporary failure resolving 'ports.ubuntu.com
Err http://ports.ubuntu.com natty-updates Release.gpg
Temporary failure resolving 'ports.ubuntu.com
Reading package lists… Done
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/natty/InRelease

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/natty-updates/InRelease

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/natty/Release.gpg Temporary failure resolving 'ports.ubuntu.com

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/natty-updates/Release.gpg Temporary failure resolving 'ports.ubuntu.com

W: Some index files failed to download. They have been ignored, or old ones used instead.

Can someone point me in the direction as to how to solve this problem?

Thanks & Regards,
Sanchayan.

With vmware, did you setup a bridged or nat connection? Thru nat, you
probally wouldn't be able to ping the beagle directly..

From the beagle, can you ping google.com or ports.ubuntu.com? If not
it looks like a problem with your router..

Regards,

I have set up a NAT connection. Is the beagle not able to ping directly, because, due to NAT the IP of my laptop is being translated to a different IP which the beagle is seeing, than the one i am assuming, meaning using ifconfig -a.?

I cannot ping google.com or ports.ubuntu.com from the beagle.

My router is an ADSL router and for use with the laptop, both the network cable and a USB cable has to be connected to my laptop.

Is there any way i can access the network to download the relevant files with a set up like mine?

Thanks for the help.

I have set up a NAT connection. Is the beagle not able to ping directly,
because, due to NAT the IP of my laptop is being translated to a different
IP which the beagle is seeing, than the one i am assuming, meaning using
ifconfig -a.?

Correct... Some later versions of NAT can handle some of that, but
really it's easiest to put it on the same subnet.

I cannot ping google.com or ports.ubuntu.com from the beagle.

My router is an ADSL router and for use with the laptop, both the network
cable and a USB cable has to be connected to my laptop.

Then it's simple, you need to install the relevant software tools to
turn your laptop into a dhcp server/internet gateway... Personally it
would be just way easier to have your network setup as:

ADSL router <-> firewall/router <-> hub <-> multiple devices

Is there any way i can access the network to download the relevant files
with a set up like mine?

All can be accessed via: http://ports.ubuntu.com/pool/ but without a
working network connection, dependicy checking is going to be a pain.

Regards,

My laptop and beagle are on the same subnet. At least, thats what the ifconfig -a command shows.

For Beagle:
ubuntu@omap:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 52:8f:0e:1a:91:c9
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::508f:eff:fe1a:91c9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1488 Metric:1
RX packets:61 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3880 (3.8 KB) TX bytes:4596 (4.5 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr 4a:87:c8:b9:1a:cd
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

For my laptop:
vm@ubuntu:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0c:29:70:e7:2d
inet addr:192.168.18.128 Bcast:192.168.18.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe70:e72d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10622 errors:0 dropped:0 overruns:0 frame:0
TX packets:10091 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8526866 (8.5 MB) TX bytes:1802379 (1.8 MB)
Interrupt:19 Base address:0x2024

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:116 errors:0 dropped:0 overruns:0 frame:0
TX packets:116 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9476 (9.4 KB) TX bytes:9476 (9.4 KB)

So basically for networking, i have to get another router or a switch which will connect to the ADSL router i already have and the beagle will connect to the new router or switch?

My laptop and beagle are on the same subnet. At least, thats what the
ifconfig -a command shows.

actually they aren't, you only get one subnet with a Mask of 255.255.255.0

For Beagle:
ubuntu@omap:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 52:8f:0e:1a:91:c9
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::508f:eff:fe1a:91c9/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1488  Metric:1
      RX packets:61 errors:0 dropped:0 overruns:0 frame:0
      TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:3880 \(3\.8 KB\)  TX bytes:4596 \(4\.5 KB\)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr 4a:87:c8:b9:1a:cd
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

For my laptop:
vm@ubuntu:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0c:29:70:e7:2d
inet addr:192.168.18.128 Bcast:192.168.18.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe70:e72d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10622 errors:0 dropped:0 overruns:0 frame:0
TX packets:10091 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8526866 (8.5 MB) TX bytes:1802379 (1.8 MB)
Interrupt:19 Base address:0x2024

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:116 errors:0 dropped:0 overruns:0 frame:0
TX packets:116 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9476 (9.4 KB) TX bytes:9476 (9.4 KB)

So basically for networking, i have to get another router or a switch which
will connect to the ADSL router i already have and the beagle will connect
to the new router or switch?

Correct, that's what most of us do..

Regards,

"actually they aren’t, you only get one subnet with a Mask of 255.255.255.0 " <<<< Ya, i totally overlooked.

Thanks for all the help.

Hello,

Can’t you access the terminal on Beaglebone?

Your Beaglebone and comp need to be on the same IP address series. If your PC’s addresss is 192.168.5.4, your beaglebone’s address can be 192.168.5.20 may be, assuming no one else on the network is using that IP.

Try to ascertain a few things first. Is the IP address of PC dynamically or statically assigned ?. Whether your router does NAT ing in some way. If yes, then your actual IP address on the network might look something different.

Basically you need to first set the ip address of the board and then try to ping the router. If this ping is successful, ping the PC. If this ping is successful, you should be able to connect to the beaglebone over ethernet.

I don’t believe I can access the terminal on Beaglebone (I can’t get a command prompt of root@beaglebone like I could on Windows). Now here, I can get minicom to connect and provide me with a root login prompt, but it hangs there!

My networking friend suggested it may be my ethernet card / hub configuration because I have Ubuntu installed on a Dell intended to run Windows.

Do you have any other suggestions for command prompts that could return some system info for troubleshooting?
thank you!

Are you sure the minicom settings are correct? Are you not able to type anything on the beaglebone minicom terminal prompt? If yes, uncheck hardware flow control in minicom settings of your PC. Getting access to terminal command prompt of the board is the foremost important task.

What you can do in windows, you can do in ubuntu as well. Just need to do the settings properly.

You need to find the ip of beaglebone board somehow. Do one thing. Connect your beaglebone directly to your computer. Open up the terminal and type “arp -a”.

It would print the ip address and the mac address of all devices it can find on the network. The command works for windows as well as ubuntu.

The ip address of your beaglebone assuming it has been set, should show up.

Thanks for working with me on this.
My minicom settings are correct as far as I know (for serial port settings):
Serial Device : /dev/ttyUSB1
Lockfile Location : /var/lock
Callin Program :
Callout Program :
Bps/Par/Bits : 115200 8N1
Hardware Flow Control : Yes
Software Flow Control : No

With these settings I cannot get a minicom terminal prompt, I get nothing after the header. Can’t type, only bring up menus and adjust settings. If I the right serial port selected, I can press the reset button and then view the boot log of the beagleBone. It has some errors - I’m about to go line by line through the log and try that. I’m wondering if my Android SD card is configured correctly.

So I tried adjusting the Hardware Flow Control to “No” as you suggested. Same minicom screen without prompt. Same boot log (I think, I need to look more closely) as before.

typing arp -a only provides me with one response: the eth1 connection which I believe is my connection to the server/internet. eth3 is the card that goes out to the hub and then to the bone. It’s listed in my wired connections on my ubuntu dash, but when I click on it to activate the eth3 port, it tries and times out but the lights on the hub are all lit.

So, I think it comes down to: How do I set my IP address for the bbone without the bone’s prompt? (or, How do I acquire the prompt without knowing the IP address?)

I’ve been looking around the internet more and I’m not finding anything specific to the Android SD boot.

I usually suggest gtkterm which is a GUI clone of Windows hyperterminal. It's much simpler and I have used nothing else since discovering it around 13 or 14 years ago.

It's available via apt-get in Ubuntu, in openSUSE I had to build it from source.
Regards
Sid.

The hardware flow control should be selected to No. Do ls /dev and see if tty/USB1 is actually the USB serial port you should be working with. Generally with no other USB serial ports, it sets to tty/USB0.

You should try and get the access to the terminal through the USB serial port first. Once you get that, the rest can be sorted out later.

Great! Thank you.
With the hardware flow to NO and an update on my sdk, I am able to get minicom up to where I see the bootlog scroll by when pressing ‘reset’. If I wait a little bit and hit Return a couple times, I can get a blank

Good to know.

I have never used SSH for access, so can’t say.