Unable to Flash BBB

Hi all, I have tried to flash my BBB with the new Angstrom. I download “Angstrom Distribution (BeagleBone Black - 2GB eMMC) 2013-09-04” and put it onto my 4GB SD card using “win32diskimager-v0.9-binary”
All went well. I then put it in and held down the button near the SD card and waited 45mins. I came back and all the lights were no longer flashing.

I restart the BBB and this screen comes up (Note: it is the same screen that came up before I flashed it)

This is not the version I flashed. I flashed the current version. If I try to flash it (Like I currently am again) this screen comes up.

Any help would be great. I have been on this for hours now.


Are you pulling the power after the flashing process and reinserting it?



Yes. Once it has stopped flashing I do unplug it… Is that the problem?

No, that is what you are supposed to do. If you follow the instructions found at the link I sent you, it will work. You can try the latest version or use and older version followed by the latest to get the process down.


When I flash the BBB should anything show up on the screen? Because while its flashing I get the same LOGIN screen I posted before… is this normal?

For some reason it is all working now. I tried 5 times and as soon as I ask ft starts working :slight_smile:

The only thing I think I did differently is that I removed the straight away. So once the LEDs stopped flashing I powered off (Removed the USB cable) then took out the SD card. Then I placed the USB cable and powered up. I think before I might have done this after powering up again… I’m not sure though.

I think the link you gave me is much better than the one used on the main page.

Anyway, I think its working now. Thanks Gerald.


Yes,the USB cable should not be connected when flashing. You have to remove the USB cable and the power for the boot mode to be reset.