unable to gain DHCP lease (no dhcpoffers received) BBB

My distribution is a bit unusual, in that it is the Botic version of debian


With the stock Debian I am able to get a DHCP lease.

Configuring /etc/network/interfaces identically in the Botic version however fails.

lsusb shows the device as:
Bus 001 Device 002: ID 2001:3308 D-Link Corp. DWA-121 802.11n Wireless N 150 Pico Adapter [Realtek RTL8188CUS]

iwconfig shows:
wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:on

/etc/network/interfaces (partial):
allow-hotplug eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
wpa-ssid “ssid”
wpa-psk “passphrase”

on boot the interface is not up
forcing ifup wlan0 results in failure to get DHCP lease.

Variations on this configuration using wpa-supplicant and more verbose configurations for the SSID have also not worked.

wicd-curses/wicd has also not worked.

This cannot be a hardware issue as the dongle behaves normally on the Debian stock for C and the current Debian 7.8 image for SD.

Any suggestions on what to try or what might be misconfigured?

Again the error is just: no dhcpoffers received