Unable to get output from DVI

Hi,

I’m trying to get output from DVI but could not succeeded to display and thing on TV. I followed setps in
http://code.google.com/p/beagleboard/wiki/HowtoUseSGXunderAngstrom

I’m sure that pixel form is RGB565. There are some outputs listed bellow, If I type “gl2info” I get lots of configuration options displayed.
When I plug HDMI cable to my LCD TV no image is displayed, even my TV did not recognized resolution.

root@beagleboard:~# cat /proc/version
Linux version 2.6.29-omap1 (borat@borat-laptop) (gcc version 4.3.3 (Sourcery G++ Lite 2009q1-203) ) #3 PREEMPT Wed Oct 21 16:31:22 EEST 2009

root@beagleboard:~# cat /proc/cmdline
console=ttyS2,115200n8 nwhwconf=device:eth0,hwaddr:00:09:df:6f:15:52 root=/dev/nfs nfsroot=192.168.1.40:/beagleboard,nfsvers=2,rsize=4096,wsize=8192,tcp ip=192.168.1.56::192.168.1.1:255.255.255.0 omapfb.mode=dvi:1280x720MR-16@60

cat /proc/pvr/version
Version 1.3.13.1607 (release) /home/borat/Projects/Home/BeagleBoard/asistantlinux/arago/arago-tmp/work/beagleboard-none-linux-gnueabi/omap3-sgx-modules-1.3.13.1607-r36/omap3-sgx-modules-1.3.13.1607
System Version String: SGX revision = 1.2.1

cat /proc/fb
0 omapfb
1
2

root@beagleboard:~# opkg info libgles-omap3
Package: libgles-omap3
Version: 3.00.00.09-r1.3
Depends: update-rc.d, libc6, libgcc1
Recommends: libgles-omap3-tests, omap3-sgx-modules
Status: install ok installed
Architecture: armv7a
Installed-Time: 1256648592

root@beagleboard:~# fbset -i

mode “1280x720-60”

D: 64.000 MHz, H: 44.444 kHz, V: 59.979 Hz

geometry 1280 720 1280 720 16
timings 15625 80 48 3 13 32 5
accel false
rgba 5/11,6/5,5/0,0/0
endmode

Could you please help me to solve it ?

Best Regards,
Bora

Any help, comment ???

Try to add omapdss.def_disp=dvi into the bootarg

Thank you very much but unfortunately it didn’t helped. Right now my cmdline is live bellow but still not working.

root@beagleboard:~# cat /proc/cmdline
console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait omapfb.mode=dvi:1280x720MR-16@60 omapdss.def_disp=dvi

Are you sure this is not a power supply issue? Have you tried diagnosing the Beagleboard with this site: http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation.

If it fails that display and audio test it could be due to Power problems.

If you connect the Beagleboard's power into the usb port of the pc you will have this issue on the dvi port due to electrical reasons.

We power our beagleboards from external usb hubs, which by default offer more amps per USB port.

Can you see the angstrom logo while booting up?

Please provide output of command 'cat /sys/devices/platform/omapdss/display0/timings'.
Meanwhile try this command 'echo 74000,1280/220/110/40,720/20/5/5 > /sys/devices/platfor m/omapdss/display0/timings'.

Bora Tunçer <boratuncer@gmail.com> [2009-10-30 16:50:36]:

Hi Everybody,

Thank you very much for help, I’m very happy because now I’m able to display images trough DVI interface on 720p resolution. Pb was not the power but timings for given resolution. My timings was “6250,1280/80/48/32,720/3/6/5”, pixel clock are too low etc…

When I write these values I get picture “74000,1280/220/110/40,720/20/5/5”. So I have question about meanings of parameters. Which one is pixel clock, Which parameters are blanking values and porch values ?

For value “74000,1280/220/110/40,720/20/5/5” I assume that ;

pixel clock : 74000

width : 1280
horizontal blanking : 220
horizontal front porch : 110
horizontal back porch : 4

height : 720
vertical blanking : 20
vertical front porch : 5
vertical back porch : 5

Is my assumption true ?

Best Regards,
Bora

2009/11/1 Petr Štetiar <ynezz@true.cz>

Take a look overhere:
http://groups.google.com/group/beagleboard/browse_thread/thread/d3a503c2a0293d32/17861449804488b4?lnk=gst&q=Using+a+HDTV+with+the+Beagleboard#17861449804488b4

/Quist

good tutorial, thank you very much. And I can clearly say that I had the problem pictures are shifted left with using timing values; “74000,1280/220/110/40,720/20/5/5” and when I change to “74250,1280/110/220/40,720/5/20/5” then everything is perfect.

Best Regards,
Bora

2009/11/3 Quist <karsten.quist@gmail.com>

I am glad it fixed your problem.

This must mean that my HDTV is not the only one requiring these
swapped timing. I don't understand why not all people have this
problem, but I guess most TVs (and also my PC monitor) can do an auto
adjust so they never see the issue.

Maybe the inplementation of the video driver (DSS2) or the OMAP3 has
the timing swapped somewhere? I will look into that later...

Quist

Hi, everybody

I’m new to Linux,
When I try the cat, it returns:
72000,1280/220/110/40,720/20/5/5

When I try to echo… the system returns “Permission Denied”.
I try to google but it seems no thread about such kind of error.
Any assistance would be appreciated.

Hi,

I found the solution so I post here too.
(In case someone like me is a beginner for Linux)

Use tee instead of echo directly.

$ echo “72000,1280/110/220/40,720/5/20/5” | sudo tee /sys/devices/platform/omapdss/display0/timings

Now the display is in center of my Sony HD TV, however the edge is still cut-off.
I’ll continue to do more googling, probably needs to adjust the parameter.

B. Regards.

Eric