Unable to locate package in beaglebone black Rev C with Debian 8

Hello Everyone,

I am a newbie for beaglebone black. I got my beaglebone black few days before and trying to install matplotlib. I am getting E:Unable to locate package python-matplotlib.

I got my beaglebone black Rev C with debian 8 jessie and python 2.7 installed

I tried following commands to install matplotlib:

sudo apt-get install python-matplotlib

pip install python-matplotlib

then I tried update and upgrade and again tried above commands but no success.

Any help would be very useful. As I am stuck.

Thanking you in advance.

According to the Debian package documentation jessie should contain “python-matplotlib” with version 1.4.2:
https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=python-matplotlib

The commands to install the Debian package (omit the dollar sign):
$ sudo apt-get update
$ sudo apt-get install python-matplotlib

You may also look for a matching package in the repository:
$ apt-cache search matplotlib

On Wed, 19 Dec 2018 19:26:47 -0800 (PST),
alekarasma@gmail.com declaimed the following:

Hello Everyone,

I am a newbie for beaglebone black. I got my beaglebone black few days
before and trying to install matplotlib. I am getting E:Unable to locate
package python-matplotlib.

  99 and 44/100 % the odds are that you do not have a network connection
(unless you set up internet connection sharing on the host computer, the
USB connection does not have access to the rest of the world).

  Make sure you have a valid internet connection from the BBB. Easiest is
to run a cat-5 (or better) cable from the BBB to your router, then reboot
the BBB.

I got my beaglebone black Rev C with debian 8 jessie and python 2.7
installed

  Rather old; Stretch has been out for over a year. Might be recommended
to obtain an 8+GB SD card, download the current OS image
http://beagleboard.org/latest-images (if you are planning matplotlib, you
probably want the LXQT image to support graphics)
Insert it into the BBB and boot. Configure the SD card as needed (apt-get
update/apt-get upgrade, install any custom packages, etc. When the SD card
is working as you want, THEN consider converting it to a flasher image,
reboot to flash the eMMC, and then remove the SD card (since a reboot would
just reflash the same data).

  Without network, (on a Stretch image), the apt-get for matplotlib
throws lots of errors about not being able to connect to the repository.
Connecting a cat-5 and rebooting, and it installed with no problems (along
with have a hundred related packages matplotlib needs).

Thank you Tarmo and Dennis for a reply. I have already connected an ethernet cable and enabled sharing and I have as well tried commnds mentioned by Tarmo but no luck.

I am getting 100% data loss for ping 8.8.8.8 and This is the output I get after update.

`
Err http://repos.rcn-ee.com jessie InRelease

Err http://repos.rcn-ee.com jessie Release.gpg
Could not resolve ‘repos.rcn-ee.com
Err http://ftp.us.debian.org jessie InRelease

Err http://ftp.us.debian.org jessie-updates InRelease

Err http://ftp.us.debian.org jessie Release.gpg
Could not resolve ‘ftp.us.debian.org
Err http://ftp.us.debian.org jessie-updates Release.gpg
Could not resolve ‘ftp.us.debian.org
Err http://security.debian.org jessie/updates InRelease

Err http://security.debian.org jessie/updates Release.gpg
Could not resolve ‘security.debian.org
Reading package lists… Done
W: Failed to fetch http://ftp.us.debian.org/debian/dists/jessie/InRelease

W: Failed to fetch http://ftp.us.debian.org/debian/dists/jessie-updates/InRelease

W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease

W: Failed to fetch http://repos.rcn-ee.com/debian/dists/jessie/InRelease

W: Failed to fetch http://repos.rcn-ee.com/debian/dists/jessie/Release.gpg Could not resolve ‘repos.rcn-ee.com

W: Failed to fetch http://ftp.us.debian.org/debian/dists/jessie/Release.gpg Could not resolve ‘ftp.us.debian.org

W: Failed to fetch http://ftp.us.debian.org/debian/dists/jessie-updates/Release.gpg Could not resolve ‘ftp.us.debian.org

W: Failed to fetch http://security.debian.org/dists/jessie/updates/Release.gpg Could not resolve ‘security.debian.org

W: Some index files failed to download. They have been ignored, or old ones used instead.

`

output of my cat /etc/apt/sources.list

`
deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
#deb-src http://ftp.us.debian.org/debian/ jessie main contrib non-free

deb http://ftp.us.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.us.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free

#deb http://ftp.debian.org/debian jessie-backports main contrib non-free
##deb-src http://ftp.debian.org/debian jessie-backports main contrib non-free

#Kernel source (repos.rcn-ee.com) : https://github.com/RobertCNelson/linux-stable-rcn-ee

If you can't even ping 8.8.8.8, then your networking bridge is not setup..

Regards,

On Wed, 26 Dec 2018 15:16:53 -0800 (PST),
alekarasma@gmail.com declaimed the following:

Thank you Tarmo and Dennis for a reply. I have already connected
an ethernet cable and enabled sharing and I have as well tried
commnds mentioned by Tarmo but no luck.

I am getting 100% data loss for ping 8.8.8.8 and This is the output I get
after update.

  If you can't ping Google's nameserver, you do NOT HAVE networking set
up.

  Using USB with a host computer that does NOT have connection sharing
active:

"""
debian@beaglebone:~$ ifconfig
eth0: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC> mtu 1500
        ether d0:39:72:18:3e:e5 txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 0 bytes 0 (0.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
        device interrupt 53

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
        inet 127.0.0.1 netmask 255.0.0.0
        inet6 ::1 prefixlen 128 scopeid 0x10<host>
        loop txqueuelen 1000 (Local Loopback)
        RX packets 1280 bytes 88000 (85.9 KiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 1280 bytes 88000 (85.9 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
        inet 192.168.7.2 netmask 255.255.255.252 broadcast 192.168.7.3
        inet6 fe80::d239:72ff:fe18:3ee7 prefixlen 64 scopeid 0x20<link>
        ether d0:39:72:18:3e:e7 txqueuelen 1000 (Ethernet)
        RX packets 845 bytes 76867 (75.0 KiB)
        RX errors 0 dropped 4 overruns 0 frame 0
        TX packets 88 bytes 20650 (20.1 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
        inet 192.168.6.2 netmask 255.255.255.252 broadcast 192.168.6.3
        ether d0:39:72:18:3e:ea txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 0 bytes 0 (0.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

debian@beaglebone:~$ ping 8.8.8.8
connect: Network is unreachable
debian@beaglebone:~$
"""

  Connecting a CAT-5 to my network router, and rebooting -- still SSH
using USB (192.168.7.2) as I don't want to dig up the extension cord and
power supply (otherwise I'd be using SSH over my network and not via USB).

"""debian@beaglebone:~$ ifconfig
eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
        inet 192.168.1.69 netmask 255.255.255.0 broadcast 192.168.1.255
        inet6 2600:1700:e630:890:d239:72ff:fe18:3ee5 prefixlen 64 scopeid
0x0<global>
        inet6 fe80::d239:72ff:fe18:3ee5 prefixlen 64 scopeid 0x20<link>
        inet6 2600:1700:e630:890::44 prefixlen 64 scopeid 0x0<global>
        ether d0:39:72:18:3e:e5 txqueuelen 1000 (Ethernet)
        RX packets 49 bytes 6158 (6.0 KiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 125 bytes 18827 (18.3 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
        device interrupt 53

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
        inet 127.0.0.1 netmask 255.0.0.0
        inet6 ::1 prefixlen 128 scopeid 0x10<host>
        loop txqueuelen 1000 (Local Loopback)
        RX packets 164 bytes 13240 (12.9 KiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 164 bytes 13240 (12.9 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
        inet 192.168.7.2 netmask 255.255.255.252 broadcast 192.168.7.3
        inet6 fe80::d239:72ff:fe18:3ee7 prefixlen 64 scopeid 0x20<link>
        ether d0:39:72:18:3e:e7 txqueuelen 1000 (Ethernet)
        RX packets 256 bytes 32650 (31.8 KiB)
        RX errors 0 dropped 4 overruns 0 frame 0
        TX packets 69 bytes 16126 (15.7 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
        inet 192.168.6.2 netmask 255.255.255.252 broadcast 192.168.6.3
        ether d0:39:72:18:3e:ea txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 0 bytes 0 (0.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

debian@beaglebone:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=121 time=22.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=121 time=22.3 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=121 time=21.6 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=121 time=21.8 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=121 time=20.9 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=121 time=21.7 ms
^C
--- 8.8.8.8 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5007ms
rtt min/avg/max/mdev = 20.996/21.899/22.748/0.575 ms
debian@beaglebone:~$
"""

  Note the extra information shown for eth0

{I was going to put in a traceroute, but it seems that command is not
available in net-tools as documented on the web... found it in just
package traceroute}

debian@beaglebone:~$ sudo apt-get install traceroute
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  traceroute
0 upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
Need to get 51.1 kB of archives.
After this operation, 124 kB of additional disk space will be used.
Get:1 http://deb.debian.org/debian stretch/main armhf traceroute armhf
1:2.1.0-2 [51.1 kB]
Fetched 51.1 kB in 1s (36.1 kB/s)

  <SNIP>

debian@beaglebone:~$ traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 dsldevice.attlocal.net (192.168.1.254) 0.830 ms 0.731 ms 0.398 ms
2 76.255.152.1 (76.255.152.1) 25.995 ms 27.292 ms 34.703 ms
3 71.152.176.29 (71.152.176.29) 18.978 ms 20.659 ms 20.582 ms
4 cr2.cgcil.ip.att.net (12.123.7.142) 29.214 ms 29.309 ms 32.375 ms
5 12.123.159.49 (12.123.159.49) 26.685 ms 26.877 ms 27.899 ms
6 12.247.252.10 (12.247.252.10) 28.592 ms 12.247.252.14 (12.247.252.14)
21.970 ms 12.247.252.6 (12.247.252.6) 22.450 ms

(that's enough of that... First node listed is my network router)

Thank you so much dennis. I tried above steps and its working now.

Thanks once again