Unable to manually load dtbo to bone_capemgr slots


I started Reading about dts files a few days ago and wrote my own to set P8.42, P8.43, P8.44 and P8.46 as gpio outputs. I compiled it and tried to echo it to /sys/devices/platform/bone_capemgr/slots, but I get no response (my terminal just stops).

Here’s what I get on dmesg’s last lines:
[ 407.020467] bone_capemgr bone_capemgr: part_number ‘bb-gpio’, version ‘N/A’
[ 407.020531] bone_capemgr bone_capemgr: slot #4: override
[ 407.033061] bone_capemgr bone_capemgr: slot #4: auto loading handled by U-Boot


And here’s my custom dts:


/ {
compatible = “ti,beaglebone”, “ti,beaglebone-black”;
/* identification /
part-number = “bb-gpio”;
version = “00a0”;
state the resources this cape uses /
exclusive-use =
fragment@0 {
target = <&am33xx_pinmux>;
overlay {
bb_gpio_pins: pinmux_bb_gpio_pins {
pinctrl-single,pins = <
0x0b4 0x0f /
P8_42 GPIO2_11 /
0x0a8 0x0f /
P8_43 GPIO2_8 /
0x0ac 0x0f /
P8_44 GPIO2_9 /
0x0a4 0x0f /
P8_46 GPIO2_7 */

fragment@1 {
target = <&ocp>;
overlay {
bbgpio : gpio {
pinctrl-names = “default”;
pinctrl-0 = <&bb_gpio_pins>;
status = “okay”;
/oe {
gpio-name = “oe”;
gpio = <&gpio3 11 0x00>;
clk {
gpio-name = “clk”;
gpio = <&gpio3 8 0x00>;
le {
gpio-name = “le”;
gpio = <&gpio3 9 0x00>;
sdi {
gpio-name = “sdi”;
gpio = <&gpio3 7 0x00>;


I tried upgrading kernel (right now, uname -a returns: Linux arm 4.9.41-ti-r53 #1 SMP PREEMPT Thu Aug 10 02:34:57 UTC 2017 armv7l GNU/Linux), disabling audio/vídeo/wireless/adc overlays, enabling/disabling cape_universal, loading internet dtbos (from kilobaser and bbbadventures) and default ones (like cape-universaln) and changing boards (I have 2 BBBs) and installing bb-cape-overlays through apt-get

I think I’m missing something really stupid, because I found nothing regarding this kind of error so far.
If I try to load the dtbos on boot through uEnv.txt, my board stops with the 4 user leds lit, which I understand as a signal that my BBB is not loading the OS. Of course, I can’t ssh it.

What am I missing?

Best regards,

"auto loading handled by U-Boot" see the directions here:



Tried to upgrade my bootloader and my board stopped booting.

Do you have a serial cable to log bootup?

Then we can see where and what caused the boot failure.


I’m sorry for taking so long to reply.
I don’t have a serial cable to see what’s happening. I did what I could do: I erased everything and started again.
This time, I upgraded my kernel with options --bone-channel --lts-4_9 and then it started working!

I really do not understand why it didn’t work before with other options, since I’m using the same dtbo file as before.