Unable to SSH to the system onboard

I’ve got a BBB in less then three days, and I found I cannot login through the SSH panel.
Login through a usb2ttl cable is ok, but everytime I try the SSH, the connection will not establish both on Windows 7 32-bit and Ubuntu.
I follow the instruction on the website:

After I plug in the usb cable, and run ipconfig on ubuntu terminal, the output will be:

steve@steve-Inspiron-M4010:~/Downloads$ ifconfig
eth0 Link encap:Ethernet HWaddr f0:4d:a2:c8:c9:53
inet6 addr: fe80::f24d:a2ff:fec8:c953/64 Scope:Link
RX packets:14 errors:0 dropped:16 overruns:16 frame:16
TX packets:50 errors:0 dropped:0 overruns:0 carrier:4
collisions:0 txqueuelen:1000
RX bytes:5610 (5.6 KB) TX bytes:10823 (10.8 KB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:4984 errors:0 dropped:0 overruns:0 frame:0
TX packets:4984 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:595411 (595.4 KB) TX bytes:595411 (595.4 KB)

wlan0 Link encap:Ethernet HWaddr 1c:65:9d:e3:45:28
inet addr: Bcast: Mask:
inet6 addr: fe80::1e65:9dff:fee3:4528/64 Scope:Link
RX packets:64211 errors:0 dropped:0 overruns:0 frame:0
TX packets:70712 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:68315915 (68.3 MB) TX bytes:10045511 (10.0 MB)

No ip addr like the said in the instruction.
So will any of you give a proper solution on this?

Did you look here?



try dhclient eth0 or udhcpc eth0

If I understand correctly you connect your BBB to an Ubuntu box, right?

did you connect the USB cable as follows: mini-USB in the BBB, big USB (USB-A) in the Ubuntu box?

then you will see an new USB mass memory device (USB-stick) appear in your filemanager

you will also see an usb0 interface appear in ifconfig, but as yet without an IP-address

if all of this does not happen the correct memory modules are not loaded in your Ubuntu box
look for cdc_ether and cdc_subset, In Ubuntu this is however quite unlikely.

then you will have to assign an IP address to the usb0 interface for instance Do NOT select, that is the BBB
then you can ssh to the BBB over usb

ifconfig usb0 up
ssh -l root

eth0 is your wired ethernet which is not in use
lo is your own box
wlan0 is your wireless connection to your provider (China Telecom?)
usb0 will be the connection to the BBB

if you want the BBB to be able to reach the internet (through your Ubuntu box) you need to set up IP forwarding:

iptables --table nat --append POSTROUTING --out-interface wlan0 -j MASQUERADE
iptables --append FORWARD --in-interface usb0 -j ACCEPT

as root on your Ubuntu box.
now you can ssh into the BBB and run updates, or download new packages
the above settings are lost when you shut down your computer.



It looks like your Ubuntu box is not on a private IP-address, and you are not using your own router, looks like.

This may be help you!

Check to see if /etc/dropbear/dropbear_rsa_host_key is an empty file. If so, delete it and start dropbear (/etc/init.d/dropbear start). It will create a new valid file then…