unnoticed issue with weather cape

Hallo, I’ve found a problem with the “weather cape” that I’m planning to use in a student lab.
I’ve bought 5 weather capes release B from Farnell. Two of them work perfectly with beaglebone black and Linux debian.
The other three do not allow linux to complete the bootstrap so that it remain impossible to interact with the board, either from the network and from the console. Apparently the cape are all release B. However i’ve notices that the three that do not work have a serial number initiating with 1514WTHR…, whereas the other two have serial number 1814WTHR… Moreover the color of the board is slightly different.
The two working ones have a color more dark, almost like peanuts butter. My conclusion is that something changed in the hardware, on the way but, at least in my knowledge, has not been noticed.
Does any one have idea of it could be the reason for this misbehaviour? I’ve tried all beaglebones and all Linux images, I’m currently using, with the same result.
Thank you in advance for your attention.
Attilio Giordana