Unstable USB dongles with BeagleBone revision 5

Hi all,

I am having a strange problem with my BegleBone (rev. 5), that I have not been able to figure out. When I connect my 3G USB dongle(s) to the Beaglebone, they are very unstable. What happens is that they work as they are supposed to for a minute or so, before they are automatically (and partly) disconnected and then connected again. In addition to causing a unstable network connection, the dongles do not like this behavior and start misbehaving. They for example stop replying properly to USB “packets”.

The dongles I have tested with are the Huawei E1753 and E173, and I have tried connecting one dongle directly to the board, through a powered USB hub, during boot and after boot, and with power to the board coming from USB and the plug in the wall. The behavior is always the same. The software and scripts used to connect the modems, as well as the modems themselves, work correctly on for example a BeagleBoard-xM and my laptop.

I first suspected the problem to be caused by a BeagleBone-equivalent of the issue mention here, but that doesnt explain why it happens when I only have one dongle connected. The Beaglebone is running the wheezy-armhf demo image from 5. February. I have tried with newer images, but they always freeze during boot.

My question is therefor, has anyone experience similar behavior with USB dongles/USB 3G modems and/or know of any solutions to make them work properly?

Thanks in advance for any help,