Updating kernel from command line without trashing SD card

Hi,

I have a Beaglebone Black running kernel 3.8 (I think - I don’t have access to the BBB at the moment, so this is from memory).
I am using this with a cape to drive a custom display.

I am pretty sure it’s booting from SD card, which has multiple partitions (one labelled rootfs and not visible to windows, and one that windows can access). Both partitions are accessible when I plug into my linux VM.
The SD card is configured such that the display is all set on boot (not really sure how this happens), and I can call scripts that are on the FAT partition by SSHing into the BBB and running from the shell.

There’s a lot I don’t understand about the configuration of the SD card, but as it works, I’m not that fussed.

However, I now want to migrate this over to the Beaglebone Black Wireless and I’m having real difficulty.

My thoughts are that I need to upgrade the kernel to a version closer to 4.4, but I can’t seem to find a method of doing this without completely trashing the SD card.

If this makes sense, can anyone point me in the right direction?

Thanks

Try this:

bone$ cd /opt/scripts/tools
bone$ git pull
bone$ sudo ./update_kernel.sh --bone-kernel

2020-08-24 10:25:12 URL:https://rcn-ee.com/repos/latest/buster-armhf/LATEST-omap-psp [223/223] → “LATEST-omap-psp” [1]

Hi Mark,

I tried the above, but get the following error:

root@beaglebone:~# cd /opt/scripts/tools
root@beaglebone:/opt/scripts/tools# git pull
Already up-to-date.
root@beaglebone:/opt/scripts/tools# sudo ./update_kernel.sh --bone-kernel
syncing local clock to pool.ntp.org
info: checking archive
GnuTLS: A TLS fatal alert has been received.
Unable to establish SSL connection.

Seems like there’s more problems…

Hmmm… I haven’t seen that one before. Maybe a
bone$ sudo apt update
bone$ sudo apt dist-upgrade

is needed.

–Mark

You can try:

sudo apt-get update
sudo apt-get install ca-certificates

But considering the script fell back to pinging pool.ntp.org, you're
on a really really really old Root File System..

Regards,

Hi Robert,

apt-get update threw a few problems including:

Err http://security.debian.org wheezy/updates/main armel Packages
404 Not Found [IP: 151.101.0.204 80]
Err http://ftp.us.debian.org wheezy/main armel Packages
404 Not Found [IP: 64.50.233.100 80]

Then apt-get install ca-certificates threw:

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be upgraded:
ca-certificates
1 upgraded, 0 newly installed, 0 to remove and 269 not upgraded.
Need to get 210 kB of archives.
After this operation, 98.3 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
ca-certificates
Install these packages without verification [y/N]? y
Err http://security.debian.org/ wheezy/updates/main ca-certificates all 20130119+deb7u2
404 Not Found [IP: 151.101.192.204 80]
Failed to fetch http://security.debian.org/pool/updates/main/c/ca-certificates/ca-certificates_20130119+deb7u2_all.deb 404 Not Found [IP: 151.101.192.204 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

If I run uname, this is the response…
Linux beaglebone 3.8.13-bone50 #1 SMP Fri Jan 19 13:52:32 CET 2018 armv7l GNU/Linux

https://wiki.debian.org/DebianWheezy

2018-06-01: End of security updates (i.e End of life. The distribution
is moved archive). (press release)

Sorry, wheezy is EOL, it's got moved to the archive server..

Change everything in /etc/apt/source.list

http://archive.debian.org/debian/

Regards,

Thanks for that Robert.
I’ll have a look at this over the next few days.