USB Hotplug - still broken? (Angstrom 05.27 and RCN Wheezy eMMC flasher 05.29)

I tried both of the images noted in the subject and I still have significant USB hotplug issues.

If I boot without a USB device plugged in, I cannot get a device to be recognized without executing ‘cat /dev/bus/usb/001/001 > /dev/null’.

If I boot with devices plugged in they are always properly recognized. This is the same behavior as all prior images that I have tried - multiple Angstrom images throughout the last month.

Sometimes after I have booted with devices plugged in (which have enumerated properly) I can unplug them and plug them back in and they will be enumerated correctly. Most of the time, however, they are not.

If a device isn’t enumerated after I plug it into a hub (which is plugged into the BBB) and I then issue ‘cat /dev/bus/usb/001/001 > /dev/null’ the shell becomes unresponsive. After a short time, all leds quit blinking and user led 2 remains lit solidly. It would appear the processor is hung.

I get this same behavior with angstrom and debian - 05.27 and 05.29 Wheezy eMMC flasher images, respectively.

What would be the best information to provide to help better isolate what is going on?

Maybe some more data points might help... I only tested with a random
usb flash drive in the lab this morning.. but if you give me your
'lsusb" line of a device that always fails, I might have something
similar in my usb junk box..


I have a MS comfort curve 2000 keyboard, a Logitech Universal receiver (for wireless trackman wheel) and a targus travel hub that shows up as:

05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB

I’ve tried plugging each in on a clean boot and only the ‘cat’ trick gets them to enumerate. I can pastebin a dmesg if that might help.

I have some updated info.

It would seem that the BBB really doesn’t like that hub.

I can plug and unplug all sorts of other devices, including another hub (SMSC2641) with devices plugged into it and it continues to handle hotplug without issue.

Once I plug in that Targus hub, the BBB USB hotplug is dead. I can plug and unplug that hub all day on my laptop without issue, but once it has been connected to the BBB, the BBB will no longer recognize any hotplug devices.

I did have an odd issue while testing - one time when I plugged a USB storage stick into the BBB the ethernet PHY locked up - my SSH connection went unresponsive and when I unplugged the ethernet cable both LEDS on the RJ45 remained lit. A hard reset fixed it. Makes me suspicious of an ESD or ground noise issue.

Anyway, I will try some more devices and see if I can track down one or two more USB hubs for comparison.