USB Power vs 5 volt Source and SD Errors

I have an issue with an SD card that works fine with USB Power but fails after a while under 5V Power.

I understand that the B**3 runs “Faster” with 5V Power sources. I can see the performance bump.

Is it possible that an SD Card works only at the “Slower” Card Clock?

I have tried a few cards and only this 32G SD has these issues. It is the best card I have for a “ROOT” card so I want more information on what to get to replace this “touchy” card with a solid performer.

I have the Latest Updated Beagle Board Black Angstrom OS Update.

What I wanted to do was “expand” the ROOT from 1.9G ==> 32G so I can work on some python code that needs more room. The DD of the OS went well and the “expand2fs” was fine. The “FSCK -f” passed OK.

What I was seeing is that over a “few hours” the OS hung when I was on 5V Power, and worked on USB Power. The performance on 5V power is great, so I did not want to loose that level.


What changes are needed to just use an “external USB Disk” as the ROOT? That would fix by problem also… I could just use an external USB as the “expanded” root for my development.

uENV looks like the place to start, but trial and error will take a long time. Any help here?

The Goal is a DEV Platform with 10’s of G free space to build my project on the ROOT.

Edward M. Goldberg
B**3 Developer.

Not sure if the clock would cause that. What speed class is your card? If you think it is the clock I would try to get a higher class card and try it. May be an 8 or a 10 since they are high speed and should have a higher clock rate. Also they will give you better performance since they will be able to keep up with the processor a little better.