USB slow initialization at bootup on Debian 10

The USB port on the Beaglebone black Rev C board is taking minutes to finally respond after boot.

I have an application for an instrument that autostarts in LXDE. When the application starts, it’s
supposed to go out the USB port and communicate with the instrument system board.

This all worked fine in Debian 7 Wheezy. The same setup in Debian 10 is having the USB response

I’ve tried several BBB and all have reacted the same way. Normal operation with Debian 7 and
no USB response for several minutes in Debian 10.

The mouse connected to the USB port has it’s red LED come on…so it’s getting power, but
the mouse just doesn’t respond ( or a keyboard, touchscreen, etc ) for a long time.

The debug port shows no problems on boot.

Could you supply the output of the following?
sudo /opt/scripts/tools/

Have you looked at the output of dmesg to see if anything is showing there?
Although if you are not seeing it on boot from a serial connection this may not show anything as well:

sudo dmesg | grep -i usb



Yeah this is an issue, i haven't found a good fix for it yet. It
takes a really long time for mouse movements to first happen in xorg..



I think I am also having this problem. It can take minutes before the ttyUSB0 device shows in the /dev directory.

Did you come up with a fix Robert?