About a month ago I disabled the USB login. I forgot the file I edited to do this. I am trying to get back to being able to ssh over USB again. Anyone know the file I edited?

Try :


Thanks of the reply. I dont see the file interfaces in the folder.

More likely you did something with the dropbear config or systemd/systemctl. There are many ways to disable ssh. The first one I would have tried would have been along the lines of ‘systemctl disable dropbear.socket’ or ‘systemctl disable sshd.socket’. I’d have to look to see what systemd service is looking at port 22.

narr is trying to re-enable ssh over USB.

I’m having a somewhat similar problem. When I first got my BBB, I installed the drivers on my Mac and was able to ssh over to it via USB no problem. Yesterday, while trying to share the Mac’s Internet connection via USB with the BBB I did something that disabled this. Before I did whatever it is that I did, I could see in the Network pane of System Preferences that the BBB was connected. Now, I see a bunch of BBB items in the list of devices, but they are all “not configured,” and there is no way to configure them.

Fortunately, I am still able to connect to my home network via the router and ssh to the BBB via Ethernet. I tried updating the software, and while that all seemed to run OK, I’m still unable to SSH over USB.

I checked /etc/network/interfaces, and the lines setting up usb0 are still there, so I don’t think that’s the problem.

Does anyone have any other ideas?

Thanks, Dan