I tried to compile VLC from source on the BBB angstrom distro last night. I did this because there doesn’t seem to be a package for it anymore in opkg. However, I ran into a problem where the configure output for the Makefile is an ELF and isn’t recognized by the make command. In particular, I ran the following:

./configure --disable-lua --disable-mad --disable-glx

VLC recognized the distro as being arm and it finished configuring with no errors reported. However, when I go to make, I get an immediate error:

Makefile:1: warning: NUL character seen; rest of line ignored
Makefile:1: *** missing separator.  Stop.

Has anyone successfully compiled VLC from source on a recent Angstrom distro? And does anyone see a way around this output?


Are you cross compiling? If yes, you should use:

–host=arm-linux-gnueabihf(change for your cross compiler)

For my case I use:

./configure --disable-a52 --disable-mmx --disable-sse --enable-run-as-root --enable-alsa --disable-dvdnav --disable-dvdread --disable-bluray --disable-crystalhd --with-tuning=cortex-a8 --host=arm-linux-gnueabihf --prefix=/home/vini/projs/vlc/target --disable-qt4