VNC and BeagleBone Black

Hello all,

I'm trying to use VNC with my Beaglebone Black and I'm facing some issues.

I'm using the original loaded image of Angstrom on the board.

I installed the correct packages to use VNC on BBB: x11vnc and
angstrom-x11vnc-xinit. I created those packages externally, using
openembedded build script and installed the packages manually.

With the default configuration, I was able to connect to the board
(using the RNDIS connection) and see my desktop remotely.

ISSUE: I was unable to use mouse and keyboard remotely. It seems to be
locked, even when it is not set as a view connection.

Looking to discussion and articles, it seems that people are using the
remote desktop just as screen. keyboard and mouse are attached
directly to the board. I could do this, if I had an USB hub. And, as I
intend to use the USB to attach a webcam, I really need to use
keyboard and mouse from my computer, and not peripherals on the board.

I would like to ask some advice in order to have full VNC working on my board.

Best regards,

Flavio

Not sure what is causing your problems but when I set mine up I used opkg to install those packages and my host keyboard and mouse worked fine.

-Wil

I'm using Ubuntu 12.04 LTS. I tested on Windows 7 too ... with similar problems.

On windows what vnc viewer did you use? I haven’t tried on ubuntu but I do have my raring setup running so I can try it if you like.

-Wil

On Windows I used RealVNC.

That’s what I used and it worked. Have you tried removing you packages and installing with opkg?

-Wil

Same thing,

I removed my packages (x11vnc and angstrom-x11vnc-xinit) and installed
the following:

http://www.angstrom-distribution.org/feeds/v2012.05/ipk/eglibc/armv7a/base/x11vnc_0.9.13-r0_armv7a.ipk

I ran the following command, from a ssh connection:

x11vnc -bg -o %HOME/.x11vnc.log.%VNCDISPLAY -auth
/var/run/gdm/auth-for-gdm*/database -display :0

And I got the same result.

How is your xorg.conf file?

Thank you for your help.

Best regards,

Flavio

Sorry it took so long to reply my damn dropbox was acting up. Here is my xorg.conf
https://dl.dropboxusercontent.com/u/26388266/xorg.conf . Also just tried vnc on my

raring setup and it works. Let me know if you need me to try anything else or need
more info.

What build of Angstrom are you using?

Just curious because i am trying to replicate your problem but i can’t
seem to get it.
Are you using the USB port or Ethernet?
On ubuntu what viewer are you using?

-Wil

What build of Angstrom are you using?

Just curious because i am trying to replicate your problem but i can't
seem to get it.
Are you using the USB port or Ethernet?

I'm using USB RNDIS communication. I didn't try Ethernet communication, yet :slight_smile:

On ubuntu what viewer are you using?

My Ubuntu is 12.04 LTS and I tried with tightvnc (vncviewer) and
Remmina Remote Desktop Client.

It is the same as mine :frowning:

Yeah I have it set up the same way. I have an idea, give me a few minutes and I’ll send you an email with instructions.

-Wil

Ok email sent.

-Wil

Did you try to vnc into my BBB? If so let me know if your keyboard and mouse worked so we can try to figure this out.

-Wil

Hello Wilfredo,

Sorry, I couldn't do that.

I just work on weekends :frowning: ... and I couldn't have time to test.

I gave up for now. I got an USB hub, mouse and keyboard. It works :slight_smile:

Thank you very much for everything.

Best regards,

Flavio

No problem. If you decide to give a try again just let me know and I will put my BBB between north and south Korea on my router.

-Wil

hello i am trying to get x11vnc server to work on beaglebone black dose not work for me i may be doing some thing wrong i have win 7 i have down load realvnc that load and look like working any help will be nice thank you ian

Hi Ian,
Can you provide the steps you took to get it set up and explain what you mean by “does not work”. What message does you screen show when it fails? It will help better understand why it does not work.

hello on win 7 useing real vnc it say a connection could not be established
reason unknown … on beagle bone black when i open x11vnc server still dose not show up i was tell on other fourm i go to open a web put in the ip that bbb so you are connected to the board and put number into vnc but still not work thank you

Just out of curiosity, how many times have you installed x11vnc without uninstalling previous installs?