Watchdog timer and boot process


I’ve been working with both BBB rev B and rev C with the QNX BSP. I’ve modified the .build of the BSP to suit my needs. Everything works fine in the rev B, but the rev C just rebooted after a minute or so. The prebuilt qnx image included in the BSP didn’t have that problem.

After some tests, I’ve found that it was the watchdog that kept rebooting the BBB. So after adding a line that starts a process wich kicks the wtd before it overflows, everything worked just fine.

My question is: What could be the difference between the two platforms? Could it be that the u-boot in my rev C kicks the watchdog or something like that?


Well B -> C is just new 4gb eMMC:

So, now you should really tell us more details, like your "B" is
running u-boot w.x and your version "C" is on u-boot y.z


Thanks for the reply.

These are the U-boot versions according to the log in the debug console

Rev C: U-Boot 2014.04-rc2-00015-g99288ca (Mar 12 2014 - 09:49:41)
Rev B: U-Boot 2013.04-dirty (Jul 10 2013 - 14:02:53)

Option 1: Copy MLO/u-boot.img from Rev B to Rev C


Ok, I tried that. Copyed the MLO/u-boot from B to C and it doesn’t reset itself. So it’s probably a thing of the u-boot after all.

Is this supposed to be a bug? I’ve searched the forum before posting and no one has reported this kind of problem. Or maybe it’s just that the OS initialization has to deal with the watchdog properly, which I didn’t consider.

Thanks for the help.

There's not a lot of qnx users and the "C" with the new factory
bootloader just began shipping last month..


Well, if found this:;a=commit;h=6843918e0035bf06cb65ad2b4c98b38e86e43bd5

Apparently, since that commit, the watchdog is enabled by default by the bootloader. Makes sense, as my B version had an older u-boot.

Guess that the OS has to deal with it.