Web interface to BBB not loading properly on the host browser

Hi folks,

I am brand new to Beagle Bone Black. I am following all available online resources to get started but still not able to solve this mystery : When i connect (via USB only) my BBB to my Ubuntu 20.04 laptop and then type on the FIrefox browser, the Cloud9 IDE loads up on the browser. This is all great and as expected. However, instead of webpages loading properly, all I see is cloud9 IDE and the webpage main body text writting inside the IDE. I do not see any interactive buttons, images etc being loaded. It almost feels like something is wrong with my browser (like js not running, or some other setting). I have tried everything at my browser end and it hasnt changed, I have also tried using a WIn10 PC with Chrome but the same behaviour and then I have updated the BB.org website and again noting has changed!

I think it is just a small setting somewhere in the Cloud9 IDE where it is not displaying webpages as they shouldand rather displaying barebones text within the IDE tab.

Please could you get me out of this mysery…


Has been abondoned by Amazon after they purchased them a few years back. Our Bullseye based images use a fork of VSCode now…



Thank you, that was indeed the problem.