Where is TI C6X CGT installation?

Hello I just finished the steps in BeagleBoard.org - upgrade and updated everything. And checked I clinfo and tried to build the OpenCL examples in usr/share/ti/examples/opencl/ but in both attempts I get the same error:

The C6000 compiler lib/include installation is not located in the default
location (/usr/share/ti/cgt-c6x).
and

…/make.inc:189: *** cl6x not found. Set TI_OCL_CGT_INSTALL to a TI C6x CGT installation.

So the compiler is not installed? In this case how can I install it? Or is it installed in any other location?

Thank you in advance

sudo apt update ; sudo apt install ti-c6000-cgt-v8.3
debian@bbb-pwr01-ser09:~$ cl6x -h
TMS320C6x C/C++ Compiler                v8.3.2
Tools Copyright (c) 1996-2018 Texas Instruments Incorporated
debian@bbb-pwr01-ser09:~$ which cl6x 
/usr/bin/cl6x
debian@bbb-pwr01-ser09:~$ ls -l /usr/share/ti/cgt-c6x/
total 8
drwxr-xr-x 6 root root 4096 Oct 29 14:04 include
drwxr-xr-x 3 root root 4096 Oct 29 14:04 lib

you might have to export:

export C6X_C_DIR="/usr/share/ti/cgt-c6x/include;/usr/share/ti/cgt-c6x/lib"

Regards,

2 Likes

Hello, thanks for your help.

I tried to follow your commands but apparently it is already installed:

debian@beaglebone:/$ sudo apt install ti-c6000-cgt-v8.3
Reading package lists… Done
Building dependency tree
Reading state information… Done
ti-c6000-cgt-v8.3 is already the newest version (8.3.2-0rcnee0~stretch+20200323).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

However, “cl6x -h” returns “command not found” and “which cl6x” returns nothing. So I am quite confused.
I also checked “/usr/share/ti” folder and there is no “/cgt-c6x” but there is “/cgt-pru”:

debian@beaglebone:/usr/share/ti$ ls
cgt-pru examples opencl tidl

where this is found, which I dont know if are the ones or not:

debian@beaglebone:/usr/share/ti/cgt-pru$ ls -l
total 16
drwxr-xr-x 2 root root 12288 Aug 4 2019 include
drwxr-xr-x 3 root root 4096 Aug 4 2019 lib

So what is happening here?

Weird,

try forcing it…

sudo apt install ti-c6000-cgt-v8.3 --reinstall

Regards,