Where to obtain source code to uImage_revc.bin uploaded on Google Code?

Hi all,

I've been trying to get audio to work using the latest kernel tree
(2.6.29-rc2) from the official linux-omap GIT repository without any
luck. I tried it with Steve Sakoman's audio patch and also with
Koen's Angstrom patches but still no luck. I always get the following

[root@OMAP3EVM /root]# aplay test.wav
Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 8000 Hz,
aplay: pcm_write:1266: write error: Input/output error

However, today I downloaded the 2.6.28-omap1 uImage_revc.bin (recently
uploaded to http://code.google.com/p/beagleboard/downloads/list) and
audio works fine. Does anyone know how I can get that 2.6.28-omap1
source tree? From this link (http://code.google.com/p/beagleboard/
wiki/BeagleboardRevCValidation), it points to the source to
http://www.beagleboard.org/linux-2.6.git/ but I'm not sure how to get
that snapshot. Thanks!


Hi guys,

Sorry to really bother you but I need your help. I've been spending the last 4 days trying to build a kernel with audio support for my beagle board (rev B5) without any luck. I have been getting different snapshots (2.6.28-omap1, 2.6.29-rc2) from the official l-o git site and building them with beagleboard ALSA audio support enabled and I always getting the "write: Input/output error" while playing a way file or a alignment exception crash. I also downloaded the Angstrom patches (http://cgit.openembedded.net/cgit.cgi?url=openembedded/tree/packages/linux/linux-omap&id=6a6d6bab519aefb44e3d49d305134057adf7539e) and applied them to the l-o tree, rebuilt the kernel, and the same problem still occurred. I downloaded Steve Sakoman's l-o git snapshot, built it, and still the same audio issue occurs. Everything seems to work except for the audio.

I downloaded the pre-built Angstom kernel (2.6.28-omap1) and also the only just available for Rev C (uImage_revc.bin) and audio works fine! I'm not sure what I'm doing wrong in building the kernel that the audio doesn't work. I'm using the arm-2007q3 toolchain. I switched to the new arm-2008q3 toolchain and same audio issue. The reason I need to rebuild the kernel because I need to do driver development; I need to get TI's open source DSP/BIOS DSPLINK driver compiled against the kernel in order to load the dsplinkk.ko module properly. Our application is an audio application so I need audio to work.

Unless I can figure this out (hopefully you guys can help), I'm at the point where I'm going to download the whole Angstrom demo source (most of which I don't need) and do a build a scratch to see if I can produce a audio-working uImage. Can anyone please advise? Thanks.