Which is the suitable kernel version for camera application in yoctoproject1.4

Hi all,

Can anyone please tell me which is the most suitable kernel version for camera application in yocto project 1.4 with poky build (beagleboard-dylan-9.0.0)
I have Beagleboard-xM revision C with two camera module LI-LBCMVGA and LI-LBCM3M1.
My application is to take a picture using beagleboard-xM at present.

Vishal