Why my BeagleBoard Rev C4 can not boot with an SD Card


I first created and formatted the SD card into two partitions: one is
FAT32, another is ext3; according to the instructions from

Then I copied MLO, u-boot.bin, x-load.bin.ift and uImage to the FAT32
partition; copied and extracted Angstrom..bz2 and modules...tgz to the
ext3 partition.

When power up, the terminal stopped at "I2C ready". The following is
the complete terminal log

Your MLO image is too old. Search the archives from this mailing list
to find out all the details.

Simple, this issue has been brought up many times on this list...

U-Boot 2010.03 is not and never will be compatible with X-Loader 1.4.2

Hold the user button down at power-up to force the omap35 to read the
mmc card on boot.. (you have MLO copied first?)

then re-flash MLO and u-boot, directions here:




I powered up the board while pressed the USER button, and beagle booted from SD card.

But after load u-boot, it didn’t locate uImage,

what’s the problem this time? The following is the log.



Sorry, the complete log file is the following:

Reformat your sd card and recopy the uImage, the first fat partition
seems to be corrupt...


Thank you! The problem is solved after re-formatting the SD card.


I have faced a similar problem (Log below). But I dont get the
"Invalid FAT entry". So I assume that my boot (VFAT) partition is not
corrupt. Could anybody throw some light on this as how to come out of
this issue.


For this, what does:

mmc init
fatls mmc 0:1

print out?


have you renamed the uImage file to uImage.bin???
make appropriate changes to bootcmd


This is the _only_ procedure I have found to work with my BeagleBoard rev C4.

I tried the instructions in Chapter 12 of the BeagleBoard System
Reference Manual and
and they are confusing, because they are full of exceptions for
different versions of the board and are incomplete and difficult to
follow. All attempts to find and use the HP SD flash formatter
programs that run on Windows failed. All attempts to determine
exactly which files go into which partitions and why led only to
frustration and doubt.

One main difference between the instructions that work and the ones
that don't is: you only need MLO, u-boot.bin, and uImage in the first
partition of the SD flash. And, yes, uImage must be in the first
partition, even though it is extracted from the tar-ball and put in
the second SD flash partition along with the root file system.


Mike Nelson, http://michaeltnelson.com
mobile: 1-650-291-7343
office: 1-650-257-7565