Why read-only rootfs is mounted.

Dear All,
I’m trying to port linux on beaglebone using Buildroot.

But rootfs is mounted as read-only, but I need write-enable. What shall I do

Following is snap of my configurations

1.Kernel configuration file as below …

Boot options

Wasn't linux already ported to beaglebone over a year ago?

Buildroot's default is to mount the root filesystem as read-only.
There's an option in the Buildroot configuration menus under "System
Configuration" to change this. It is the
BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW option in the config file.

Or you could manually remount the root filesystem by running:

mount -o remount,rw /

Thanx Frank,

It worked, Thanx again.