wifi help please

Thanks for the suggestion - I gave this distribution a try and had similar problems. The dongle wouldn’t work at all unless an extension cable was in place. Overall I’ve been very disappointed in the wireless capabilities of the current generation BeagleBone. Others have reported that they could get it working, but I don’t have much to show for many frustrating hours spent looking for a reliable solution. I’ve got one of the wifi capes on order, so hopefully that and/or the next generation BeagleBone will be better.

FWIW, this Ubuntu distribution gave me the following error on startup when using the dongle, in spite of having plenty of extra 5V power:

[ 2.505512] usb 1-1: rejected 1 configuration due to insufficient available bus power

I was able to work around this by doing the following:

echo 1 > /sys/bus/usb/devices/1-1/
bConfigurationValue

The dongle then established a wifi connection, but it’s not very solid and seems to drop out after a while. I don’t think it’s a problem with my router since both Windows and OSX hosts have no problems using the same dongle for rock solid connections.

I’ve tried the following two dongles under both Angstrom and Ubuntu and had the same behavior. One uses the RTL8192 chipset and the other uses the RTL8188CUS chipset.

http://www.intellinet-network.com/en-US/products/9568-wireless-300n-high-gain-usb-adapter
http://www.intellinet-network.com/en-US/products/9622-nano-150n-wireless-usb-adapter

Has anyone else gotten rock solid wifi connections with the BeagleBone? If so, what is your exact configuration? Do you use an extension cable?