Wifi not working.

Hi Robert,

I am failed to bring up the Wifi on Ubuntu Distro running on Beagle board.

I have tried the other way as mentioned below

  1. downloaded code from http://code.google.com/p/beagleboard/wiki/BeagleSourceCode
  2. Edited the .config file for the following


  1. loaded the uImage on SD card and switched on the Beagle Board.

It is still not recognizing the Wifi device attached to self-powered USB HUB connected to OTG port.

Do you have any idea what is missing here?

Please give me some pointer on this issue.

Thanks & Regards


I have had success under both debian and angstrom with my zd1211 wifi.
When using the otg port, I must power the beagle up with no usb
plugged in, once booted, then apply power to the powered hub (don't
leave your wifi card powered from last boot or it won't work) then
plug in usb. I find that sometimes this does not even work, but
usually does, but only with 2.6.29 kernel. Hope this helps.


What does lsusb / dmesg show…? Which wifi adapter are you using…?

Sean: your problem is probably firmware not being loaded because as the kernel boots it tries to load the firmware before the root filesystem is mounted. You can either change the kernel config to build it as a module or you can embed the zd1211 firmware into the kernel image…