Wifi Problems - Edimax

Ok, I just got my self a BBB and have been trying to get wifi working with the popular Edimax Wifi Dongle.

I have tried the steps shown at both of the following pages.



The BBB does not even see the Edimax, as when typing in IFCONFIG it does not show. The Edimax’s blue LED does not come on either.

I have also performed the following troubleshooting:-

Power supply is plenty - 5v 4amp.
Plugged the Edimax directly into the USB of the BBB without any hub.
The Edimax is fine, as it works with my Windows machine.
The USB on the BBB seems fine as I can use a mouse and keyboard without an issue
Ethernet works without any issues.

I can live with the fact that my BBB doesn’t work on my monitor and that I cannot use an SD card to boot from. But I really need to get it going with Wifi, so any suggestion are very much welcome!

p.s. Is everyone else having these sorts of problems…or is it me and my BBB?


You might try using an extension cable as indicated at http://circuitco.com/support/index.php?title=BeagleBoneBlack#WIFI_Adapters

You also need to update to the latest official SW. http://circuitco.com/support/index.php?title=Updating_The_Software


Yep the latest distro did the trick…thanks!

Great! Glad it worked!


I know this one is complete but wanted to refresh since I just tired the $10 Edimax mini wifi from amazon( http://amzn.com/B003MTTJOY ) and got it working with Debian wheezy running Machinekit super easy:

show the Edimax is recognized after plugging it in:

lsusb | grep Edimax

See there are some RTL firmware installed:
ls /lib/firmware/rtlwifi/

Install the WPA Supplicant package for WPA2 security
sudo apt-get install wpasupplicant

Edit/create the WPA Supplicant configuration file for your network:
sudo vi /etc/wpa_supplicant.conf

pairwise=CCMP TKIP

Enable the automatic start of your wifi network:
sudo vi /etc/network/interfaces

Use these settings:

WiFi Example

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant.conf
wpa-driver wext

Load the module, then start the wlan0 interface:
sudo modprobe rtl8187
sudo ifup wlan0

Check to see your network is up and has an IP address.