Wifi unreliable

Hey everyone,

I have been using the BBB now for quite a while and I really like it. There is only one persistent problem I do not seem to get rid of. So I hope you can guide me into the right direction.

I am using the Ourlink wifi dongle to connect to the internet and wicd-curses to set up the wifi. Initially it seems to work fine.

However, quite often the dongle disconnects and I am no longer connected to the internet. I am unsure how to proceed or what I could try. A couple of observations/comments:

  • I am using an external usb hub and the beaglebone is also powered from a 5V wall plug. So sketchy power supply should not be the issue as some people indicate.
  • Interestingly wicd-curses still indicates that it is connected, however the router does not confirm that and I cannot connect to the BBB.
  • It seems to happen more often when I try to run BTSync to push a lot of data through the BBB to an external HDD. If it sits just there and idles it can be online for days without problem.

Do you guys have any advice what to try? I am quite lost and the internet does not give me any more help…


Hi Tommi,

The only way I could do it was follow this post:

@Tommi -

I have a similar setup and use a variety of 80211 usb plugs via a usb hub and external power source. One is a Realtek RTL8188CUS using the RTL8192cu driver (the plug you use is a true RTL8192cu.) Ideas:

  • Receive Signal Strength (RSS) plays a big part and can vary dramatically by location and plug. If it’s below -60dB you will drop packets, below -70dB and it gets bad. Yes, TCP is a reliable protocol but I’ve found that some plugs just stop when the noise level is too high. I run WPA2 and I suspect the plug will loose connection and then cannot re-negotiate a good eapol exchange when reconnecting - dead in the water at that point.

  • To get signal strength 1) install iw and use “iw dev wlanX link” or 2) use “sudo wpa-cli -y -n0 -p strength”. Option 2 is less reliable than 1.

  • The Ralink RT537 and RTL8187 plugs seem to perform better. Try another device/driver combination, maybe will work better for you.

  • The Atheros chipsets are suppose to be great; the post mentioned about Ubuntu supports them but Debian not so much. I’m thinking of switching to Ubuntu just because I run that on my other systems. I don’t know why I haven’t tried the Atheros plugs - maybe cost?


thanks for your replies.
I just ordered a different USB plug, let’s see if that improves things. After tinkering so much with it, it seems the better options. In the end it is probably cheaper spending another $14, rather than sitting hours of hours trying to fix it. Hope the TP-LINK TL-WN722N will help.

I’ll also try to also do what you suggest Dave, let’s see if that helps too. Have to say it is a bit annoying that such a simple problem keeps you from using the beaglebone…


We had similar problems with RTL8192/Realtek dongles. We moved to TP-LINK 722 and so far its been super! We’ve tested streaming video for over 2 weeks with it now.

As David mentioned, Atheros seems to play well with Debian. You can’t go wrong with the TP-LINK


Thanks, I really hope it will work. It is amongst the most frustrating things to have something that works sometimes…

No problems with Atheros (TP-LINK 722). Use them all the time with Debian for video and audio streaming.

Heh going on two years now since this board has been out to the public, and still no one listens . . .

Wow that TL-WN722N has a BIG-ass antenna! BTW, the ath9k driver is in the kernel but I don’t think the firmware is packaged for Debian (htc_9271.fw according to driver code.) So it’s not plug-and-play but it’s easy to find the firmware file in Ubuntu distros and download it to the BBB. Check syslog when you first plug it to see what the system says. Yeah, simple problems… OTOH I’m still pretty amazed I can run a full linux distro on a 1W card and most peripherals work. Dave

Correct, that firmware currently isn't in a *.deb package yet, so we
manually add that firmware for the bb.org images.


Correct, that firmware currently isn’t in a *.deb package yet, so we
manually add that firmware for the bb.org images.

@RCN - I’m using your great image-builder scripts and integrating my kernel and u-boot. The beagleboard.org_image.sh, etc. don’t seem to have the ath9k firmware, or a way to get it. Is there a list of files you add when doing the bb.org images?

I’m thinking I’ll buy one of these cards to test out…


as long as: include_firmware=enable...



Small update, I got the TL-WN722N to work. Since yesterday evening it is online, hope it will stay that way.

The biggest problem was that wlan0 was already taken from the old dongle, so it now runs on wlan3.

first I followed this instructions: (not sure if I had to :))

Then I had some problems that I would see wlan3 in iwconfig, but wicd-curses would not be able to access it (added wlan3 in prefs)

I think adding wlan3 to /etc/network/interfaces did the trick for me.

thanks for all the suggestions, I think I am now happy (until the next problem…)

You can cleanup the old (not plugged in) devices in:


To get back down to wlan0..


Thanks, good to know!

Though at this point I might go with the mantra: “never change a running system” :smiley:

Nah... Keep modifying till it breaks, then using your notes don't go as far. :wink:


I have been using Win all my life until I started with the beaglebone - Not easy to change habits :stuck_out_tongue: