Windows 7 (64bit) USB issue, BeagleBoneBlack shows up under "Other devices"

Installed the USB drivers using BONE_D64.exe, selected the “yes install anyway” options, got the “ready to use” status
on all 4 drivers.

Hook up the USB to the BBB, and … I get the driver failed to install, and … BeagleBoneBlack listed under “Other Devices” in device manager.

Any ideas?

Tried another computer, and … it works just fine. Looks like the BONE_D64.exe installer is not cleanup up if the beagleboneblack is connected before the driver is installed.

Now off to try and purge the USB entries that no longer allow me access… Thanks Microsoft.

Don’t bash Microsoft. They are trying to make it right. Bill admitted that ctrl-alt-del was a mistake. Maybe more mistakes will come out as he gets a little older!!


I know this is an old post… If anyone else has this problem just go to the windows device manager and uninstall the “beagleboneblack” Next just unplug the beaglebone usb and plug it back in, and the drivers installed earlier will now be configured properly.

Hi Jeff,
Did you ever get this resolved? How did you purge the other USB entries. We have several computers here that all exhibit the same problem all are Windows 7-64. We’ve used the signed drivers BONE_D64.

We’ve tried:

  1. Uninstalling the BeagleBoneBlack in the device manager, then unplugging it and plugging it back in.

  2. Uninstalling the BeagleBoneBlack in the device manager, then unplugging, then uninstalling the BONE_64 drivers in the control panel and starting from scratch.

  3. We’ve also tried #2 having rebooted with “disable signed driver enforcement”
    I just can’t seem to get it to work. Windows is just hell bent on bringing it up as “BeagleBoneBlack” and it only shows up as one device instead of three.

Any thoughts?

I had a problem using the latest TI kernel and the windows USB/ethernet driver. Seemed to be some issue with the
windows driver expecting RNDIS where the kernel USB gadget support was configured to support both CDC ECM and
RNDIS by default. Changing the USB gadget support to just support RNDIS solved the problem (usb/ethernet worked
with both Linux and Windows). In fact just copied in a rebuilt g_multi.ko and rebooted to fix.

Cheers Steve.

Hi Steve,

I am having this problem and I was hoping you could clarify on what you said. You rebuilt the g_multi.ko and copied to the BBB, what exactly is involved in doing that?
Could you recommend a resource that will provide instructions? I will continue to look as I research this myself.


Hi Bruce,

This should be fixed in all current images..

What base image are you currently using? (cat /etc/dogtag) and what kernel
(uname -r)


Hi Robert,

I am using Debian Image 2015-10-11 and 4.1.10-ti-r21. My problem is the beagleboneblack shows up under other devices and fails to install the driver. I am currently working it from the Ethernet port which is sufficient for the time being but this is a nuisance for me. I’m not sure if CDC EMC being enable or not is issue since this problem seems to be with my PC and not the BBB. My BBB works on a co-workers machine and another BBB still does not work on my PC. This discussion is the only one I’ve found that mentions my symptoms so I figured it was worth a try.

Thank you,


This was fixed in:


Feel free to upgrade to the latest:

sudo apt-get update
sudo apt-get install linux-image-4.1.13-ti-r35
sudo reboot



Thanks Robert, I will do that.

Has your problem been solved?
I encounter the same problem now .
If you has solve it ,can you tell me the version of the image you use or the way to solve the problem?
在 2013年9月28日星期六 UTC+8上午8:42:10,Jeff Curless写道: