Wireless Networking on the Angstrom

Hi All

I have been trying for a number of weeks to get wireless networking
working with Angstrom.

A bit about my hardware:

Revision B7 Beagleboard
Netgear WG121 (Prism 54 - I think)
Belkin F5D7050ed (Ver: V5000ed) (rlt8187)
Belkin USB-to-PS/2 adpater (for keyboard and mouse)

I initially built a Angstrom Demo Image using OE and BitBake. I found
the prism 54 firmware (isl3890) from wireless.kernal.org and placed it
in /lib/firmware. This seemed to work in the sence that the device was
recognised (seen in 'Network Setup' and 'Connection Management' and I
could see my intended network ('Connection Manager'). However, 1) the
signal strength is very low (due to thick walls where I am working)
and secondly, after a few minutes of being connected the link stops.
Hovering my mouse over the 'Connection Manager' at the right of the
'task-bar' states that 'The Connection Manager daemon is no longer
running'. The wireless device is no longer visible in the 'Network
Setup' and 'Connection Management' tools.

Due to the low signal strength, I am now trying to setup a ad-hoc link
between the beagleboard and a pc (Ubuntu 8.10). I have the Belkin
attached to the PC as the Netgear only seems to want to work via an
ndiswrapper on Ubuntu.

I have attempted to configure both devices to use static IP addresses
on the same subnet. However, I am not sure how to do the 'final

Has anyone else tried to establish an ad-hoc link between a Linux pc
and beagleboard?
If so, what steps were taken to establish the link?
Would it be easier to obtain an access point and connect via that?

Please note that I (fairly) am new to Linux and the Beagleboard.

An ethernet solution is not an option for my final target application.

Thank you in advance.


First of all you need to find out what the name of the wireless device is - probably wlan0. Run the command “ifconfig -a” to get a list of all network interfaces and their names.

Then you can run the following command on the BeagleBoard:

sudo iwconfig wlan0 mode adhoc essid BeagleBoard

You can run the same command on the Ubuntu Desktop to connect it to the same wireless network. Then you need to configure the IP addresses for the desktop and the BeagleBoard, they need to be different and on the same subnet. If you aren’t sure the use for the BeagleBoard and for the Ubuntu desktop.

sudo ifconfig wlan0 up

You should then be able to use “ping” from the desktop to ping the beagleboard.

Thank you for the advice, however, I cannot still establish a ad-hoc connection between the beagleboard and an ubuntu desktop.

I have since given up on trying to establish an ad-hoc connection and obtained a second Belkin F5D7050ed, this time Version 3020ed, which uses the rt73 chipset (i think). I have also purchased a Linksys Access Point and am trying to establish a connection between the beagleboard and this accesspoint.

The access point is connected via a wired connection to a windows pc (second network adapter). Both the Windows PC and AP have static IP addresses on the 192.168.1.x ( subnet. I have set the Windows PC to be the gateway.

I can establish a connection when using the Angstrom Demo image that I built a while ago, however this involved a bit of fiddling via the serial console and a few clicks within the connection manager. However, as my ultimate goal does not require a display, I built a console image (adding references to the wireless chipset bb in the console bitbake file).

I modified the interfaces file to include

  • static ip configuration
  • ip
  • netmask
  • broadcast
  • gateway
  • wireless essid E4Dev
  • wireless ap (mac address)
  • wireless rate 54M
  • wireless mode managed
  • wireless channel 1
    On boot, the Belkin stick is recognised, however I cannot ping either the AP or the Windows PC, when i issue ifconfig wlan0 and iwconfig wlan0, the correct information appears to be set.

Am I doing anything wrong?

Thank you in advance