I’m trying to connect my BB Blue to my local wifi. I can ssh into the board through USB. I can also connect to the onboard AP and ssh through that. I am failing to connect the board as a client to my WiFi router.

root@beaglebone:/home/debian# connmanctl

enable wifi
Error wifi: Already enabled
tether wifi disable
Error disabling wifi tethering: Already disabled
scan wifi
Scan completed for wifi
ATT2F5HVb4 wifi_f45eab3dac4c_41545432463548566234_managed_psk
NTGR_VMB_1406851422 wifi_f45eab3dac4c_4e5447525f564d425f31343036383531343232_managed_psk
agent on
Agent registered
connect wifi_f45eab3dac4c_41545432463548566234_managed_psk
Agent RequestInput wifi_f45eab3dac4c_41545432463548566234_managed_psk
Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
WPS = [ Type=wpspin, Requirement=alternate ]
Passphrase? ************
Agent ReportError wifi_f45eab3dac4c_41545432463548566234_managed_psk
Agent request cancelled by ConnMan
Error /net/connman/service/wifi_f45eab3dac4c_41545432463548566234_managed_psk: Operation aborted

Enter code here...


Hello Ari,

using a BeagleBone.org Debian Image 2017-03-19, I was able to configure BB Blue for my network using connman instructions from this gist: https://gist.github.com/kylemanna/6930087

Very similar to what you did, but not calling ‘enable wifi’, ‘tether wifi disable’, and ‘agent on’.
Also, I directly wrote the settings (including the passphrase) to /var/lib/conman/xyz-psk.config, as explained in the gist.
Finally I had to tell my router to accept the new device :wink:

However, I am struggling to modify the Accesspoint default password, or even just disabling the AccessPoint. Very nice that
AP and Wifi Client connections are possible at the same time though.

Greetings, Kjell

The access point is controlled thru: /etc/default/bb-wl18xx

make sure you have latest version of: bb-wl18xx-firmware

# TETHER_ENABLED: Whether or not to run the /usr/bin/bb-wl18xx-tether
daemon; set to no to disable.

# USE_CONNMAN_TETHER: Whether or not to just use connman tether
inteface; set to no to disable.

# USE_WL18XX_IP_PREFIX: default IP block of SoftAP0 interface

# USE_WL18XX_MAC_ADDRESS: use custom mac address, for when work wifi
starts sending deauthentication packet spam.

# USE_PERSONAL_SSID: set custom ssid

# USE_PERSONAL_PASSWORD: set ssid password

# USE_GENERATED_DNSMASQ: use generated version of
/etc/dnsmasq.d/SoftAp0; set to no so user can modify

# USE_GENERATED_HOSTAPD: use generated version of /etc/hostapd.conf;
set to no so user can modify /etc/hostapd.conf

# USE_APPENDED_SSID: appends mac address after SSID (aka -WXYZ, BeagleBone-WXYZ)


Thanks, that works and was exactly the information I was missing.

The BB Blue now connects to my network during startup, with configuration from


And at the same time, is available as Accesspoint with settings from

The access point is controlled thru: /etc/default/bb-wl18xx

Neat :slight_smile:

Here is a different way to do it, not sure if there are disadvantages, but for me easier to toggle the AP on and off.

sudo connmanctl
tether wifi on


sudo connmanctl
tether wifi off

In both of the cases above, the connection drops immediately. In the case of tether wifi off, my wireless router picks it up right away.
When using tether wifi on, the router drops the connection, but then I can connect peer-to-peer with laptop wifi. This is great for demos away from the home router.

Note that I have the Connman tether lines both set to no in the text file.
I don’t get AP and STA modes simultaneously with this method.