workaround for systemd-journalctl --follow not working to pipes

I'm on BBB with the shipping software, plus debian updates.

This works fine:

     systemd-journalctl --lines=10 --all --follow

This outputs nothing:

     systemd-journalctl --lines=10 --all --follow | cat

Looks like this version of journalctl is broken somehow when output is to
a pipe.

So you can't monitor output remotely using ssh either, which is annoying.
Anyone know a fix for this?

I asked on #debian and they said the program is supposed to be called just
'journalctl' and works fine to pipes for them.


The version of systemd in Wheezy is pretty ancient. We mainly enabled
it in the shipping image due to massive speed up in bootup time.

If your interested in a newer systemd image take look at the current
jessie snapshot..

Once Jessie is released, you'll see this image replace the older Wheezy images..