X applications not working over usb

I cannot run X-apps on my BBBs when they are connected to my computer over the USB. But the X-apps work just fine when the BBBs are connected to my computer over the LAN. Why? My older BBBs work just fine in either connection mode, but the newer ones (purchase in the past year) fail when connected on the USB (but work on the LAN). All BBBs are running debian, and all are version C.

I connect to windows machines (Windows 7 & 10 give the same result) using Putty and Xming – and I use the same settings whether I’m connected via LAN or USB. The only thing I change is the IP. (I use the default BBB IP when connected to the USB and the “assigned” IP when connected to the LAN.)

Since the bad behavior is a function of how new the BBB is, I conclude that something in the debian system has changed from 2 years ago to 1 year ago. (I only noticed this recently when I started attaching all my BBBS to laptops via USB. That’s when I noticed the new ones fail and the older ones worked.)

The particular software I’m running on the BBBs is gnuplot.