x-loader problem

I'm porting android to the beagleboard based on embinux. In a certain
moment I tried the 0xdroid version of the kernel, just for curiosity.
When I did that, my boot configurations where changed, and I couldn't
load my old images anymore, and couldn't either find the proper setenv
configurations to restore my boot configuration.

the setenv commands I did where:

setenv bootcmd 'mmc init;fatload mmc 0 80000000 uImage;bootm 80000000'

setenv bootargs console=ttyS2,115200n8 noinitrd root=/dev/mmcblk0p2
omap-dss.def_disp=lcd omapfb.video_mode=640x480MR-16@60 init=/init
rootfstype=ext3 rw rootdelay=1 nohz=off androidboot.console=ttyS2

but that didn't work.

So, I tried to reflash the x-loader and u-boot, but when I reflashed
the x-loader, I think something went wrong, because now the serial
communication displays only a few characters, and a lot of junk, and
then freezes. I already tried all sorts of serial communications
settings on my terminal, but with no results.

the steps I followed to reflash the x-loader where:

fatload mmc 0 0x80200000 x-load-bin.ift
nand unlock
nand ecc hw
nand erase 0 80000
nand write.i 0x80200000 0 80000

Does anyone have any ideas of what could be happening?

My questions are:

How will I reflash the x-loader and u-boot properly, now that my
serial communication is off? And how could I have reset the boot
configurations when all of this started?


don’t forget to erase the whole NAND

2010/9/13 GeanChu <gfdchu@gmail.com>