xM rev C not booting and serial console only shows "60"

Hello to all,

I am new to beagleboard and embeded linux and I only started working
with the beagleboard-XM a mounth ago.
I was able to download a image from Angstrom Narcissus and to boot it
up of the beagleboard.

Everything was fine until 2 days ago when i made "opkg update" and
"opkg upgrade".
After rebooting the system, it never worked again, the board does not
boot, only led D5 is ON, and on Serial console only "60" appears.

I have used the original microSD card (labeled: xM TEST Beta 4-25)
that came with the board and it also does not work. Same message on

My problem now is that i am not able to boot anything or to get access
to the prompt to write commands.

Reading several posts i have checked that the Voltage is OK (i am
using a transformer of 5 volts with 2 amperes), the serial console
settings are OK because i was working with it before the problem
happened, the image on the card is OK because it is the original
microSD Card that came with the board and i did not use it, pressing
the USER button while powering ON the board also does not do nothing.

I have read some posts about the NAND on the XM should not be written
because it would cause problems.
But i do not know if this is the case.

Can anyone help me in finding and resolving this problem?
Or is my BeagleBoard XM revC dead and i have to buy a new one?

Thanks in advance to all of you for the Help.

Luis Pedro

You may have damaged the SD connector. You need to push in the card to eject it. If you just pull it out, then you can damage the connector. I would try to recreate the card that shipped with it and try that again.


If that does not work, then you will need to request an RMA and have the connector looked at.



Hello Gerald,
thank you for your reply.

about the SD connector, it works fine inserting and loking the card and pushing the card to eject. I have not remove the card by force and i tried to check the HW on the board and i do not see anything damaged, but...

Relating to recreating the card that shipped with the board.
- I have downloaded the image from website you pointted:
- formatted the microSD card with HP USB Disk Storage Format tool.
- Used Win32DiskImager to flash the Image to the microSD Card.
- placed it on the Beagleboard microSD slot
- Powered UP the board.

RESULT: nothing happened. still the same as before.

Could it be anything else besides a HW problem with the SD connector?
Is there anything else i can test before doing the RMA?

Thanks in advance for your reply.

Luis Pedro

No, it sounds like you confirmed that the SD might be damaged. Do the RMA.


Ok thanks.

I will do the RMA.

Thanks for all the help.

best regards,
Luis Pedro

No dia 13 de Fevereiro de 2012 18:58, Gerald Coley <gerald@beagleboard.org> escreveu:

99% of the time, it's just a BADLY miss-formated SD card...

Retry with the CircuitCo demo image..

Otherwise, it's a bent pin on the micro sd card..


check this link once :
kernel 3.4.0 ported on beagle board
blog :
best wishes

Someone should kick this … out of the list.

Go to hell! Everyone already read this message.