xrandr Can't open display

Hi,

I am working with a Beaglebone Black with Debian Jessie.

I am trying to interface with an LG 19M38H - B LCD display through its HDMI port.

  1. When I am running the command

sudo apt-get install read-edid xserver-xorg-video-fbdev xserver-xorg-video-modesetting x11-xserver-utils

I am getting the following message

root@localhost:~# sudo apt-get install read-edid xserver-xorg-video-fbdev xserver-xorg-video-modesetting x11-xserver-utils
Reading package lists… Done
Building dependency tree
Reading state information… Done
read-edid is already the newest version.
x11-xserver-utils is already the newest version.
xserver-xorg-video-fbdev is already the newest version.
xserver-xorg-video-modesetting is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 204 not upgraded.

  1. Then I tried xrandr. It is giving the following message

root@localhost:~# xrandr
Can’t open display

  1. I did the following to solve the issue, after exploring in forums

a)defining environment variable DISPLAY

root@localhost:~# export DISPLAY=:0.0
root@localhost:~# xrandr
Can’t open display :0.0
root@localhost:~#

b)defining environment variable XAUTHORITY

root@localhost:~# export XAUTHORITY=/root/.Xauthority
root@localhost:~# xrandr
No protocol specified
Can’t open display :0.0
root@localhost:~#

c) used the command xhost local:root

root@localhost:~# xhost local:root
No protocol specified
xhost: unable to open display “:0.0”
root@localhost:~# xrandr
Can’t open display :0.0

d) used the command xhost +

root@localhost:~# xhost +
xhost: unable to open display “:0.0”
root@localhost:~# xrandr
No protocol specified
Can’t open display :0.0

e) Also I changed the host name from beaglebone black to localhost to solve the issue.

But nothing is working. Thanks in advance for the help.

Thanks and Regards,

Sajeevan.K

i don't see that you started the X server---it needs to be running for
any of this to work.

Hi Przemek,

Thank You for the reply.

I stated the X server with startx command.
I am getting the following messages in the terminal.

root@localhost:~# startx

X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-0.bpo.4-armmp-lpae armv7l Debian
Current Operating System: Linux localhost 3.8.13-bone83 #1 SMP Wed Jan 4 23:20:53 UTC 2017 armv7l
Kernel command line: console=ttyO0,115200n8 root=UUID=11f97cd3-d7c9-4b33-af80-46741144f70b ro rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable
Build Date: 11 February 2015 01:18:06AM
xorg-server 2:1.16.4-1 (http://www.debian.org/support)
Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.2.log”, Time: Tue Feb 14 18:06:03 2017
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”

Also now a default display is coming in the LCD display(which may be the BBB’s default display)

Now I tried to run a simpleQt program, by opening another terminal. But it is only showing the following message in the terminal.

root@localhost:~# ./simpleQt
QXcbConnection: Could not connect to display
Aborted
root@localhost:~#

The configuration is as shown below

root@localhost:~# cat /etc/X11/xorg.conf
Section “Monitor”
Identifier “Builtin Default Monitor”
EndSection

Section “Device”
Identifier “Builtin Default fbdev Device 0”
Driver “fbdev”
#HWcursor_false Option “HWcursor” “false”
EndSection

Section “Screen”
Identifier “Builtin Default fbdev Screen 0”
Device “Builtin Default fbdev Device 0”
Monitor “Builtin Default Monitor”
DefaultDepth 16
EndSection

Section “ServerLayout”
Identifier “Builtin Default Layout”
Screen “Builtin Default fbdev Screen 0”
EndSection
root@localhost:~#

The logged messages( /var/log/Xorg.2.log) showing the following errors
1) FBDEV(0): FBIOPUTCMAP: Invalid argument
2) Failed to load module “evdev” (loader failed, 7)
3) No input driver matching `evdev’

The full logged messages are as shown below.

root@localhost:~# cat /var/log/Xorg.2.log
[ 449.268]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[ 449.272] X Protocol Version 11, Revision 0
[ 449.275] Build Operating System: Linux 3.16.0-0.bpo.4-armmp-lpae armv7l Debian
[ 449.276] Current Operating System: Linux localhost 3.8.13-bone83 #1 SMP Wed Jan 4 23:20:53 UTC 2017 armv7l
[ 449.276] Kernel command line: console=ttyO0,115200n8 root=UUID=11f97cd3-d7c9-4b33-af80-46741144f70b ro rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable
[ 449.281] Build Date: 11 February 2015 01:18:06AM
[ 449.281] xorg-server 2:1.16.4-1 (http://www.debian.org/support)
[ 449.282] Current version of pixman: 0.32.6
[ 449.283] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 449.284] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 449.294] (==) Log file: “/var/log/Xorg.2.log”, Time: Tue Feb 14 18:06:03 2017
[ 449.300] (==) Using config file: “/etc/X11/xorg.conf”
[ 449.300] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 449.304] (==) ServerLayout “Builtin Default Layout”
[ 449.304] (
) |–>Screen “Builtin Default fbdev Screen 0” (0)
[ 449.308] () | |–>Monitor “Builtin Default Monitor”
[ 449.309] (
) | |–>Device “Builtin Default fbdev Device 0”
[ 449.309] (==) Automatically adding devices
[ 449.309] (==) Automatically enabling devices
[ 449.309] (==) Automatically adding GPU devices
[ 449.310] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 449.310] Entry deleted from font path.
[ 449.310] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 449.310] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 449.310] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 449.314] (II) Loader magic: 0xb6ff7f18
[ 449.314] (II) Module ABI versions:
[ 449.314] X.Org ANSI C Emulation: 0.4
[ 449.314] X.Org Video Driver: 18.0
[ 449.314] X.Org XInput driver : 21.0
[ 449.314] X.Org Server Extension : 8.0
[ 449.316] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 449.321] (II) no primary bus or device found
[ 449.321] falling back to /sys/devices/ocp.3/4830e000.fb/drm/card0
[ 449.322] (II) LoadModule: “glx”
[ 449.332] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 449.385] (II) Module glx: vendor=“X.Org Foundation”
[ 449.385] compiled for 1.16.4, module version = 1.0.0
[ 449.385] ABI class: X.Org Server Extension, version 8.0
[ 449.385] (==) AIGLX enabled
[ 449.385] (II) LoadModule: “fbdev”
[ 449.386] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 449.391] (II) Module fbdev: vendor=“X.Org Foundation”
[ 449.391] compiled for 1.15.99.904, module version = 0.4.4
[ 449.391] Module class: X.Org Video Driver
[ 449.391] ABI class: X.Org Video Driver, version 18.0
[ 449.391] (II) FBDEV: driver for framebuffer: fbdev
[ 449.396] (–) using VT number 3

[ 449.404] (WW) Falling back to old probe method for fbdev
[ 449.405] (II) Loading sub module “fbdevhw”
[ 449.405] (II) LoadModule: “fbdevhw”
[ 449.405] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 449.406] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 449.406] compiled for 1.16.4, module version = 0.0.2
[ 449.406] ABI class: X.Org Video Driver, version 18.0
[ 449.406] (II) FBDEV(0): using default device
[ 449.407] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 449.407] (II) FBDEV(0): Creating default Display subsection in Screen section
“Builtin Default fbdev Screen 0” for depth/fbbpp 16/16
[ 449.407] () FBDEV(0): Depth 16, (–) framebuffer bpp 16
[ 449.407] (==) FBDEV(0): RGB weight 565
[ 449.407] (==) FBDEV(0): Default visual is TrueColor
[ 449.407] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[ 449.407] (II) FBDEV(0): hardware: (video memory: 1800kB)
[ 449.407] (II) FBDEV(0): checking modes against framebuffer device…
[ 449.407] (II) FBDEV(0): checking modes against monitor…
[ 449.407] (–) FBDEV(0): Virtual size is 1280x720 (pitch 1280)
[ 449.407] (
) FBDEV(0): Built-in mode “current”
[ 449.408] (==) FBDEV(0): DPI set to (96, 96)
[ 449.408] (II) Loading sub module “fb”
[ 449.408] (II) LoadModule: “fb”
[ 449.412] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 449.413] (II) Module fb: vendor=“X.Org Foundation”
[ 449.414] compiled for 1.16.4, module version = 1.0.0
[ 449.416] ABI class: X.Org ANSI C Emulation, version 0.4
[ 449.416] () FBDEV(0): using shadow framebuffer
[ 449.416] (II) Loading sub module “shadow”
[ 449.416] (II) LoadModule: “shadow”
[ 449.416] (II) Loading /usr/lib/xorg/modules/libshadow.so
[ 449.417] (II) Module shadow: vendor=“X.Org Foundation”
[ 449.417] compiled for 1.16.4, module version = 1.1.0
[ 449.417] ABI class: X.Org ANSI C Emulation, version 0.4
[ 449.485] (==) FBDEV(0): Backing store enabled
[ 449.486] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.486] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.486] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.486] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.486] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.486] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.488] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.489] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.490] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.490] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.490] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.490] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.490] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 449.492] (==) FBDEV(0): DPMS enabled
[ 449.493] (==) RandR enabled
[ 449.547] (II) SELinux: Disabled on system
[ 449.552] (II) AIGLX: Screen 0 is not DRI2 capable
[ 449.552] (EE) AIGLX: reverting to software rendering
[ 449.552] (EE) AIGLX error: dlopen of /usr/lib/arm-linux-gnueabihf/dri/swrast_dri.so failed (/usr/lib/arm-linux-gnueabihf/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
[ 449.552] (EE) GLX: could not load software renderer
[ 449.552] (II) GLX: no usable GL providers found for screen 0
[ 449.796] (II) config/udev: Adding input device tps65217_pwr_but (/dev/input/event0)
[ 449.797] (
) tps65217_pwr_but: Applying InputClass “evdev keyboard catchall”
[ 449.797] (II) LoadModule: “evdev”
[ 449.797] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 449.799] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 449.799] (II) UnloadModule: “evdev”
[ 449.799] (II) Unloading evdev
[ 449.799] (EE) Failed to load module “evdev” (loader failed, 7)
[ 449.799] (EE) No input driver matching evdev' [ 449.802] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 449.802] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 449.802] (II) LoadModule: "evdev" [ 449.803] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 449.804] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 449.804] (II) UnloadModule: "evdev" [ 449.804] (II) Unloading evdev [ 449.804] (EE) Failed to load module "evdev" (loader failed, 7) [ 449.804] (EE) No input driver matching evdev’
[ 449.806] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 449.807] (II) No input driver specified, ignoring this device.
[ 449.807] (II) This device may have been added with another device file.
[ 495.329] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 495.329] () Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 495.329] (II) LoadModule: “evdev”
[ 495.332] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 495.335] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 495.335] (II) UnloadModule: “evdev”
[ 495.336] (II) Unloading evdev
[ 495.336] (EE) Failed to load module “evdev” (loader failed, 7)
[ 495.336] (EE) No input driver matching evdev' [ 495.346] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 495.346] (II) No input driver specified, ignoring this device. [ 495.346] (II) This device may have been added with another device file. [ 557.047] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 557.048] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 557.048] (II) LoadModule: "evdev" [ 557.053] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 557.057] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 557.057] (II) UnloadModule: "evdev" [ 557.057] (II) Unloading evdev [ 557.057] (EE) Failed to load module "evdev" (loader failed, 7) [ 557.058] (EE) No input driver matching evdev’
[ 557.063] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 557.064] (II) No input driver specified, ignoring this device.
[ 557.064] (II) This device may have been added with another device file.
[ 618.771] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 618.772] (
) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 618.772] (II) LoadModule: “evdev”
[ 618.775] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 618.778] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 618.778] (II) UnloadModule: “evdev”
[ 618.778] (II) Unloading evdev
[ 618.779] (EE) Failed to load module “evdev” (loader failed, 7)
[ 618.779] (EE) No input driver matching evdev' [ 618.785] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 618.785] (II) No input driver specified, ignoring this device. [ 618.785] (II) This device may have been added with another device file. [ 680.502] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 680.507] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 680.510] (II) LoadModule: "evdev" [ 680.511] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 680.514] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 680.515] (II) UnloadModule: "evdev" [ 680.515] (II) Unloading evdev [ 680.515] (EE) Failed to load module "evdev" (loader failed, 7) [ 680.515] (EE) No input driver matching evdev’
[ 680.521] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 680.522] (II) No input driver specified, ignoring this device.
[ 680.522] (II) This device may have been added with another device file.
[ 742.222] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 742.227] () Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 742.227] (II) LoadModule: “evdev”
[ 742.230] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 742.233] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 742.234] (II) UnloadModule: “evdev”
[ 742.234] (II) Unloading evdev
[ 742.234] (EE) Failed to load module “evdev” (loader failed, 7)
[ 742.235] (EE) No input driver matching evdev' [ 742.240] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 742.241] (II) No input driver specified, ignoring this device. [ 742.241] (II) This device may have been added with another device file. [ 803.944] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 803.944] (II) No input driver specified, ignoring this device. [ 803.944] (II) This device may have been added with another device file. [ 803.953] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 803.954] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 803.954] (II) LoadModule: "evdev" [ 803.956] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 803.959] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 803.959] (II) UnloadModule: "evdev" [ 803.959] (II) Unloading evdev [ 803.960] (EE) Failed to load module "evdev" (loader failed, 7) [ 803.960] (EE) No input driver matching evdev’
[ 865.661] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 865.662] (
) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 865.662] (II) LoadModule: “evdev”
[ 865.670] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 865.676] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 865.676] (II) UnloadModule: “evdev”
[ 865.677] (II) Unloading evdev
[ 865.677] (EE) Failed to load module “evdev” (loader failed, 7)
[ 865.677] (EE) No input driver matching evdev' [ 865.683] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 865.683] (II) No input driver specified, ignoring this device. [ 865.683] (II) This device may have been added with another device file. [ 927.391] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 927.394] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 927.395] (II) LoadModule: "evdev" [ 927.396] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 927.405] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 927.405] (II) UnloadModule: "evdev" [ 927.405] (II) Unloading evdev [ 927.406] (EE) Failed to load module "evdev" (loader failed, 7) [ 927.406] (EE) No input driver matching evdev’
[ 927.411] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 927.412] (II) No input driver specified, ignoring this device.
[ 927.412] (II) This device may have been added with another device file.
[ 989.108] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 989.109] (II) No input driver specified, ignoring this device.
[ 989.109] (II) This device may have been added with another device file.
[ 989.114] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 989.115] () Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 989.115] (II) LoadModule: “evdev”
[ 989.117] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 989.120] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 989.120] (II) UnloadModule: “evdev”
[ 989.120] (II) Unloading evdev
[ 989.121] (EE) Failed to load module “evdev” (loader failed, 7)
[ 989.121] (EE) No input driver matching evdev' [ 1050.832] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 1050.833] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 1050.833] (II) LoadModule: "evdev" [ 1050.835] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 1050.838] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 1050.839] (II) UnloadModule: "evdev" [ 1050.839] (II) Unloading evdev [ 1050.839] (EE) Failed to load module "evdev" (loader failed, 7) [ 1050.843] (EE) No input driver matching evdev’
[ 1050.848] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 1050.849] (II) No input driver specified, ignoring this device.
[ 1050.849] (II) This device may have been added with another device file.
[ 1112.556] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 1112.558] (
) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 1112.558] (II) LoadModule: “evdev”
[ 1112.560] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 1112.563] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 1112.563] (II) UnloadModule: “evdev”
[ 1112.564] (II) Unloading evdev
[ 1112.564] (EE) Failed to load module “evdev” (loader failed, 7)
[ 1112.564] (EE) No input driver matching evdev' [ 1112.570] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 1112.570] (II) No input driver specified, ignoring this device. [ 1112.571] (II) This device may have been added with another device file. [ 1174.285] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 1174.286] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 1174.286] (II) LoadModule: "evdev" [ 1174.287] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 1174.291] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 1174.291] (II) UnloadModule: "evdev" [ 1174.295] (II) Unloading evdev [ 1174.295] (EE) Failed to load module "evdev" (loader failed, 7) [ 1174.295] (EE) No input driver matching evdev’
[ 1174.301] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 1174.301] (II) No input driver specified, ignoring this device.
[ 1174.302] (II) This device may have been added with another device file.
[ 1236.001] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 1236.005] () Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 1236.005] (II) LoadModule: “evdev”
[ 1236.010] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 1236.014] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 1236.014] (II) UnloadModule: “evdev”
[ 1236.014] (II) Unloading evdev
[ 1236.014] (EE) Failed to load module “evdev” (loader failed, 7)
[ 1236.015] (EE) No input driver matching evdev' [ 1236.020] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 1236.021] (II) No input driver specified, ignoring this device. [ 1236.021] (II) This device may have been added with another device file. [ 1297.714] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 1297.714] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 1297.714] (II) LoadModule: "evdev" [ 1297.717] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 1297.720] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 1297.721] (II) UnloadModule: "evdev" [ 1297.721] (II) Unloading evdev [ 1297.721] (EE) Failed to load module "evdev" (loader failed, 7) [ 1297.721] (EE) No input driver matching evdev’
[ 1297.727] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 1297.727] (II) No input driver specified, ignoring this device.
[ 1297.728] (II) This device may have been added with another device file.
[ 1359.450] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 1359.450] (
) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 1359.451] (II) LoadModule: “evdev”
[ 1359.453] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 1359.456] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 1359.457] (II) UnloadModule: “evdev”
[ 1359.457] (II) Unloading evdev
[ 1359.458] (EE) Failed to load module “evdev” (loader failed, 7)
[ 1359.458] (EE) No input driver matching evdev' [ 1359.463] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 1359.464] (II) No input driver specified, ignoring this device. [ 1359.464] (II) This device may have been added with another device file. [ 1421.176] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 1421.176] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 1421.176] (II) LoadModule: "evdev" [ 1421.182] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 1421.185] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 1421.186] (II) UnloadModule: "evdev" [ 1421.186] (II) Unloading evdev [ 1421.186] (EE) Failed to load module "evdev" (loader failed, 7) [ 1421.186] (EE) No input driver matching evdev’
[ 1421.197] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 1421.198] (II) No input driver specified, ignoring this device.
[ 1421.198] (II) This device may have been added with another device file.
[ 1482.897] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1)
[ 1482.897] (**) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 1482.897] (II) LoadModule: “evdev”
[ 1482.903] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 1482.907] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header
[ 1482.907] (II) UnloadModule: “evdev”
[ 1482.907] (II) Unloading evdev
[ 1482.907] (EE) Failed to load module “evdev” (loader failed, 7)
[ 1482.908] (EE) No input driver matching evdev' [ 1482.913] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0) [ 1482.914] (II) No input driver specified, ignoring this device. [ 1482.914] (II) This device may have been added with another device file. [ 1544.618] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event1) [ 1544.623] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall" [ 1544.624] (II) LoadModule: "evdev" [ 1544.627] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so [ 1544.630] (EE) Failed to load /usr/lib/xorg/modules/input/evdev_drv.so: /usr/lib/arm-linux-gnueabihf/libevdev.so.2: invalid ELF header [ 1544.630] (II) UnloadModule: "evdev" [ 1544.630] (II) Unloading evdev [ 1544.631] (EE) Failed to load module "evdev" (loader failed, 7) [ 1544.631] (EE) No input driver matching evdev’
[ 1544.637] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 1544.637] (II) No input driver specified, ignoring this device.
[ 1544.637] (II) This device may have been added with another device file.

Thank You in advance for the help.

Thanks and Regards,
Sajeevan.K

I stated the X server with startx command.
Also now a default display is coming in the LCD display(which may be the
BBB's default display)

That's good. I don't know about the erorrs---it looks like the GL
software rendering is turned off but simple X should work now.

Now I tried to run a simpleQt program, by opening another terminal. But it
is only showing the following message in the terminal.

root@localhost:~# ./simpleQt
QXcbConnection: Could not connect to display

Are you doing that from the same terminal as the one you ran startx
from? What is the value of the DISPLAY environment variable?

Try doing
DISPLAY=:0 ./simpleQt

Hi Przemek,

Initially I was not aware of the X server. With a detailed study about X server and X window system, I could solve this issue.
Thank You for the information and help.

Thanks & Regards,
Sajeevan.K

Hi Przemek,

My original question was regarding xrandr command.

Now I am able to open a window as per a small qt progam in the LCD display.

But still xrandr is not showing the outputs. It is showing no protocol specified.

root@localhost:~# xrandr
No protocol specified
Can’t open display :0.0
root@localhost:~#

Am I missing something?

Thanks for the help.

Sajeevan.K

how do you connect local via console or remote via (whatever) ?
you must have you X server running.

When you are local

You can open a terminal window ? (xterm, ...)
(note: Handling is more easy if you have a windowmanager running)

now you must be able to try "xrandr -q" inside the terminal window.

hope that help,

re,
wh

How are you running your qt program? Run xrandr in exactly the same
way; it should work. If it doesn't, describe how you set up your
console, show exactly the commands you're typing and their output

Hi,

Sorry for not replying. I have been busy with my works.

Like Przemek pointed out, here the issue may be the way in which I am entering the command 'xrandr’

So I will explain it.

After I enter startx in the command prompt of my desktop (ie root@beaglebone:~#) the following messages appearing in the display of my desktop.

root@beaglebone:~# startx

X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-0.bpo.4-armmp-lpae armv7l Debian
Current Operating System: Linux beaglebone 4.4.9-ti-r25 #1 SMP Thu May 5 23:08:13 UTC 2016 armv7l
Kernel command line: console=ttyO0,115200n8 root=UUID=f80ffe30-c1d0-4c51-8cab-b33a74f7ae1b ro rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable
Build Date: 11 February 2015 01:18:06AM
xorg-server 2:1.16.4-1 (http://www.debian.org/support)
Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.1.log”, Time: Thu Feb 23 10:40:00 2017
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 720, current 1280 x 720, maximum 1280 x 720
default connected 1280x720+0+0 0mm x 0mm
1280x720 0.00*
./q_msg_linux: /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5: no version information available (required by ./q_msg_linux)
./q_msg_linux: /usr/lib/arm-linux-gnueabihf/libQt5Widgets.so.5: no version information available (required by ./q_msg_linux)
Openbox-Message: Couldn’t set messages locale category from environment.
Openbox-Message: Couldn’t set locale from environment.
libEGL warning: DRI3: Screen seems not DRI3 capable
libEGL warning: DRI2: failed to authenticate

Also then my simple Qt application is run on the LCD display connected to BBB. (I have already included the executable file of simple Qt application in the file ~/.xinitrc) . (The contents of .xinitrc is given at the end of this mail)

Here the important point is that, now in my desktop terminal, I cannot enter the xrandr command, because there is no command prompt ( ie # ) in the terminal.

Now as Przemek suggested, I included the command ‘xrandr’ in ~/.xinitrc, before ./simpleQt (name of my simple Qt application).

But the execution of this command is observed in either desktop display or display connected to BBB.

I am also giving the contents of .xinitrc file

#!/bin/bash
xrandr
oclock -geometry +1450+920 -bg ivory -fg blue &
./q_msg_linux &
exec openbox

Please suggest a method, how I can run xrandr command in this situation.

Thanks & Regards,
Sajeevan.K

After I enter startx in the command prompt of my desktop (ie
root@beaglebone:~#) the following messages appearing in the display of my
desktop.

root@beaglebone:~# startx

X.Org X Server 1.16.4

....

(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 720, current 1280 x 720, maximum 1280 x 720
default connected 1280x720+0+0 0mm x 0mm
   1280x720 0.00

So here you're running the xrandr command and getting output from it, right?

Here the important point is that, now in my desktop terminal, I cannot enter
the xrandr command, because there is no command prompt ( ie # ) in the
terminal.

OK, so the terminal program is not set up right. I see that you're
using openbox, which is a window manager.
I am not familiar with it, so I don't know what do you do in openbox
to start programs, but you need to start a terminal emulator and
arrange for a shell to be run within that emulator. This is normally
done automatically, but clearly in your case something is choking up.
I don't know what terminal emulators are available on your system, but
you need something like xterm, gtkterm or lxterm. Perhaps
https://bbs.archlinux.org/viewtopic.php?id=155127 has some advice that
you could use.

Now as Przemek suggested, I included the command 'xrandr' in ~/.xinitrc,
before ./simpleQt (name of my simple Qt application).

But the execution of this command is observed in either desktop display or
display connected to BBB.

See above---the execution of your xrandr outputs the information about
your screen.

Hi Przemek,

Now I am getting the response for xrandr command.

What I need to do is call the command xrandr, after my simpleQt program, but before the calling of X window manager.

So the contents in the .xinitrc should be as follows.

#!/bin/bash
oclock -geometry +1450+920 -bg ivory -fg blue &
./simpleQt &
xrandr
xrandr --output HDMI-0 --mode 800x600 --rate 60
exec /etc/alternatives/x-window-manager

I think earlier I was calling xrandr before simpleQt. I don’t remember correctly. Anyway it is coming now.

The following comments in your earlier post helped me.

"How are you running your qt program? Run xrandr in exactly the same
way; it should work. "

Thank You.

Now I am facing another problem.
I am using a video capture program and instead of simpleQt, now I am placing video capture program in .xinitrc as shown below.

#!/bin/bash
oclock -geometry +1450+920 -bg ivory -fg blue &
./video_capture &
xrandr
xrandr --output HDMI-0 --mode 800x600 --rate 60
exec /etc/alternatives/x-window-manager

Video is displayed nicely. But there is one issue.

A bottle with orange cap is appeared as one with blue cap. That means color displayed is not correct.

This is true for Image capture also. An image which is displayed with original color in debian image viewer is displayed with wrong color, when I am displaying in this way.

I don’t think it is because of the programs that we used here. A frame which is captured with a program is showing correct color with debian image viewer, but with different color, when I am displaying with startx in BBB.

Please provide some hints, where should I work on this issue?

Thanks in advance for the help.

Thanks & Regards,
Sajeevan.K

Sorry, I just don't know this area. In general, I'd try to isolate the
problem---I think you started doing this anyway, by moving the
captured images to an external host (I think that's what you mean by
viewing the image with 'debian image viewer'). This would mean that
the image is captured correctly, so the wrong display must happen when
you display it on BBB; does it happen only for the captured images, or
for all images? Keep trying to find the specific case for which you
have the problem. Sorry I can't be of more help.


|

Auto Generated Inline Image 1.png



Mar 8
|

  • | - |

Hi Przemek,

Thank you for the reply. I will ask this in a new post.

Thank You for the help.

Sajeevan.K